errors should go to stderr, not stdout

Bug #1353580 reported by Dimitri John Ledkov on 2014-08-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dmidecode (Ubuntu)
Medium
Dimitri John Ledkov
Precise
Medium
Unassigned
Trusty
Medium
Unassigned
Utopic
Medium
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

2012 is calling, it wants non-broken future-proof dmidecode that doesn't print two line comment block to stdout and thus killing ubiquity =)

thanks, bye.

Related branches

Changed in dmidecode (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in dmidecode (Ubuntu Trusty):
status: New → Confirmed
Changed in dmidecode (Ubuntu Precise):
status: New → Confirmed
Changed in dmidecode (Ubuntu Trusty):
assignee: nobody → Dimitri John Ledkov (xnox)
importance: Undecided → Medium
Changed in dmidecode (Ubuntu Precise):
importance: Undecided → Medium
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in ubiquity (Ubuntu Precise):
status: New → Won't Fix
Changed in ubiquity (Ubuntu Utopic):
status: New → Won't Fix
Changed in ubiquity (Ubuntu Trusty):
status: New → Won't Fix
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.2

---------------
ubiquity (2.21.2) vivid; urgency=medium

  [ Dimitri John Ledkov ]
  * Add --quiet option to dmidecode calls, in the future release that will
    prevent dmidecode from printing error banner if a newer than dmidecode
    smbios version has happened to be in use. LP: #1353580.
  * Add "support" for Gauja laptops and self-builts - that is do not use
    "To be filled by O.E.M." as a valid model name.
  * Remove setting translated placeholder text in the usersetup
    plugin. (LP: #1283047)
  * Drop translation messages from ubiquity.templates.

  [ Unit 193 ]
  * Enable the ubiquity panel in xfwm4 now since it is functional.

  [ Tim Lunn ]
  * scripts/plugininstall.py: Remove obsolete code to generate wallpaper
    cache, unity-settings-daemon/gnome-settings-daemon now run in install
    mode (LP: #1318621)

  [ Martin Wimpress ]
  * Improve support for Mate desktop.

  [ Shih-Yuan Lee (FourDollars) ]
  * Fix the usage of effective uid/gid and the HOME environment variable.

  [ Dimitri John Ledkov ]
  * Automatic update of included source packages: clock-setup
    0.121ubuntu1, console-setup 1.70ubuntu11, partman-basicfilesystems
    108ubuntu1, partman-crypto 78ubuntu1, partman-jfs 45, partman-lvm
    102, partman-xfs 55.
 -- Dimitri John Ledkov <email address hidden> Sun, 21 Dec 2014 06:46:46 +0000

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
Changed in dmidecode (Ubuntu):
status: Confirmed → Fix Released
Changed in dmidecode (Ubuntu Precise):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in dmidecode (Ubuntu Trusty):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in dmidecode (Ubuntu Utopic):
assignee: Dimitri John Ledkov (xnox) → nobody
Rolf Leggewie (r0lf) wrote :

utopic has seen the end of its life and is no longer receiving any updates. Marking the utopic task for this ticket as "Won't Fix".

Changed in dmidecode (Ubuntu Utopic):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers