Add the full IPP Everywhere support from Utopic to Trusty

Bug #1386241 reported by Till Kamppeter on 2014-10-27
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
cups-filters (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
system-config-printer (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

This is a hardware enablement SRU for Ubuntu 14.04 LTS (Trusty).

From 14.10 (Utopic) on Ubuntu has full support for IPP Everywhere printing:

1. Printing on IPP Everywhere printers

2. Printing on IPP-over-USB printers

3. When sharing a printer to the network the shared print queue emulates an IPP Everywhere printer

4. PPD-less printing on IPP network printers (IPP Everywhere, PDF, PostScript, PCL) without need of a printer setup tool

14.04 *Trusty), the current LTS, supports only (4). An OEM asked whether we could backport the full IPP Everywhere support to Trusty.

This bug report is about the backport of IPP Everywhere support into Trusty as an SRU.

Affected are the source packages cups-filters, cups, and system-config-printer:

cups-filters:

    - Add ippusbxd (Support for IPP-over-USB printers), generating the new binary package cups-filters-ippusbxd. Its installation in Trusty will be assured by a dependency on it in system-config-printer-udev
    - Add rastertopdf filter. This filter allows PWG Raster as input format for a CUPS queue. This is needed to make shared CUPS printers fully emulating IPP Everywhere printers (all other requirements are fulfilled by CUPS itself).
    - Add conversion rule for rastertopdf filter to the MIME conversion rules.
    - Add PPD file for a generic IPP Everywhere printer (on-the-fly auto-generation by cupsfilters.drv).
    - Support for PWG-Raster output activation via a keyword in the PPD file.
    - pdftoraster filter: Support for output in the color spaces 18 (sGray), 19 (sRGB), and 20 (Adobe RGB). No color management appropriate to these color spaces is added yet.

system-config-printer:

    - Add auto-setup for UDEV-discovered IPP-over-USB printers using ippusbxd.

cups:

    - Fix priority setting of PWG Raster MIME type, so that PWG Raster input is actually recognized.

[Impact]

Trusty has a total support life of 5 years, ending in April 2019, but it does not support the new PWG standard IPP Everywhere for driverless printing. So in the near future many new printer models which can get easily supported under Linux as they are fulfilling an open standard are not supported by Trusty. This is especially very bad for Trusty being used as pre-installed OS on new PC/notebook/server hardware and on mobile devices.

[Test Case]

1. Connect an IPP Everywhere printer to the network and try to set it up. There is no suitable selection in the Make/Model lists (no "Generic IPP Everywhere Printer").
2. Connect an IPP-over-USB printer to the USB. It gets set up automatically but with the conventional USB interface, not giving access to the printer's configuration web interface and other network-printer-typical features.
3. Share a local print queue on your box and try to access this queue with a mobile device which supports printing on IPP Everywhere printers. The printer will not be found or be found based on older mobile printing protocols.

After installing this SRU (all three packages) all this will work.

[Regression Potential]

Most changes are addition of new code files and new conversion rules, there are only a few simple changes in existing code files so the risk of regressions is very low.

Changed in cups (Ubuntu):
importance: Undecided → High
Changed in system-config-printer (Ubuntu):
importance: Undecided → High
Changed in cups (Ubuntu Trusty):
importance: Undecided → High
Changed in cups-filters (Ubuntu Trusty):
importance: Undecided → High
Changed in system-config-printer (Ubuntu Trusty):
importance: Undecided → High
Changed in cups (Ubuntu):
status: New → Fix Released
Changed in cups-filters (Ubuntu):
status: New → Fix Released
Changed in system-config-printer (Ubuntu):
status: New → Fix Released
Changed in cups-filters (Ubuntu Trusty):
milestone: none → trusty-updates
Changed in cups-filters (Ubuntu):
milestone: trusty-updates → none
Changed in cups (Ubuntu Trusty):
milestone: none → trusty-updates
Changed in system-config-printer (Ubuntu Trusty):
milestone: none → trusty-updates
Changed in cups (Ubuntu Trusty):
status: New → Triaged
Changed in cups-filters (Ubuntu Trusty):
status: New → Triaged
Changed in system-config-printer (Ubuntu Trusty):
status: New → Triaged
Till Kamppeter (till-kamppeter) wrote :

Uploaded fixed versions of the cups-filters, system-config-printer, and cups packages to trusty-proposed now. As soon as they get approved they get available for installation and instructions for installing them get posted here. Please update all the packages and test the IPP Everywhere support. Report your results here as this is required for the update getting into the official updates or Trusty.

Till Kamppeter (till-kamppeter) wrote :

For the SRU team: debdiff for cups-filters

Till Kamppeter (till-kamppeter) wrote :

For the SRU team: debdiff for system-config-printer

Till Kamppeter (till-kamppeter) wrote :

For the SRU team: debdiff for cups

Till Kamppeter (till-kamppeter) wrote :

Daniel, I am very grateful if you could test the IPP-over-USB support with these updates on a Trusty system and with your IPP-over-USB printer.

You can already start testing before SRU -proposed approval by applying the three debdiffs.

Till Kamppeter (till-kamppeter) wrote :

Note for everyone who wants to test and for the SRU team. The SRU works only by updating all three packages, especially the binary package system-config-printer-udev needs the new cups-filters-ippusbxd package now.

Changed in cups (Ubuntu Trusty):
status: Triaged → In Progress
Changed in cups-filters (Ubuntu Trusty):
status: Triaged → In Progress
Changed in system-config-printer (Ubuntu Trusty):
status: Triaged → In Progress

Hello Till, or anyone else affected,

Accepted system-config-printer into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/system-config-printer/1.4.3+20140219-0ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in system-config-printer (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in cups (Ubuntu Trusty):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Till, or anyone else affected,

Accepted cups into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cups/1.7.2-0ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cups-filters (Ubuntu Trusty):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Till, or anyone else affected,

Accepted cups-filters into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cups-filters/1.0.52-0ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Daniel, can you test whether all is working correctly with IPP-over-USB on both Utopic and Trusty?

Download full text (5.3 KiB)

Hello Till

I'm still testing but something appears wrong. When I plug the printer
in I get "Missing sysattr idVendor" in the syslog. Which means the
device path udev-configure-printer is trying to find the vendor,
product ids, and serial number from, is not the device's root.

udev-configure-printer is reporting the device as
/devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.1 which is not the
device's root but instead the path to one of the device's interfaces.
But the patch I included should be navigating up the tree to the
device's root. This is one of the existing bugs I tried to fix that
occured before I made my patch. If I unplug and plug the printer into
a different usb port it correctly finds the vendor id.

This second time when it worked the path was:
/devices/pci0000:00/0000:00:14.0/usb3/3-10/3-10:1.1

I've even removed the ippusbxd binary from /usr/sbin so it is oing
through ippusb scanning. Which means, at least for this printer,
something more fundamental is broken.

Sorry, I do not had much time to work on printer stuff so I'm slowly
testing the patches.

Daniel

2014-11-07 7:48 GMT+09:00 Till Kamppeter <email address hidden>:
> Daniel, can you test whether all is working correctly with IPP-over-USB
> on both Utopic and Trusty?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1386241
>
> Title:
> Add the full IPP Everywhere support from Utopic to Trusty
>
> Status in “cups” package in Ubuntu:
> Fix Released
> Status in “cups-filters” package in Ubuntu:
> Fix Released
> Status in “system-config-printer” package in Ubuntu:
> Fix Released
> Status in “cups” source package in Trusty:
> Fix Committed
> Status in “cups-filters” source package in Trusty:
> Fix Committed
> Status in “system-config-printer” source package in Trusty:
> Fix Committed
>
> Bug description:
> This is a hardware enablement SRU for Ubuntu 14.04 LTS (Trusty).
>
> From 14.10 (Utopic) on Ubuntu has full support for IPP Everywhere
> printing:
>
> 1. Printing on IPP Everywhere printers
>
> 2. Printing on IPP-over-USB printers
>
> 3. When sharing a printer to the network the shared print queue
> emulates an IPP Everywhere printer
>
> 4. PPD-less printing on IPP network printers (IPP Everywhere, PDF,
> PostScript, PCL) without need of a printer setup tool
>
> 14.04 *Trusty), the current LTS, supports only (4). An OEM asked
> whether we could backport the full IPP Everywhere support to Trusty.
>
> This bug report is about the backport of IPP Everywhere support into
> Trusty as an SRU.
>
> Affected are the source packages cups-filters, cups, and system-
> config-printer:
>
> cups-filters:
>
> - Add ippusbxd (Support for IPP-over-USB printers), generating the new binary package cups-filters-ippusbxd. Its installation in Trusty will be assured by a dependency on it in system-config-printer-udev
> - Add rastertopdf filter. This filter allows PWG Raster as input format for a CUPS queue. This is needed to make shared CUPS printers fully emulating IPP Everywhere printers (all other requirements are fulfilled by CUPS itself).
> - A...

Read more...

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of cups from trusty-proposed was performed and bug 1390724 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1390724 "bot-stop-nagging". Thanks!

tags: added: verification-failed

Bug 1390724 is a bug in CUPS. The only change on the CUPS package for this SRU is a fix for a MIME type recognition rule, which cannot cause a bug like bug 1390724. Therefore removing the "verification-failed" tag and tagging bug 1390724 with "bot-stop-nagging".

tags: removed: verification-failed

SRU team, I would like to temporarily withdraw this SRU, as it still needs some fixing to be worked out with printer manufacturers and in the time being I would like to get another SRU into the updates, to fix bug 1401835 and bug 1398444 in Trusty. Can you reject/discard the package currently in trusty-proposed so that I can upload the package for the other SRU? Thanks.

tags: added: verification-failed
removed: verification-needed
Steve Langasek (vorlon) wrote :

packages removed from trusty-proposed; resetting bug state.

Changed in cups (Ubuntu Trusty):
status: Fix Committed → Triaged
Changed in system-config-printer (Ubuntu Trusty):
status: Fix Committed → Triaged
Changed in cups-filters (Ubuntu Trusty):
status: Fix Committed → Triaged
tags: removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.4.3+20140219-0ubuntu2.5

---------------
system-config-printer (1.4.3+20140219-0ubuntu2.5) trusty-proposed; urgency=medium

  * debian/patches/35_ipp-over-usb-support.patch: Removed, IPP-over-USB support
    was not yet intended with this SRU.
  * debian/control: Removed dependency on cups-filters-ippusbxd package
    (LP: #1409263).
 -- Till Kamppeter <email address hidden> Sat, 10 Jan 2014 17:19:26 +0100

Changed in system-config-printer (Ubuntu Trusty):
status: Triaged → Fix Released
Brian Murray (brian-murray) wrote :

The Launchpad Janitor is confused and this was not fixed.

Changed in system-config-printer (Ubuntu Trusty):
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers