14e4:4727 [Asus 1225B] BCM4313 not working with D-Link DIR-645 AP

Bug #1289746 reported by LennartP on 2014-03-08
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Medium
Unassigned
Trusty
High
Unassigned

Bug Description

[Impact]
Users of Ubuntu 14.04 with bcmwl are unable to utilize WiFi with the D-Link DIR-645 AP (AccessPoint). They are able to connect to the AP using WPA2-PSK and obtain an IP address from the AP, but no IP unicast packets are ever received. Thus, WiFi is for all practical purposes not working for this combination of Ubuntu software and AP.

While this is happening, devices using other software (e.g. Android) are able to utilize WiFi with the same AP without problems.

The bug can also be reproduced using the ASUS WL-330N AP. There may be other APs with which the bug can also be reproduced.

The bug was not present in Ubuntu 12.04. It is fixed in Ubuntu Vivid Vervet.

The bug should be back-ported to Ubuntu 14.04 because WiFi is a fundamental function for laptops which has worked in Ubuntu LTS before. Speaking for myself, I am reluctant to move to a development release of Ubuntu such as Vivid because problems are to be expected with applications running on top of Ubuntu, e.g. Virtualbox, in such a release.

[Test Case]
DUT :== Device Under Test, a laptop with Ubuntu 14.04 and bcmwl installed.

1. Ascertain no other network connection (e.g. wired Ethernet) are connected to DUT.

2. Connect DUT to av D-Link DIR-645 or ASUS WL-330N AP using WPA2-PSK.

3. Open a Terminal and do at least one of the following:
3a. Determine the IP address of the default gateway ("destination 0.0.0.0") using netstat -rn and ping the IP-address.
3b. Ping the IP address of some other device connected to the same AP. Optionally, use a protocol analyzer (e.g. WireShark) to observe ping packets being received by the other device from DUT and responses being sent back.

4a. If the buig is fixed, you should see lines like "64 bytes received from <IP-address>" in your terminal. After pressing CTRL+C, ping should report "0% packet loss".
4b. If the bug is not fixed, ping just writes "PING <IP-address> ..." and nothing else happens. After pressing CTRL+C, ping reports "100% packet loss".

[Regression Potential]
Software Regression is unlikely to occur. If it does will most likely manifest itself as Ubuntu 14.04 with bcmwl being unable to utilize WiFi with any AP (of any make and model).

LennartP (lennart-preuss) wrote :

When pinging the machine running broadcom-sta, i don't get an icmp reply, but a valid arp entry. So, it would appear that at the ethernet level, the driver is working.

LennartP (lennart-preuss) wrote :

Using a wireshark in the computer i'm trying to from and the computer i'm pinging, i can see unicast packets reaching the computer i'm trying ping, but the computer running broadcom-sta never sees any unicast response packets directed to it. It does, however, receive multicast packets.

So, it would appear that the problem is with receiving IP unicast packets (since arp is obviously working).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in broadcom-sta (Ubuntu):
status: New → Confirmed
Prakhar Singh (prakharsingh95) wrote :

Any updates on this?

LennartP, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1289746

As well, please include all the information following https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx#Filing_bug_reports .

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in broadcom-sta (Ubuntu):
status: Confirmed → Incomplete

I did as you asked, but all I got was this error message:

"Package broadcom-sta not installed and no hook available, ignoring"

...and a pop-up saying "No additional information collected.

So, what do I do now?

On Wed, Oct 29, 2014 at 8:06 PM, Christopher M. Penalver <
<email address hidden>> wrote:

> LennartP, thank you for taking the time to report this bug and helping to
> make Ubuntu better. Please execute the following command, as it will
> automatically gather debugging information, in a terminal:
> apport-collect 1289746
>
> As well, please include all the information following
>
> https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx#Filing_bug_reports
> .
>
> When reporting bugs in the future please use apport by using 'ubuntu-
> bug' and the name of the package affected. You can learn more about this
> functionality at https://wiki.ubuntu.com/ReportingBugs.
>
> ** Changed in: broadcom-sta (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1289746
>
> Title:
> BCM4313 not working with some wireless AP
>
> Status in “broadcom-sta” package in Ubuntu:
> Incomplete
>
> Bug description:
> 1) lsb_release -rd
> Description: Ubuntu Trusty Tahr (development branch)
> Release: 14.04
>
> N.B: The same problem existed in 13.10 with this computer about a
> month ago.
>
> 2) From software center: broadcom-sta-source 6.30.223.141-1.
>
> 3) What i expected to happen: Once the driver connects to my AP at
> home, i expect it to forward IP-packets between the AP and my
> computer.
>
> 4) What happened instead: Almost nothing. There is a valid ARP entry
> for the AP in the ARP cache, but there are no replies from ping.
>
> The AP is a DLINK DIR-645. I've got two Android devices of different
> versions using the AP w/o problems, so the AP is not broken. The
> driver works with an AP from Huawei. This computer has been able to
> use the AP w/o problems running 12.04 until abount six months ago,
> when no longer connect to it.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/broadcom-sta/+bug/1289746/+subscriptions
>

--
Mr Lennart Preuss
Trillans Väg 43
131 49 NACKA
Sweden
<email address hidden>
+46 8 718 04 03 (fax)
+46 73 0300 280 (cellular)

LennartP (lennart-preuss) wrote :

1) See below:
lennart@slim2a:~$ ubuntu-bug bcmwl-kernel-source
lennart@slim2a:~$ lspci -vvnn | grep -A 9 Network
04:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
 Subsystem: AzureWave Device [1a3b:2047]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 17
 Region 0: Memory at fea00000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: wl

lennart@slim2a:~$ lsb_release -rd
Description: Ubuntu 14.04.1 LTS
Release: 14.04
lennart@slim2a:~$ uname -a
Linux slim2a 3.13.0-39-generic #66-Ubuntu SMP Tue Oct 28 13:30:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
lennart@slim2a:~$ apt-cache policy bcmwl-kernel-source
bcmwl-kernel-source:
  Installed: 6.30.223.141+bdcom-0ubuntu2
  Candidate: 6.30.223.141+bdcom-0ubuntu2
  Version table:
 *** 6.30.223.141+bdcom-0ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/restricted amd64 Packages
        100 /var/lib/dpkg/status
lennart@slim2a:~$ apt-cache policy broadcom-sta-source
broadcom-sta-source:
  Installed: 6.30.223.141-1
  Candidate: 6.30.223.141-1
  Version table:
 *** 6.30.223.141-1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/multiverse amd64 Packages
        100 /var/lib/dpkg/status
lennart@slim2a:~$ sudo dmidecode -s bios-version
[sudo] password for lennart:
209
lennart@slim2a:~$ sudo dmidecode -s bios-release-date
06/05/2012
lennart@slim2a:~$ sudo dmidecode -s baseboard-manufacturer
ASUSTeK Computer Inc.
lennart@slim2a:~$

2) Asus 1225B-SIV047M

3) Yes, in ubuntu 13.10.

4) Yes.

5) No, last time I checked, "the relevant open source driver" did not support my particular WiFi chip.

tags: added: amd64 latest-bios-209 saucy trusty
description: updated

LennartP, thank you for providing the requested information. Just to clarify:
+ When you are having this issue, do you have both bcmwl-kernel-source and broadcom-sta-source installed simultaneously?
+ What is the firmware version of your DLINK DIR-645?
+ If the firmware version is older than 1.04.B11, could you please upgrade to this via support.dlink.com/ProductInfo.aspx?m=DIR-645 and advise to the results?

summary: - BCM4313 not working with some wireless AP
+ 14e4:4727 [Asus 1225B] BCM4313 not working with D-Link DIR-645 AP
Changed in broadcom-sta (Ubuntu):
importance: Undecided → Medium
Download full text (3.3 KiB)

Yes, I jave both bcmwl-kernel-source and broadcom-sta-source installed
simultaneously.

I just upgraded to 1.04 B12, and the error is still there.

/Lennart

On Thu, Nov 6, 2014 at 11:20 PM, Christopher M. Penalver <
<email address hidden>> wrote:

> LennartP, thank you for providing the requested information. Just to
> clarify:
> + When you are having this issue, do you have both bcmwl-kernel-source and
> broadcom-sta-source installed simultaneously?
> + What is the firmware version of your DLINK DIR-645?
> + If the firmware version is older than 1.04.B11, could you please upgrade
> to this via support.dlink.com/ProductInfo.aspx?m=DIR-645 and advise to
> the results?
>
> ** Summary changed:
>
> - BCM4313 not working with some wireless AP
> + 14e4:4727 [Asus 1225B] BCM4313 not working with D-Link DIR-645 AP
>
> ** Changed in: broadcom-sta (Ubuntu)
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1289746
>
> Title:
> 14e4:4727 [Asus 1225B] BCM4313 not working with D-Link DIR-645 AP
>
> Status in “broadcom-sta” package in Ubuntu:
> Incomplete
>
> Bug description:
> 1) lsb_release -rd
> Description: Ubuntu 14.04.1 LTS
> Release: 14.04
>
> 2) apt-cache policy broadcom-sta-source
> broadcom-sta-source:
> Installed: 6.30.223.141-1
> Candidate: 6.30.223.141-1
> Version table:
> *** 6.30.223.141-1 0
> 500 http://se.archive.ubuntu.com/ubuntu/ trusty/multiverse
> amd64 Packages
> 100 /var/lib/dpkg/status
>
> 3) What is expected to happen with my Asus 1225B-SIV047M laptop and
> DLINK DIR-645 AP is the WiFi works via the broadcom-sta-source driver.
>
> 4) What happened instead: Almost nothing. There is a valid ARP entry
> for the AP in the ARP cache, but there are no replies from ping. The
> same problem existed in 13.10 with this computer about a month ago.
> However, this computer has been able to use the AP w/o problems
> running 12.04 until about six months ago, when no longer connect to
> it.
>
> I have two Android devices of different versions using the AP w/o
> problems.
>
> However, the driver works with an AP from Huawei.
>
> uname -a
> Linux slim2a 3.13.0-39-generic #66-Ubuntu SMP Tue Oct 28 13:30:27 UTC
> 2014 x86_64 x86_64 x86_64 GNU/Linux
>
> lspci -vvnn | grep -A 9 Network
> 04:00.0 Network controller [0280]: Broadcom Corporation BCM4313
> 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
> Subsystem: AzureWave Device [1a3b:2047]
> Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
> Stepping- SERR- FastB2B- DisINTx-
> Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
> <MAbort- >SERR- <PERR- INTx-
> Latency: 0, Cache Line Size: 64 bytes
> Interrupt: pin A routed to IRQ 17
> Region 0: Memory at fea00000 (64-bit, non-prefetchable) [size=16K]
> Capabilities: <access denied>
> Kernel driver in use: wl
>
> sudo dmidecode -s bios-version
> 209
> sudo dmidecode -s bios-release-date
> 06/05/2012
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.n...

Read more...

description: updated

LennartP, one wouldn't want both installed simultaneously, as they provide different versions of the same driver. Hence, if you uninstall one, and vice versa, does it change anything?

As you may know, the 1.04 B12 is a Beta firmware (this is why I recommended the latest stable version 1.04 B11). As the QA may not be there for a Beta, would you be able to downgrade the firmware to the stable version for a test?

LennartP (lennart-preuss) wrote :

Christopher, I've tried removing broadcom-sta-source, and that didn't change anything, the error persists.

I also tried removing bcmwl-kernel-source and putting back broadcom-sta-source, but that didn't work at all in the sense that there was no option to enable wireless -- But then again, maybe that's the way it's supposed to work.

I did not, however, revert the AP back to 1.04 B11, since the problem was present in that release also.

LennartP, could you please test for this with the latest version of bcmwl (live environment is fine) via http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

LennartP (lennart-preuss) wrote :

YES! That worked.

Any chance of getting whatever that was back-ported to Trusty, or is going for Vivid my best bet?

LennartP (lennart-preuss) wrote :

BTW, i managed to install the latest source from Brodacom (hybrid-v35_64-nodebug-pcoem-6_30_223_248), but that didn't help either, the error persists.

LennartP, thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because as per https://bugs.launchpad.net/ubuntu/+source/broadcom-sta/+bug/1289746/comments/14 the bug has been fixed in the latest development version of Ubuntu - Vivid Vervet.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please perform as much as possible of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

affects: broadcom-sta (Ubuntu) → bcmwl (Ubuntu)
Changed in bcmwl (Ubuntu):
status: Incomplete → Fix Released
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Changed in bcmwl (Ubuntu Trusty):
importance: Undecided → Medium
status: New → Triaged
importance: Medium → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers