jar files do not include OSGi metadata

Bug #894302 reported by James Page on 2011-11-24
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
apache-log4j1.2 (Ubuntu)
High
James Page
Nominated for Precise by Rolf Leggewie
Trusty
High
James Page
axis (Ubuntu)
High
Unassigned
Nominated for Precise by Rolf Leggewie
Trusty
High
Unassigned

Bug Description

apache-log4j1.2 1.2.16-2 introduced OSGi metadata using the bnd package; however this pulls an extensive dependency chain into Ubuntu main so has been dropped from 1.2.16-2ubuntu1.

OSGi metadata should be included in the jar files (but preferably without using bnd).

James Page (james-page) on 2011-11-24
Changed in apache-log4j1.2 (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → James Page (james-page)
Andreas Moog (ampelbein) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi there,

are you still working on this issue? This seems to cause problems in
unrelated packages, for example bug #1270692

Thanks for your time.

 importance High
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.15 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBAgAGBQJS4/g2AAoJEGHzRCZ03mYk5K0P/jRF9f/WtdGzw2Pe1dOpwL5D
fUkMydyrQ56msceoTHg943msXCead0+yop8uKWhU1qY8tGmzquujB6UFLg4Wmak+
p+vgMCnWqWu+Vfcu4JP+EgqfCbVsWaewbPLEjBryLNY++wcuXc6urYi9mxSqOAzq
dvZb5TKuruVgdTHmCKdDhWof4V5XC4Jb35tsyZU7xEyM65nDUgOj3dJtxqGV+1r5
ShfvxqlGyrSb9q8OeSxEGbigbagmZlR/zmCJwxeroMGisD0kjMrKHr142dhsMKrk
mUosW8OXkWVTIfvhAETQtp2rZ5sx0b55ISz4iWCqDtAkm9sheXLMx/V3ka05lm3C
MraR+16jW6bzBuUhhNuvU52WXytiET07Q5TvcDMmyMDK3BbwJDxjs9l+STs4Ac8i
06fTXGZbFNqp2ZdSesuyC+lC98WBbX4VWjmZbNUl0NPXEUWmuyl0RHCamEyEBWbU
82amDxpmJKbSXGWkvaVpvSa4O7fmtZnWC2ixfG2FleasXjUHFBQd8EYetElEjNf0
aLBLROka31TQ+P223qL/tOfwRrMb2+w3sfyuUf9giSp3J7yh64ZbxQtYPwp/QOw4
B8ZIMtWykChxF4+VaBEwQ3cPbTS7fJn+FPwGe9NY3avKa3M7wRcLzJIRoO9frjd0
YeQSNzJ+0H5AQIUEmBAc
=xgEJ
-----END PGP SIGNATURE-----

Changed in apache-log4j1.2 (Ubuntu):
importance: Medium → High
Rolf Leggewie (r0lf) on 2014-03-01
Changed in apache-log4j1.2 (Ubuntu):
milestone: none → ubuntu-14.04-beta-1
James Page (james-page) on 2014-03-03
Changed in apache-log4j1.2 (Ubuntu):
status: Confirmed → In Progress
James Page (james-page) on 2014-03-03
Changed in apache-log4j1.2 (Ubuntu Trusty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apache-log4j1.2 - 1.2.17-4ubuntu2

---------------
apache-log4j1.2 (1.2.17-4ubuntu2) trusty; urgency=medium

  * d/liblog4j1.2.manifest,control,rules: Add OSGi manifest for log4j using
    javahelper (LP: #894302).
 -- James Page <email address hidden> Mon, 03 Mar 2014 10:56:35 +0000

Changed in apache-log4j1.2 (Ubuntu Trusty):
status: Fix Committed → Fix Released
James Page (james-page) on 2014-03-04
summary: - log4j jar files do not include OSGi metadata
+ jar files do not include OSGi metadata
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package axis - 1.4-20ubuntu2

---------------
axis (1.4-20ubuntu2) trusty; urgency=medium

  * d/control,rules,libaxis-java.manifest: Add missing OSGi data to manifests
    for axis jar files using javahelper (LP: #894302).
 -- James Page <email address hidden> Tue, 04 Mar 2014 11:00:06 +0000

Changed in axis (Ubuntu Trusty):
status: New → Fix Released
Ingo Bauersachs (y-ingo) wrote :

The mandatory attribute "Bundle-SymbolicName: log4j" is still missing from the manifest and the fix is therefore incomplete.

Rolf Leggewie (r0lf) wrote :

would be nice to see this fixed in precise, too

Changed in axis (Ubuntu Trusty):
status: Fix Released → Triaged
importance: Undecided → High
Changed in apache-log4j1.2 (Ubuntu Trusty):
status: Fix Released → Triaged
Rolf Leggewie (r0lf) wrote :

apache-log4j1.2 (1.2.17-4ubuntu3) trusty; urgency=medium

  * d/liblog4j1.2.manifest: Add missing Bundle-SymbolicName to manifest.

 -- James Page <email address hidden> Tue, 25 Mar 2014 09:26:51 +0000

Changed in apache-log4j1.2 (Ubuntu Trusty):
status: Triaged → Fix Released
Lars Noodén (larsnooden) wrote :

This is carried over from the tail end of bug 1270692
Jitsi does not install from the Ubuntu repositories on i386. I've downloaded and installed a fresh 5 Apr image from here:

http://iso.qa.ubuntu.com/qatracker/milestones/308/builds/66090/testcases

$ sudo apt-get install jitsi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 jitsi : Depends: default-jre but it is not going to be installed or
                  java6-runtime
E: Unable to correct problems, you have held broken packages.

So it's not possible to verify whether the bug is fixed on i386 or not.

Rolf Leggewie (r0lf) wrote :

Lars, that is a separate issue. Please open a new ticket and feel free to subscribe me to it. In the bug ticket please include the output of "sudo aptitude install default-jre".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers