OSK uses incorrect layout when switching from one numeric field to another

Bug #1227343 reported by Thomi Richards on 2013-09-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-keyboard
Fix Released
Critical
Thomas Moenicke
ubuntu-keyboard (Ubuntu)
Critical
Unassigned
Saucy
Critical
Unassigned

Bug Description

I can make the OSK keyboard use a totally borked layout: buttons are spaced out too far apart, some buttons overlap each other, and we seem to be looking at a very narrow slice of the alphanumeric layout, even though we're focused on a numeric input.

To reproduce, there are a few steps involved:

1) shell in to the device and create a simple HTML file (I use this to get an input field with a numeric input hint):

echo '<html><body><input type="number" /> </body></html>' > foo.html

2) Open the webbrowser-app and navigate to: file:///home/phablet/foo.html

3) Go to the dash home screen, click on the search icon.

4) Change the keyboard to numeric mode

5) Reveal the launcher and switch to the web browser again

6) Focus the input field in the HTMl file you just loaded.

What should happen:

The OSK should appear with the numeric input

What does happen:

The OSK appears, but shows the wrong layout.

See attached Screenshot and video for more details.

Nicholas Skaggs (nskaggs) wrote :

This happens across the board for the OSK, for example in the address book app adding a phone number doesn't show a numeric only keyboard, etc. OSK isn't context aware.

Changed in ubuntu-keyboard:
status: New → Confirmed
tags: added: balloons-20130917.1
Changed in ubuntu-keyboard:
importance: Undecided → Critical
Bill Filler (bfiller) on 2013-09-20
Changed in ubuntu-keyboard:
assignee: nobody → Thomas Moenicke (thomas-moenicke)
Bill Filler (bfiller) wrote :

I could not reproduce using ubuntu-keyboard 0.99.trunk.phablet2+13.10.20130918-0ubuntu1
Please re-open if you are still seeing it with latest

Changed in ubuntu-keyboard (Ubuntu Saucy):
importance: Undecided → Critical
status: New → Fix Committed
Changed in ubuntu-keyboard:
status: Confirmed → Fix Committed
Bill Filler (bfiller) wrote :

@nskaggs
latest address-book-app 0.2+13.10.20130919.3-0ubuntu1 does support correct input hints for different fields so keyboard will change layout depending on field (number, email, url, text, etc)

Bill Filler (bfiller) on 2014-01-24
Changed in ubuntu-keyboard:
status: Fix Committed → Fix Released
Changed in ubuntu-keyboard (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-keyboard (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers