Meta bug for tracking Openstack 2013.2.3 Stable Update

Bug #1302575 reported by Chuck Short on 2014-04-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
ceilometer (Ubuntu)
Saucy
Undecided
Unassigned
cinder (Ubuntu)
Saucy
Undecided
Unassigned
glance (Ubuntu)
Saucy
Undecided
Unassigned
heat (Ubuntu)
Saucy
Undecided
Unassigned
horizon (Ubuntu)
Saucy
Undecided
Unassigned
keystone (Ubuntu)
Saucy
Undecided
Unassigned
neutron (Ubuntu)
Saucy
Undecided
Unassigned
nova (Ubuntu)
Saucy
Undecided
Unassigned

Bug Description

This is a meta-bug used for tracking progress of the 2013.2.13 Havana stable update to Nova, Horizon, Keystone, Cinder, Neutron, Ceilometer, and Heat in Ubuntu 13.10.

Chuck Short (zulcss) on 2014-04-10
description: updated

Hello Chuck, or anyone else affected,

Accepted nova into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nova/1:2013.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nova (Ubuntu Saucy):
status: New → Fix Committed
tags: added: verification-needed
Changed in horizon (Ubuntu Saucy):
status: New → Fix Committed
Dave Walker (davewalker) wrote :

Hello Chuck, or anyone else affected,

Accepted horizon into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/horizon/1:2013.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ceilometer (Ubuntu Saucy):
status: New → Fix Committed
Dave Walker (davewalker) wrote :

Hello Chuck, or anyone else affected,

Accepted ceilometer into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ceilometer/2013.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cinder (Ubuntu Saucy):
status: New → Fix Committed
Dave Walker (davewalker) wrote :

Hello Chuck, or anyone else affected,

Accepted cinder into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cinder/1:2013.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in heat (Ubuntu Saucy):
status: New → Fix Committed
Dave Walker (davewalker) wrote :

Hello Chuck, or anyone else affected,

Accepted heat into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/heat/2013.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dave Walker (davewalker) wrote :

Hello Chuck, or anyone else affected,

Accepted glance into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/glance/1:2013.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in glance (Ubuntu Saucy):
status: New → Fix Committed
Changed in keystone (Ubuntu Saucy):
status: New → Fix Committed
Dave Walker (davewalker) wrote :

Hello Chuck, or anyone else affected,

Accepted keystone into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/keystone/1:2013.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chuck Short (zulcss) on 2014-04-24
tags: added: verification-done
removed: verification-needed
Dave Walker (davewalker) wrote :

Chuck, Please can you comment and link to the test results please?

Thanks.

James Page (james-page) wrote :

Tests from the lab:

Cinder iSCSI: https://jenkins.qa.ubuntu.com/view/All/job/test_tempest_smoke/477/
Cinder Ceph: https://jenkins.qa.ubuntu.com/view/All/job/test_tempest_smoke/476/
Neutron: https://jenkins.qa.ubuntu.com/view/All/job/test_quantum/117/

Note that the two tempest smoke tests have a single failure each - this is due to the fact that we don't currently include heat in lab testing and tempest does not handle this that elegantly.

Changed in cloud-archive:
status: New → Fix Committed
Chris J Arges (arges) wrote :

Changed neutron to fix committed. The bug# in the changelog is incorrect, but will be fixed retroactively in a future upload.

Changed in neutron (Ubuntu Saucy):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 1:2013.2.3-0ubuntu1

---------------
nova (1:2013.2.3-0ubuntu1) saucy-proposed; urgency=medium

  * Resynchronize with stable/havana (feedcb2) (LP: #1302575):
    - [feedcb2] Fix 'icehouse-compat' processing for compute rpc
    - [ecb058d] User a more accurate max_delay for reconnects
    - [bdc7519] Pass thru credentials to allow re-authentication
    - [25e761a] Persist image format to a file, to prevent attacks based on changing it
    - [53acc09] Do not hide exception in update_instance_cache_with_nw_info
    - [f44bdfe] handle empty network info in instance cache
    - [00d1882] VMware: enable driver to work with postgres database
    - [44c60c6] Grizzly to Havana Upgrade wipes out Nova quota_usages
    - [2edf6ff] VMware: fix the VNC port allocation
    - [4ac67d1] neutron_metadata_proxy_shared_secret should not be written to log file
    - [590519a] Correct the state for PAUSED instances on reboot
    - [d50fad8] VMWare: bug fix for Vim exception handling
    - [c87a88f] Fix InstanceNotFound error in _delete_instance_files
    - [374ff97] Fixed a problem in iSCSI multipath
    - [5661055] VMware: fix bug for exceptions thrown in _wait_for_task
    - [aa7f550] VMware: fix image snapshot with attached volume
    - [06dd47f] Explicity teardown on error in libguestfs setup()
    - [985b5aa] VMware: fix disk extend bug when no space on datastore
    - [03f7ee0] Further harden boto version checking in EC2 tests
    - [88da098] Take a vm out of SNAPSHOTTING after Glance error
    - [6564525] Enable compute_node_update to tolerate deadlocks
    - [9520b8d] VMware: Always upload a snapshot as a preallocated disk
    - [d3c8757] Remove unneeded call to conductor in network interface
    - [b047eaa] Remove reduntant call to update_instance_info_cache
    - [3f72ffb] Fix changes-since filter for list-servers API
    - [b09ccd5] Don't raise MySQL 2013 'Lost connection' errors
    - [2bb8ce8] Add db2 communication error code when check the db connection
    - [1c7ff2a] hyperv: Retry after WMI query fails to find dev
    - [0d3d7c9] Retry reservation commit and rollback on deadlock
    - [e095dab] Make rbd.libvirt_info parent class compatible
    - [83926a0] libvirt: handle exception while get vcpu info
    - [b508376] Use block_device_info at post_live_migration_at_destination
    - [e52d4fa] Ensure MTU is set when the OVS vif driver is used
    - [d4056f8] Add RBAC policy for ec2 API security groups calls
  * debian/patches/fix-boto-versioning.patch: Dropped no longer needed.
 -- Chuck Short <email address hidden> Fri, 04 Apr 2014 10:00:12 -0400

Changed in nova (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heat - 2013.2.3-0ubuntu1

---------------
heat (2013.2.3-0ubuntu1) saucy-proposed; urgency=medium

  * Resynchronize with stable/havana (8bb7830) (LP: #1302575):
    - [527009d] Don't delete trust on backup stack delete
    - [defcf23] Raise the default max header to accommodate large tokens
    - [a440ccb] Fix "members" property check
    - [cfd6b02] Fix incompatibilities in tests with keystoneclient 0.6
    - [8bb7830] Don't raise MySQL 2013 'Lost connection' errors
 -- Corey Bryant <email address hidden> Fri, 04 Apr 2014 10:49:12 -0400

Changed in heat (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 2013.2.3-0ubuntu1

---------------
ceilometer (2013.2.3-0ubuntu1) saucy-proposed; urgency=medium

  * debian/patches/fix-setup-requirements.patch: Rebase on top of
    new upstream requirements.txt file.
  * Resynchronize with stable/havana (0ac6942) (LP: #1302575):
    - [c92c106] latest alembic imcompatible with current sqlalchemy requirements
    - [4ffeead] User a more accurate max_delay for reconnects
    - [6637acd] Checks for presence of Hyper-V cpu metrics before accessing
    - [7cb5f4c] Fix ceilometer.conf.sample mismatch
    - [ebe72d5] Fixes Hyper-V Inspector disk metrics bug
    - [bbab3d5] Fix validation error for invalid field name in simple query
    - [83a2725] Adds doc string to query validate functions in V2 API
    - [4461828] Ensure insecure config option propagated by alarm service
    - [0a1db09] Fix the default rpc policy value
    - [b13ee97] Ensure the correct error message is displayed
    - [2c6a84f] Refactor timestamp existence validation in V2 API
    - [ff0375c] cacert is not picked up correctly by alarm services
    - [0a85f22] Add an insecure option for Keystone client
    - [0ac6942] Propogate cacert and insecure flags to glanceclient
 -- Corey Bryant <email address hidden> Fri, 04 Apr 2014 12:02:50 -0400

Changed in ceilometer (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 1:2013.2.3-0ubuntu1

---------------
horizon (1:2013.2.3-0ubuntu1) saucy-proposed; urgency=medium

  * Resynchronize with stable/havana (82cb9f6) (LP: #1302575):
    - [b2259b3] Don't copy the flavorid when updating flavors
    - [8db4687] Allow snapshots of paused and suspended instances
    - [cf181c1] Reduce number of novaclient calls
    - [82cb9f6] Fixing tests to work with keystoneclient 0.6.0
 -- Corey Bryant <email address hidden> Fri, 04 Apr 2014 10:52:55 -0400

Changed in horizon (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 1:2013.2.3-0ubuntu1

---------------
cinder (1:2013.2.3-0ubuntu1) saucy-proposed; urgency=medium

  * Resynchronize with stable/havana (c5cdf82) (LP: #1302575):
    - [c5cdf82] User a more accurate max_delay for reconnects
    - [62d4e54] VMware: Fixed upload-to-image for available volume
    - [9ff2f90] Cast the quota set values to integer before checking their validity
    - [5b9fc5c] Raise max header size to accommodate large tokens
    - [78d7e7a] Ensures NetApp iSCSI driver correctly compares int values for size
    - [d043874] Don't raise MySQL 2013 'Lost connection' errors
    - [41f043a] Add db2 communication error code when check the db connection
    - [ed41b68] Update quota-set throw 500 error
    - [42e2805] Delete volume transfer in volume_destroy function
    - [24a1bd8] Catch ImageBusy exception when deleting rbd volume
    - [69e687d] GlusterFS: Fix deadlock in volume clone
    - [e0dca03] GlusterFS: Synchronize additional operations
    - [018ece5] Fix volume transfer href issue
    - [924a901] Support volume_readonly_update using XML format
    - [e8aeb57] Hiding postgresql password in connection string
    - [07892b1] Add valid check and unit tests on quota class
    - [472cf25] NetApp fix for vsadmin role failure for ssc
 -- Chuck Short <email address hidden> Fri, 04 Apr 2014 11:25:01 -0400

Changed in cinder (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glance - 1:2013.2.3-0ubuntu1

---------------
glance (1:2013.2.3-0ubuntu1) saucy-proposed; urgency=medium

  * Resynchronize with stable/havana (1690a73) (LP: #1302575):
    - [1690a73] Raise max header size to accommodate large tokens
    - [19b8fbb] Prevent E500 when delayed delete is enabled
    - [33d1840] Glance image-list failed when image number exceed DEFAULT_PAGE_SIZE
    - [13069a4] To prevent remote code injection on Sheepdog store
  * debian/patches/revert-stable-havana-requirements.patch: Refreshed.
 -- Chuck Short <email address hidden> Fri, 04 Apr 2014 10:09:55 -0400

Changed in glance (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 1:2013.2.3-0ubuntu1

---------------
keystone (1:2013.2.3-0ubuntu1) saucy-proposed; urgency=medium

  * Resynchronize with stable/havana (b85a531) (LP: #1302575):
    - [a96d1a4] User a more accurate max_delay for reconnects
    - [a120f25] Fix issue deleting ec2-credentials as non-admin user
    - [181c3c1] SQLAlchemy Change to support more strict dialect checking
    - [b6f0e26] Ensure tokens are added to both Trustor and Trustee indexes
    - [b85a531] Fix list_projects_for_endpoint failed bug
 -- Corey Bryant <email address hidden> Fri, 04 Apr 2014 10:58:26 -0400

Changed in keystone (Ubuntu Saucy):
status: Fix Committed → Fix Released
Chris J Arges (arges) wrote :

This bug was fixed in the package neutron - 1:2013.2.3-0ubuntu1

---------------
neutron (1:2013.2.3-0ubuntu1) saucy-proposed; urgency=medium

  * Resynchronize with stable/havana (8cb9d89) (LP: #1284643):
    - [8cb9d89] Use a temp dir for CONF.state_path
    - [566321b] Subnets should be set as lazy='join'
    - [eb4c045] Qpid, RabbitMQ: advance thru the list of brokers on reconnect
    - [1faec83] Prevent cross plugging router ports from other tenants
    - [858ec2e] Fixes Hyper-V port metrics enabling after service restart
    - [d57ce79] Adds Hyper-V utils methods
    - [5ccfeae] NSX: Sync do not pass around model object
    - [7f2c41f] NSX: Fix possible deadlock in sync code
    - [7871486] Use a more accurate max_delay for reconnects
    - [8e92741] Adds id in update_floatingip API in PLUMgrid plugin driver
    - [ab46900] Report proper error message in PLUMgrid Plugin
    - [ece27c9] Update help message of flag 'enable_isolated_metadata'
    - [a47fde6] Remove the warning for Scheduling Network
    - [28ee2ac] vshield task manager: abort tasks in stop() on termination
    - [c194262] Fix request timeout errors during calls to NSX controller
    - [2b4cdcd] Fix error while connecting to busy NSX L2 Gateway
    - [5158744] Tweak version nvp/nsx version validation logic for router operations
    - [722746f] [ML2] l2-pop MD handle multi create/delete ports
    - [99339a9] Fix metering iptables driver doesn't read root_helper param
    - [2e9f5a7] Add support for managing async processes
    - [5678fb8] fix --excluded of meter-label-rule-create is not working
    - [c0586c4] Fix a typo in log exception in the metering agent
  * debian/patches/bump-sqlalchemy-versions.patch: Rediffed
  * debian/patches/revert-stable-havana-requirements.patch: Updated not to
    bump the version of python-neutronclient.
 -- Chuck Short <email address hidden> Mon, 31 Mar 2014 11:51:57 -0400

Changed in neutron (Ubuntu Saucy):
status: Fix Committed → Fix Released
James Page (james-page) on 2014-08-01
no longer affects: nova (Ubuntu)
no longer affects: neutron (Ubuntu)
no longer affects: keystone (Ubuntu)
no longer affects: horizon (Ubuntu)
no longer affects: heat (Ubuntu)
no longer affects: glance (Ubuntu)
no longer affects: cinder (Ubuntu)
no longer affects: ceilometer (Ubuntu)
James Page (james-page) on 2015-03-24
Changed in cloud-archive:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers