Please enable CONFIG_EARLY_PRINTK_DBGP

Bug #1026761 reported by Steve Langasek on 2012-07-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Quantal
Medium
Tim Gardner

Bug Description

CONFIG_EARLY_PRINTK_DBGP is currently disabled in the Ubuntu kernel configs. This would be useful to have enabled for debugging early-boot problems with a USB debugging cable.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-4-generic 3.5.0-4.4
ProcVersionSignature: Ubuntu 3.5.0-4.4-generic 3.5.0-rc6
Uname: Linux 3.5.0-4-generic x86_64
AcpiTables: Error: command ['gksu', '-D', 'Apport', '--', 'env', '-u', 'LANGUAGE', 'LC_MESSAGES=C', '/usr/share/apport/dump_acpi_tables.py'] failed with exit code -11:
ApportVersion: 2.3-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: vorlon 30476 F.... pulseaudio
CheckboxSubmission: 017452a27eca3c8b498abbfa5ef91db9
CheckboxSystem: ecaaad6fa1e0799a0aa1126bf620f39e
Date: Thu Jul 19 12:03:27 2012
HibernationDevice: RESUME=UUID=f6ab3c43-61b4-4af7-bf03-fa3b147a1de0
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MachineType: LENOVO 3249CTO
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-4-generic root=/dev/mapper/hostname-root ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-4-generic N/A
 linux-backports-modules-3.5.0-4-generic N/A
 linux-firmware 1.84
SourcePackage: linux
UpgradeStatus: Upgraded to quantal on 2012-06-11 (38 days ago)
WifiSyslog:

dmi.bios.date: 08/23/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET52WW (1.22 )
dmi.board.name: 3249CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET52WW(1.22):bd08/23/2010:svnLENOVO:pn3249CTO:pvrThinkPadX201:rvnLENOVO:rn3249CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3249CTO
dmi.product.version: ThinkPad X201
dmi.sys.vendor: LENOVO

Steve Langasek (vorlon) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Tim Gardner (timg-tpi) on 2012-07-20
Changed in linux (Ubuntu Quantal):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Tim Gardner (timg-tpi) wrote :

Steve - After looking at the code and reading the Kconfig blurb I don't think this is a very good idea.

"This is useful for kernel debugging when your machine crashes very early before the console code is initialized. For normal operation it is not recommended because it looks ugly and doesn't cooperate with klogd/syslogd or the X server. You should normally N here, unless you want to debug such a crash. You need usb debug device."

I'd rather not break klogd/syslogd. We could certainly build a test kernel to help you debug the UEFI boot sequence.

Changed in linux (Ubuntu Quantal):
status: In Progress → Won't Fix
Changed in linux (Ubuntu):
status: In Progress → Won't Fix
Steve Langasek (vorlon) wrote :

Tim,

> I'd rather not break klogd/syslogd. We could certainly
> build a test kernel to help you debug the UEFI boot sequence.

The ugliness only applies if you pass an additional earlyprintk=dbgp commandline option to the kernel. Otherwise, there's just one additional kernel message - via the usual interface - and no other impact. It would be very useful to have this included in the stock kernel rather than in a separate debugging kernel, so that our daily images are debuggable out of the box. Please reconsider enabling this.

(FWIW, Matthew Garrett says that they've had this enabled for years in Red Hat too)

Changed in linux (Ubuntu Quantal):
status: Won't Fix → Triaged
Tim Gardner (timg-tpi) wrote :

Ah, I missed the line in Documentation/x86/earlyprintk.txt that mentioned the command line parameters.

Changed in linux (Ubuntu Quantal):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package linux - 3.5.0-6.6

---------------
linux (3.5.0-6.6) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * [Config] CONFIG_INET6_XFRM_MODE_ROUTEOPTIMIZATION enable IPv6
    experimental features
  * SAUCE: highbank -- export clock functions for modules
  * [Config] highbank -- reenable CONFIG_TOUCHSCREEN_W90X900
  * [Config] highbank -- renenable CONFIG_SERIO_AMBAKMI
  * [Config] highbank -- reenable CONFIG_RFKILL_GPIO
  * [Config] highbank -- reenable CONFIG_MMC_SDHCI_PXAV3
  * [Config] highbank -- reenable CONFIG_MMC_SDHCI_PXAV3
  * [Config] highbank -- reenable CONFIG_KEYBOARD_SAMSUNG
  * [Config] highbank -- reenable CONFIG_FB_ARMCLCD
  * [Config] highbank -- reenable CONFIG_DW_DMAC
  * [Config] highbank -- reenable CONFIG_USB_R8A66597_HCD
  * [Config] highbank -- reenable CONFIG_USB_MV_UDC
  * [Config] highbank -- reenable CONFIG_USB_DWC3
  * [Config] highbank -- reenable CONFIG_SATA_MV
  * [Config] highbank -- reenable CONFIG_PATA_ARASAN_CF
  * [Config] highbank -- CONFIG_CAN_C_CAN_PLATFORM
  * [Config] highbank -- reenable CONFIG_MMC_ARMMMCI
  * [Config] highbank -- reenable CONFIG_SERIAL_AMBA_PL010
  * [Config] highbank -- reenable CONFIG_ATMEL_PWM
  * [Config] highbank -- enable CONFIG_CHECKPOINT_RESTORE
  * [Config] highbank -- enable CONFIG_EXPERT
  * [Config] highbank -- enable CONFIG_CHECKPOINT_RESTORE
  * [Config] enable CONFIG_USB_DYNAMIC_MINORS
  * [Config] enable CONFIG_USB_EHCI_TT_NEWSCHED
  * [Config] enable CONFIG_USB_ETH_EEM
  * [Config] enable CONFIG_USB_HCD_BCMA/CONFIG_USB_HCD_SSB
  * [Config] disable CONFIG_USB_M66592
  * [Config] enable CONFIG_USB_NET2272
  * [Config] enable CONFIG_USB_R8A66597
  * [Config] annotate: CONFIG_USB_OMAP not required for our h/w
  * [Config] set CONFIG_USB_MUSB_HDRC=m for omap
  * [Config] annotate: CONFIG_USB_G_MULTI fix rule
  * [Config] CONFIG_USB_GPIO_VBUS=m for OMAP
  * [Config] Enable CONFIG_DRM_AST/_CIRRUS_QEMU/_MGAG200
  * [Config] sync configuration armhf omap -> armel omap
  * [Config] annotate: CONFIG_IIO triggers build failures on OMAP4
  * [Config] disable CONFIG_OMAP_IOVMM is deprecated

  [ Bryan Wu ]

  * [Config] change default IO scheduler from CFQ to Deadline

  [ Leann Ogasawara ]

  * Revert "[Config] Temporarily disable CONFIG_MV643XX_ETH on powerpc"
  * [Config] Disable CONFIG_MOUSE_INPORT

  [ Tim Gardner ]

  * SAUCE: firmware: Update bnx2x to current firmware version 7.2.51
  * [Config] Add bnx2x firmware to nic-modules udeb
  * SAUCE: Add script to convert firmware to ihex format
  * SAUCE: firmware: Upgrade bnx2 to current versions
  * [Config] Add tigon firmware to nic-modules udeb
  * [Config] CONFIG_EARLY_PRINTK_DBGP=y
    - LP: #1026761
  * SAUCE: Remove redundant cis firmware
  * SAUCE: Remove redundant emi26 firmware
  * SAUCE: Remove redundant ttusb-budget firmware
  * SAUCE: Remove redundant sun/cassini firmware
  * SAUCE: Remove redundant ositech/Xilinx7OD firmware
  * SAUCE: Remove redundant 3com/typhoon.bin firmware
  * SAUCE: Remove redundant yamaha/ds1 firmware
  * SAUCE: Remove redundant keyspan_pda firmware
  * rebase to v3.5

  [ Upstream Kernel Changes ]

  * rebase to v3.5
    - LP: #1027828
 -- Leann Ogasaw...

Read more...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints