Ubuntu

omapdss only works on some monitors in quantal

Reported by Oliver Grawert on 2012-06-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-ti-omap4 (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

during quantal image testing my monitor was not properly detected by omapdss, spilling teh message below to teh console:

[ 29.595184] omapdss error: HPD IRQ request failed
[ 30.625518] omapdss DISPC error: SYNC_LOST on channel tv, restarting the output with video overlays disabled

this can be worked around by leaving the monitor unplugged until X comes up.
plugging in the monitor then shows the 1024x768 fallback mode which omapdss apparently uses if monitor detection failed.

testing with a precise kernel makes the monitor detection work properly as is should be.

Oliver Grawert (ogra) on 2012-06-07
Changed in linux-ti-omap4 (Ubuntu):
importance: Undecided → High
Changed in linux-ti-omap4 (Ubuntu Quantal):
milestone: none → quantal-alpha-2
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1010009

tags: added: iso-testing
Oliver Grawert (ogra) wrote :

 including video=HDMI-A-1:1280x800@60 in the bootargs works around the issue for me ...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-ti-omap4 (Ubuntu):
status: New → Confirmed
Oliver Grawert (ogra) wrote :

a quick rundown how to edit boot.scr to change the used kernel cmdline:

mount SD to /mnt on your PC;
cp /mnt/boot.scr ~/boot.script;
.... drop the binary header from the half of the first line (the line should start with the word fatload afterwards);
make your edits;
sudo mkimage -A arm -O linux -T script -n 'Ubuntu Boot Script' -d boot.script /mnt/boot.scr;
unmount /mnt

Oliver Grawert (ogra) on 2012-06-27
summary: - omapdss fails to properly detect some monitors in quantal
+ omapdss only works on some monitors in quantal
Pete Graner (pgraner) wrote :

Workaround in #4 doesn't work for me on 4 different monitors of different makes and models, this occurs on both a Panda ES and Panda A1 board with the same monitors.

Monitor Make and models:

Hannspree HF257 via HDMI & HDMI->DVI cable
ASUS VW224T via HDMI->DVI cable
ViewSonic VX2450 via HDMI->DVI cable
Vizio E47DVL HDTV via HDMI

I have verified all of these combos work on both the ES & A1 with Precise.

Andy Whitcroft (apw) wrote :

I have a panda A1 I am unable to get to display on a monitor here with any of the work arounds.

Andy Whitcroft (apw) wrote :

My monitor is an AOC e2243Fw.

tags: added: quantal
Chris Van Hoof (vanhoof) wrote :

Panda ES here, booted today's quantal armhf desktop build, and the backlight on my monitor fired up and stayed up (did not go into sleep mode) but nothing displayed on the monitor at all.

I'm using a 23 inch Samsung PX2370.

I tried the stock image, and then rebuilt my boot.scr per comment #4 using: video=HDMI-A-1:1920x1080@60 as well as 1280x800@60.

For my own sanity I grabbed a Precise armhf image and it booted up with no issues on the same monitor.

Note all tests were done on the Samsung monitor via HDMI.

--chris

Chris Van Hoof (vanhoof) wrote :

Just to clarify Comment #8, using the workarounds (rebuilding boot.scr) with either:

 * video=HDMI-A-1:1920x1080@60
 * video=HDMI-A-1:1280x800@60

... yield no difference in behaviour, identical to the behaviour on today's daily build.

Oliver Grawert (ogra) wrote :

just because nobody mentioned it yet, switching an installed system that exposes this issue to a 12.04 omap4 kernel makes everything work fine.

Oliver Grawert (ogra) wrote :

if you want to collect more information, use the ubuntu-server preinstalled image which does the whole install on serial console.

after you are done with the installation edit the omap bootscript in /usr/share/flash-kernel/bootscript/bootscr.omap and drop quiet and splash from the bootarg line, then add "omapdss.debug drm.debug=7", save the file and run sudo flash-kernel ... now reboot.

/var/log/dmesg should have a lot of graphics debugging info after the next boot.

Oliver Grawert (ogra) wrote :

oops, sorry, the changes above should have been: "omapdss.debug=1 drm.debug=7"

Stéphane Graber (stgraber) wrote :

Worked fine for me with a PandaBoard A2 connected over HDMI to a Samsung TV (LN46C610), got 1920x1080 without any tweaks required.

Oliver Grawert (ogra) wrote :

so it is likely that along with the framebuffer driver bug we also have a plymouth bug that keeps the screen black during boot instead of showing a splash screen (bug 1018907)

Changed in linux-ti-omap4 (Ubuntu Quantal):
milestone: quantal-alpha-2 → quantal-alpha-3
Paolo Pisati (p-pisati) wrote :

Ubuntu-3.4.0-202.7

Changed in linux-ti-omap4 (Ubuntu Quantal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers