[arrandale] GPU lockup render.IPEHR: 0x01840000

Bug #912134 reported by Roland Dreier on 2012-01-05
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Timo Aaltonen
Precise
Undecided
Unassigned

Bug Description

Problem seems to be related to the fact that I suspended my laptop while it was docked and attached to an external monitor (displayport attached to output DP3), and then undocked and resumed with the monitor disconnected.

(By the way, in case it matters, with this laptop and the precise kernel, I found I had to boot with "intel_iommu=igfx_off" or else I see a bunch of messages like

[ 98.467011] DRHD: handling fault status reg 2
[ 98.467014] DMAR:[DMA Write] Request device [00:02.0] fault addr 400020000
[ 98.467038] DMAR:[fault reason 05] PTE Write access is not set

where 02.0 is the graphics device; so this report is running with igfx_off and hence a not-totally-default precise install)

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Chipset: arrandale
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Wed Jan 4 21:42:39 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DuplicateSignature: [arrandale] GPU lockup render.IPEHR: 0x01840000 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: I don't know
GpuHangReproducibility: I don't know
GpuHangStarted: I don't know
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21c1]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120104)
InterpreterPath: /usr/bin/python2.7
MachineType: LENOVO 2901CTO
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-7-generic root=UUID=677292b2-a7ba-4d9e-8f1a-662c546b62ce ro intel_iommu=igfx_off quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6+7ubuntu7
 libdrm2 2.4.29-1ubuntu1
 xserver-xorg-video-intel 2:2.15.901-1ubuntu4
SourcePackage: xserver-xorg-video-intel
Title: [arrandale] GPU lockup render.IPEHR: 0x01840000
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 10/27/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6UET61WW (1.41 )
dmi.board.name: 2901CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6UET61WW(1.41):bd10/27/2010:svnLENOVO:pn2901CTO:pvrThinkPadT410s:rvnLENOVO:rn2901CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2901CTO
dmi.product.version: ThinkPad T410s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu8
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.29-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1

Roland Dreier (roland.dreier) wrote :
tags: removed: need-duplicate-check
Bryce Harrington (bryce) wrote :

Could you switch on kernel modesetting debug messages? Run 'sudo xdiagnose', it's the first checkbox. Click apply, let it rebuild your bootloader, then reboot. Now reproduce the bug, and then collect 'sudo dmesg > dmesg.txt' and post that here.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since there has not been a response from the original reporter. However, the issue still exists please feel free to reopen with the requested information. If you're not the original reporter, we'd prefer you file a new bug report.

Some tips:

  * Report X.org bugs via the command: `ubuntu-bug xorg`

  * Test against the latest development Ubuntu. http://cdimage.ubuntu.com/daily-live/
    Bugs marked as affecting the development version tend to get priority attention.

  * The `xdiagnose` utility has functionality for enabling debugging and
    analyzing a few common X problems.

  * Tag your bugs with the Ubuntu versions you have reproduced the issue in.

  * See https://wiki.ubuntu.com/X/Reporting for tips on writing good bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
Alexandre Otto Strube (surak) wrote :

Hey Bryce,

I will reopen the bug. Problem is, I only got here by reading the information about it on the apport's details (where it says that whatever bug I have is a duplicate of this one).

Alexandre Otto Strube (surak) wrote :

reopening with further information

Changed in xserver-xorg-video-intel (Ubuntu):
status: Expired → Confirmed
Alexandre Otto Strube (surak) wrote :

xdianose on, sending dmesg output.

Alexandre Otto Strube (surak) wrote :

By the way, my notebook is also attached to a docking station with a displayport screen attached to it, but it happens as soon as the user session is initiated, no relation to sleep mode here, apparently.

Timo Aaltonen (tjaalton) wrote :

I just hit this same IPEHR error on quantal with my i965gm based thinkpad X61. Got a new patch from upstream, and will upload it to quantal & precise soon..

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Confirmed → In Progress
David Monro (davidm-ub) wrote :

Just hit this bug with my thinkpad X201 (Arrandale core i7 M620) after the following sequence:
xrandr --output HDMI1 --off (its actually a DVI display using a DP->DVI cable from the docking station)
undock
suspend
get home, unsuspend
Notice that xrandr still thinks I have a 3200 pixel wide display (1920 for the external monitor, 1280 for the laptop panel). I don't think I've had this happen before.
Run xrandr --fb 1280x800
black screen, and 'Sorry, Ubuntu 12.04 has experienced an internal error' dialog after reboot.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.20.6-0ubuntu1

---------------
xserver-xorg-video-intel (2:2.20.6-0ubuntu1) quantal; urgency=low

  * Merge from unreleased debian git.

xserver-xorg-video-intel (2:2.20.6-1) UNRELEASED; urgency=low

  * New upstream bugfix release.
  * Added uxa-flush-batch-immediately.diff. (LP: #912134)

xserver-xorg-video-intel (2:2.20.5-1) experimental; urgency=low

  * New upstream release.
    - Remove patch to support passing a builder string, merged upstream
      0001-Fix-build-failure-when-passing-with-builderstring.patch
 -- Timo Aaltonen <email address hidden> Wed, 05 Sep 2012 17:27:17 +0300

Changed in xserver-xorg-video-intel (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers