update fails on libpam-ck-connector:i386

Bug #900483 reported by K Richard Pixley on 2011-12-05
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Michael Vogt
Michael Vogt

Bug Description

Upgrading from 11.10 to precise alpha 1 on amd64.

rich@chipmunk> apt-cache policy update-manager
  Installed: (none)
  Candidate: 1:0.154.6
  Version table:
     1:0.154.6 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

I expected an update. Updated failed and asked me to file this bug report. So here I am.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager (not installed)
ProcVersionSignature: Ubuntu 3.0.0-13.21palm1-za 3.0.6
Uname: Linux 3.0.0-13-za x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Mon Dec 5 12:48:24 2011
InstallationMedia: Ubuntu-Server 10.10 "Maverick Meerkat" - Release amd64 (20101007)
 PATH=(custom, user)
SourcePackage: update-manager
UpgradeStatus: Upgraded to precise on 2011-12-05 (0 days ago)

K Richard Pixley (rich-noir) wrote :
tags: added: distribution-upgrade
RedSingularity (redsingularity) wrote :

Whats the output of:

apt-cache policy libdevmapper1.02.1
Ubuntu Bug Squad volunteer triager

Changed in update-manager (Ubuntu):
status: New → Incomplete
K Richard Pixley (rich-noir) wrote :

<email address hidden>> ssh chipmunk.palm.com
Welcome to Ubuntu precise (development branch) (GNU/Linux 3.2.0-7-generic x86_64)

 * Documentation: https://help.ubuntu.com/
Last login: Tue Jan 3 14:24:16 2012 from flamingo.palm.com
DISPLAY=localhost:10.0, TERM=xterm, EDITOR=emacsclient, TAPE=/dev/st0
rich@chipmunk> apt-cache policy libdevmapper1.02.1
  Installed: 2:1.02.48-4ubuntu7
  Candidate: 2:1.02.48-4ubuntu7
  Version table:
 *** 2:1.02.48-4ubuntu7 0
        500 http://ubunturep.palm.com/ubuntu/ precise/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Steve Langasek (vorlon) wrote :

Part of this is due to bug #652063 in dpkg, which was fixed in dpkg (10 days after your upgrade). Part of this is due to bug #850264 in apt, for which the fix in precise is pending. But what's not clear here is why the dist-upgrader calculated an upgrade path for ia32-libs-multiarch at all, because ia32-libs-multiarch was uninstallable continuously in precise from October 16th until January 1st.

We need to try to reproduce this with the current precise and see what happens. It's possible that we'll still hit bug #850264 due to using the oneiric apt for the upgrade and need to backport this apt fix in some fashion.

Changed in update-manager (Ubuntu Precise):
importance: Undecided → High
status: Incomplete → Triaged
assignee: nobody → Michael Vogt (mvo)
tags: added: rls-mgr-p-tracking
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers