Ubuntu

multiple instances or double icons of application detected on bamfdaemon respawn

Reported by Didier Roche on 2012-02-08
94
This bug affects 16 people
Affects Status Importance Assigned to Milestone
BAMF
Medium
Marco Trevisan (Treviño)
Unity
High
Marco Trevisan (Treviño)
Unity Distro Priority
Medium
Unassigned
bamf (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Marco Trevisan (Treviño)

Bug Description

Doesn't happen 100% of the time, but quite easy to tackle:
test case

1. start a non pinned app e.g. system monitor
2. open terminal and type 'killall bamfdaemon; /usr/lib/bamf/bamfdaemon

What happens:
you see two icons of system monitor in launcher

-> This case is fixed, but:
For example, try to run an application with no desktop file (i.e. Xclock, valkyrie...) then kill bamfdaemon: the icons will be duplicated.

I just using mail client - thunderbird, I close it. When I open thunderbird again, next icon appears in unity, while both icons forwarding to this one instance of thunderbird. After right click on the icon in unity panel, there is blank line instead app name on the newly created icon. I guess it'll happen with more apps.

Another case:
TEST CASE:
1. open a single instance of an application
2. killall bamfdaemon
 -> when bamfdaemon will respawn, 2 arrows will appear on the launcher, alt-tab think there are two instances as well.
Not that in 5.4, some icons are doubled (no more double arrows)

Unity Issue test case:
1. Open gnome-control-center
2. killall bamfdaemon

libbamf issue test case:
1. Open xclock
2. killall bamfdaemon

expected:
 -> when bamfdaemon reconnect, only one instance in launcher/alt+tab is seen.

Didier Roche (didrocks) on 2012-02-08
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
milestone: none → 5.4.0
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → Medium
Nekhelesh Ramananthan (nik90) wrote :

Would this definitely be fixed for Unity 5.4? It is happening very frequently thereby messing with the alt-tab.

Didier Roche (didrocks) on 2012-02-17
Changed in unity:
milestone: 5.4.0 → 5.6.0
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Didier Roche (didrocks) on 2012-02-20
description: updated
summary: - multiple instances of application detected on bamfdaemon respawn
+ multiple instances or double icons of application detected on bamfdaemon
+ respawn
Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
Omer Akram (om26er) on 2012-02-27
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Didier Roche (didrocks) on 2012-03-01
description: updated
Omer Akram (om26er) wrote :

I think its in 11.10 as well? a backport for 11.10 would be highly welcome as well.

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Federico Raimondo (fraimondo) wrote :

I can confirm this bug happening in up to date ubuntu 12.04

Didier Roche (didrocks) wrote :

still here in 5.6

tags: added: rls-mgr-p-tracking
tags: added: precise
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Didier Roche (didrocks) wrote :

Can't reproduce in 5.8. Closing ;)

Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in unity:
status: Triaged → Fix Released
milestone: 5.10.0 → none
Changed in unity (Ubuntu Precise):
status: Triaged → Fix Released

Didier, it still can happen.
For example, try to run an application with no desktop file (i.e. Xclock, valkyrie...) then kill bamfdaemon: the icons will be duplicated.

Didier Roche (didrocks) on 2012-04-02
Changed in unity-distro-priority:
status: Fix Released → Fix Committed
Changed in unity:
milestone: none → 5.10.0
status: Fix Released → Triaged
Changed in unity (Ubuntu Precise):
status: Fix Released → Triaged
description: updated
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 0.2.116
importance: Undecided → Medium
Gord Allott (gordallott) on 2012-04-26
Changed in unity:
milestone: 5.12.0 → 5.14.0
Gord Allott (gordallott) on 2012-04-26
Changed in bamf:
milestone: 0.2.116 → 0.2.118
Changed in unity:
status: In Progress → Fix Committed
milestone: 5.14.0 → 5.12.0
Didier Roche (didrocks) on 2012-04-27
Changed in bamf:
status: In Progress → Fix Released
Changed in unity:
status: Fix Committed → Fix Released

Hello Didier, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in bamf:
status: Fix Released → Fix Committed
Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf (Ubuntu Precise):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Precise):
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.12-0ubuntu1

---------------
unity (5.12-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
      Tab raises all app windows, not just most recently focused (LP: #959339)
    - [heap corruption?] compiz crashed with SIGSEGV in _int_malloc() from
      g_realloc() from ... from g_dbus_connection_send_message_with_reply()
      from g_object_unref() from unity::dash::HomeLens::Impl::~Impl() from
      unity::dash::HomeLens::~HomeLens() (LP: #931201)
    - compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
      XOpenDisplay() from nux::WindowThread::ThreadCtor() (LP: #947844)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Window management - unity doesn't realise when applications bring their
      windows to the front (LP: #802816)
    - Dash - Clicking on the desktop dash border should do nothing, *NOT*
      close the dash (LP: #839472)
    - [FFe, UIFe] HUD - The HUD does not respect launcher icon size settings
      in autohide mode (LP: #921506)
    - compiz crashed with SIGSEGV in g_volume_get_mount() (LP: #918548)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - Panel is transparent when Dash is open; no blur no average BG color
      (LP: #965323)
    - Unity crashes with SIGSEGV when hitting debug DBus interface hard
      (LP: #979429)
    - compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
      unity::dash::Model<unity::dash::FilterAdaptor>::~Model() (LP: #941750)
    - indicators menu are sometimes cut off at screen edge (LP: #883317)
    - the shortcut keys in workspace section of the shortcut overlay aren't
      translated (LP: #980828)
    - [regression] Dash keeps repainting unnecessarily (LP: #980924)
    - compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
      nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
      (LP: #952378)
    - compiz crashed with SIGSEGV in g_object_unref() from
      unity::dash::Settings::~Settings() from
      unity::UnityScreen::~UnityScreen() (LP: #981764)
    - compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
      from unity::dash::ResultViewGrid::~ResultViewGrid() from
      nux::Object::Destroy() from nux::Object::UnReference() (LP: #942286)
    - compiz crashed with SIGSEGV in
      ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
      std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
      from unity::ui::PointerBarrierWrapper::EmitCurrentData() (LP: #983268)
    - Chinese can't be shown completely in dash filter (LP: #984583)
    - [Unity 5.10] compiz crashed with SIGSEGV in
      unity::hud::HudIconTextureSource::ColorForIcon() from
      unity::hud::Icon::Icon() from emit from unity::IconTexture::IconLoaded
      (LP: #983646)
    - [regression] Close button does not close the dash/HUD (LP: #986264)
    - compiz crashed with SIGSEGV in g_volume_eject_with_operation_finish()
      fro...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu1

---------------
bamf (0.2.118-0ubuntu1) quantal; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu):
status: Confirmed → Fix Released
Changed in bamf (Ubuntu):
importance: Undecided → High
Changed in bamf (Ubuntu Precise):
importance: Undecided → High
status: Confirmed → Fix Committed
Changed in bamf:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

Hello Didier, or anyone else affected,

Accepted bamf into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Sebastien Bacher (seb128) wrote :

Settings verification-done since the original issue is fixed and there is no regression, some cases are not solved and the bug should be reopened once the update is to precise-updates though

tags: added: verification-done
removed: verification-needed

Excerpts from Sebastien Bacher's message of 2012-06-01 14:35:24 UTC:
> Settings verification-done since the original issue is fixed and there
> is no regression, some cases are not solved and the bug should be
> reopened once the update is to precise-updates though
>
> ** Tags removed: verification-needed
> ** Tags added: verification-done
>

Awesome. Wouldn't that be a different bug entirely though? It seems to
me that if one fix only fixes half the reports, then there were actually
two bugs.

Sebastien Bacher (seb128) wrote :

yes, having a new bug about the other issues would probably be easier than abusing the current one with side issues

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu0.1

---------------
bamf (0.2.118-0ubuntu0.1) precise-proposed; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Quantal):
status: New → Confirmed
no longer affects: bamf (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers