Ubuntu

sometimes icons get dropped from the launcher when they should not

Reported by Sebastien Bacher on 2012-02-02
160
This bug affects 40 people
Affects Status Importance Assigned to Milestone
BAMF
High
Marco Trevisan (Treviño)
0.2
High
Unassigned
Unity
High
Marco Trevisan (Treviño)
5.0
High
Marco Trevisan (Treviño)
6.0
High
Marco Trevisan (Treviño)
Unity Distro Priority
High
Unassigned
bamf (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Unassigned
Quantal
Undecided
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Unassigned

Bug Description

[Test Case]
1. Start something (let's say gedit) from the dash
2. Right click on the launcher icon and pick "lock to launcher"
3. Close it
4. Click on the launcher icon
5. Right click on the launcher icon and pick "unlock from launcher"
   -> Verify that the application icon is still visible while the application is running

Try multiple times to confirm that the behavior is correct every time.

[Regression Potential]
Broken indication of open/closed applications. Missing icons in Launcher.

Original description:

WORKAROUND: to temporarily fix the problem without loggin out/resarting and losing all program state, one can run "xkill" and click the unity launcher. it will respawn and the "lost" applications will reappear...

Using 5.2rc1:
- start something (let's say gedit) from the dash
- right click on the launcher icon and pick "lock to launcher"
- close it
- click on the launcher icon
- right click on the launcher icon and pick "unlock from launcher"

the icon sometimes is dropped from the launcher (it doesn't happen every time) while the program is still running

Related branches

lp:~3v1n0/unity/quick-app-reopen-icon-fix
Merged into lp:unity at revision 2358
Tim Penhey (community): Approve on 2012-05-16
Thomi Richards: Approve on 2012-05-15
lp:~3v1n0/unity/missing-launcher-icon-fix-5.0
Merged into lp:unity/5.0 at revision 2349
Gord Allott (community): Needs Information on 2012-05-22
tags: added: 5.2-rc1
Didier Roche (didrocks) wrote :

confirmed by more than 10 people on the manual tests. Got it sometimes here as well.

Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Tim Penhey (thumper) on 2012-02-29
Changed in unity:
status: New → Triaged

I think the only way this can happen is while the program is starting you unlock it from launcher. This is before the program has actually started, though it'll start soon.

 A good example of this is the software center, as it takes a little longer to start up:

Open Ubuntu Software Center
While its opening Unlock form Launcher

...Icon is removed, then the Software Center starts without adding the icon back to the launcher

Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
Austin Holbrook (nxuul) wrote :

This bug and bug #916098 are the same.

Linux Lover (obake) wrote :

@Brandon: I don´t think this affects application that are in the process of starting. I tested with lightweight applications such as the terminal and gedit. And I can reproduce this bug when they have already been initiated and I can work with them.

Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: Brandon Schaefer (brandontschaefer) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
milestone: none → 5.14.0
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-distro-priority:
status: Fix Committed → Fix Released

What needs to happen for the SRU here?

Sebastien Bacher (seb128) wrote :

@Thomas: is that still an issue with this SRU:
https://launchpad.net/ubuntu/+source/unity/5.12-0ubuntu1.1

it seems it the bug got closed on the basis that it's similar to some of the issues fixed in that SRU:

"- App icon on the Unity Launcher lost track of running
      instance (LP: #772063)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running
      status (LP: #999820)"

I didn't notice the issue described here recently but if it's still happening we will need to reopen and I will ping the unity team to look into details to it, do you use the same steps that the ones described there to reproduce the bug?

I just tried following the instructions here and it happened the very first time.

And this is indeed with unity 5.12-0ubuntu1.1.

I did exactly what was described:

- start something (let's say gedit) from the dash
- right click on the launcher icon and pick "lock to launcher"
- close it
- click on the launcher icon
- right click on the launcher icon and pick "unlock from launcher"

The icon disappeared from the launcher and was not visible in Alt-Tab. [Bug]

Then I did this:
- close gedit
- open a new gedit from the dash

The problem is still there: not in launcher and not in Alt-Tab. [Bug]

So I thought, "hey, I wonder if the gimp case is fixed".

I did this:
- start gimp from terminal
- notice launcher icon
- close gimp
- launcher icon goes away
- start gimp from launcher icon
- and *two* copies of the gimp icon appear, both with three buttons.
- Alt-Tab likeways sees two instances, each with the same windows.

Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
Changed in unity-distro-priority:
status: Fix Released → Fix Committed
Sebastien Bacher (seb128) wrote :

Thanks Thomas, the gimp case was a bit different, gimp wouldn't get any icon at all in the launcher when started (i.e the icon would be displayed with the start screen, but go away when this one was dismissed and didn't come back with the main ui), for sure some issues are remaining, we will address them for the LTS for sure but I'm not sure if that can make it for the next SRU round, I will check with the unity people working on the LTS fixes

Michael Nagel (nailor) on 2012-06-12
description: updated

So now this one says "Fix Committed" for unity-distro-priority, but AFAIK, nobody has fixed it anywhere. (If that's incorrect, I would dearly like to have a package to test.)

Sebastien Bacher (seb128) wrote :

@Thomas: sorry if the status are confusing, the "unity-distro-priority" line is just a way to track bugs which the distribution team considers as important, the "fix commited" there means that we confirmed it's a priority bug for us, the unity status and the bug will be updated once there is a fix available to test

Changed in bamf:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
no longer affects: bamf
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in bamf:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed
description: updated
Changed in bamf:
status: In Progress → Fix Committed
Changed in bamf (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-1ubuntu1

---------------
bamf (0.2.118-1ubuntu1) quantal; urgency=low

  * Sync from debian. No more difference.
  * Cherry-pick from upstream:
    - Started applications pinned to the launcher are not set as running
      (LP: #976642)
    - sometimes icons get dropped from the launcher when they should not
      (LP: #925421)
  * debian/*symbols:
    - add new private symbol (will not be exported after next release)
  * debian/control:
    - change packaging location to canonical branch (lp:ubuntu/bamf)

bamf (0.2.118-1) unstable; urgency=low

  * Backport latest release to debian
  * debian/control:
    - bump Standards-Version to latest
    - remove build-dep only used for unit tests
    - replace the gtk2 variant of the wnck introspection gir package with
      gtk3 one
    - ensure the gtk2/gtk3 version doesn't have the same description
  * debian/*.symbols:
    - adding some PRIVATE symbols to make lintian happy. We saw that bamf
      is exporting by error some of its private symbols. This will be fixed
      in next released (and so the symbols will be removed from the .symbols
      files)
  * debian/rules:
    - add hardening flags (thanks Andrea)
  * debian/sources/format:
    - added to specify we use format 1.0
 -- Didier Roche <email address hidden> Mon, 25 Jun 2012 11:01:57 +0200

Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
description: updated
Changed in unity (Ubuntu Precise):
status: New → In Progress
Changed in bamf (Ubuntu Precise):
importance: Undecided → High
Changed in unity (Ubuntu Precise):
importance: Undecided → High
Changed in bamf (Ubuntu):
importance: Undecided → High
Changed in bamf (Ubuntu Precise):
status: New → In Progress

Hello Sebastien, or anyone else affected,

Accepted bamf into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/bamf/0.2.118-0ubuntu0.2 in a few hours and then in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bamf (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Eero Aaltonen (ejn) wrote :

I updated
- bamfdaemon
- libbamf0
- libbamf3-0

sudo aptitude install bamfdaemon/precise-proposed libbamf0/precise-proposed libbamf3-0/precise-proposed

Tested by firing up gedit a few times.

Results in three categories (seemingly randomly)
1. Single slot, missing icon
2. Single slot, icon visible
3. Two slots, first without icon and second with icon.

Sebastien Bacher (seb128) wrote :

@Eero: did you restart your session after the update, can you describe the steps you used?

I can't confirm none of the issue there since the update but I didn't get the bug every time before either, though by now I should have run into it at least once so it looks like the update is working for me at least

Eero Aaltonen (ejn) wrote :

@Sebastian: Yes, I restarted.

Basically I'm just opening text files by double clicking them in Nautilus.

Looks very random, although I got a fourth result. Three slots opened and one of them remained as a 'ghost slot' after closing gedit.

Sebastien Bacher (seb128) wrote :

@Eero: your issue seems different, the bug there is about icons being dropped from the launcher when being locked and then unlocked, not when starting programs in a random way

Sebastien Bacher (seb128) wrote :

I will go ahead and set as verification-done, I can't reproduce the pin,unpin issue since the update and didn't see regressions, if anybody else wants to confirm that the fix is working or not for you there is still time before the SRU is moved to updates

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu0.2

---------------
bamf (0.2.118-0ubuntu0.2) precise-proposed; urgency=low

  * Cherry-pick from upstream:
    - Started applications pinned to the launcher are not set as running
      (LP: #976642)
    - sometimes icons get dropped from the launcher when they should not
      (LP: #925421)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Wed, 20 Jun 2012 19:09:43 +0100

Changed in bamf (Ubuntu Precise):
status: Fix Committed → Fix Released

I don't understand how an update to bamf can fix this, since I don't have bamf installed.

Never mind, I'm dumb.

I can confirm that with the referenced package update I no longer see the bug. thanks!

Changed in unity:
status: Fix Committed → Fix Released
Changed in bamf:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

Marco: So this would need some backporting still to 5.0 series, right? The bamf fix is already in precise.

Changed in bamf (Ubuntu Quantal):
status: New → Fix Released
Changed in unity (Ubuntu Precise):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
assignee: Timo Jyrinki (timo-jyrinki) → nobody
Changed in bamf:
status: Fix Committed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

It _looks_ like all the fixes are in both Ubuntu 12.04 LTS by now, not only bamf but also unity. Please reopen if there something left to do on the unity side.

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers