the unity-greeter keyboard's selection doesn't respect the user config

Bug #915468 reported by Sebastien Bacher on 2012-01-12
128
This bug affects 23 people
Affects Status Importance Assigned to Milestone
accountsservice (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
lightdm (Ubuntu)
High
Robert Ancell
Precise
High
Robert Ancell
unity-greeter (Ubuntu)
High
Michael Terry
Precise
High
Unassigned

Bug Description

Using the current trunk from lightdm and unity-greeter, unity-greeter display a keyboard indicator but default to "en" where my system and user .dmrc are set to fr.

Related branches

Timo Aaltonen (tjaalton) wrote :

This is quite serious actually, since users might not notice the 'en' icon on the top panel (I didn't). The fallback default should be XKBLAYOUT from /etc/default/keyboard (= just use the xserver default), and if the user has something set in accountsservice use that instead.

Changed in lightdm (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Sam_ (and-sam) wrote :

Was reported there against shadow. bug 918924
Although it doesn't occur here with 'de', reboot and logout several times.

Martin Pitt (pitti) on 2012-01-20
Changed in lightdm (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)
milestone: none → precise-alpha-2
tags: added: regression-release
Changed in unity-greeter (Ubuntu Precise):
importance: Undecided → High
status: New → Confirmed
Changed in lightdm (Ubuntu Precise):
assignee: Michael Terry (mterry) → Robert Ancell (robert-ancell)
Changed in unity-greeter (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)
brian baker (brian-m-baker) wrote :

happens with me too even with the latest update to https://launchpad.net/ubuntu/precise/+source/lightdm/1.1.1-0ubuntu3

also the cog doesn't show ! i added a new user and if you toggle between users then the cog re-appears.

Martin Pitt (pitti) on 2012-01-20
Changed in lightdm (Ubuntu Precise):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.0-0ubuntu4

---------------
unity-greeter (0.2.0-0ubuntu4) precise; urgency=low

  * debian/patches/drop_keyboard_indicator.patch:
    - Back out the keyboard layout indicator for now, until we can properly
      fix the bugs with detecting user layouts. (LP: #915468)
 -- Michael Terry <email address hidden> Fri, 20 Jan 2012 07:05:31 -0500

Changed in unity-greeter (Ubuntu Precise):
status: Confirmed → Fix Released
Michael Terry (mterry) wrote :

Robert, for lightdm, it seems that user's keyboad layout *used* to be stored in ~/.dmrc in GDM2. Which sometimes isn't readable. And for GDM3, it's stored in gsettings: org.gnome.libgnomekbd.keyboard.

We should probably put that into accountsservice and then pull that into lightdm.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in accountsservice (Ubuntu):
status: New → Confirmed
brian baker (brian-m-baker) wrote :

to confirm latest update unity-greeter - 0.2.0-0ubuntu4 wks :-)

syscon-hh (syscon-kono) wrote :

@*Michael Terry*

Please consider, that all positions mentioned (~.drmc as well as gsettings) are not readable, if you are using an "encrypted" home (ecryptfs).

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/919305

tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

Fixed, but imho was better choosing a different layout at greeting, now it ie disappeared
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Well, the problem was bigger. The greeter didn't even remember my keyboard choice. It always reverts back to english.

tags: added: rls-mgr-p-tracking
Martin Pitt (pitti) on 2012-02-02
Changed in lightdm (Ubuntu Precise):
milestone: precise-alpha-2 → ubuntu-12.04-beta-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.1.2-0ubuntu3

---------------
lightdm (1.1.2-0ubuntu3) precise; urgency=low

  * debian/patches/05_keyboard_indicator.patch:
    - Backported patch from trunk to fix various keyboard layout issues
      preventing greeter keyboard indicators from working.
      LP: #919199, LP: #919200, LP: #915468
 -- Michael Terry <email address hidden> Sun, 12 Feb 2012 19:37:51 -0500

Changed in lightdm (Ubuntu Precise):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package accountsservice - 0.6.15-2ubuntu5

---------------
accountsservice (0.6.15-2ubuntu5) precise; urgency=low

  * debian/patches/0012-add-keyboard-layout-support.patch:
    - Add XKeyboardLayouts property to report a user's keyboard layouts,
      largely for LightDM's benefit. LP: #915468
 -- Michael Terry <email address hidden> Fri, 10 Feb 2012 22:48:39 -0500

Changed in accountsservice (Ubuntu Precise):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.2.2-0ubuntu16

---------------
gnome-settings-daemon (3.2.2-0ubuntu16) precise; urgency=low

  * debian/patches/06_use_application_indicator.patch:
    - Check for gtk3 version of libappindicator, not gtk2
  * debian/patches/sync_keyboard_layout_to_accountsservice.patch:
    - Sync user's list of layouts to accountsservice so it can in turn
      inform LightDM. LP: #915468
 -- Michael Terry <email address hidden> Mon, 13 Feb 2012 10:40:21 -0500

Changed in gnome-settings-daemon (Ubuntu Precise):
status: New → Fix Released
Michael Terry (mterry) wrote :

Reopening unity-greeter task for the real fix, not the workaround patch.

Changed in unity-greeter (Ubuntu Precise):
status: Fix Released → Triaged
Michael Terry (mterry) wrote :

And a unity-greeter that turns the keyboard indicator back on is released:

unity-greeter (0.2.1-0ubuntu1) precise; urgency=low

  * New upstream release
    - Fix session menu button not showing for first user
    - Skip indicators that fail to load
    - Distribute translations correctly
    - Load indicators from location specified in pkg-config
    - Use gsettings instead of /etc/lightdm/unity-greeter.conf
    - Accept numpad arrow key presses
    - Instead of showing all layouts in the system in the keyboard indicator,
      only show the layouts a user has configured
    - Don't crash if gnome-settings-daemon's gsettings schema isn't as expected
    - Disable gnome-settings-daemon's new gsdwacom plugin as well as its older
      wacom plugin
    - Use vala-0.16 instead of valac-0.14
  * debian/control:
    - Bump valac build-depend to valac-0.16
    - Bump liblightdm-gobject build-depend to one that has backported
      keyboard layout query functions

Changed in unity-greeter (Ubuntu Precise):
status: Triaged → Fix Released
Alkis Georgopoulos (alkisg) wrote :

This is still an issue in Ubuntu Precise fully updated.

1) If I use autologin, everything is fine, my keyboard layout is the same as the system default, En/El.
2) If I use the greeter:
 * I only have "En" available in the greeter,
 * I only have "En" available in the session,
 * I don't get a keyboard layout panel applet in the session.

System settings:
================
alkisg@server:~$ cat /var/lib/AccountsService/users/alkisg

[User]
XSession=ubuntu
XKeyboardLayouts=
Icon=/usr/share/pixmaps/faces/guitar.jpg

alkisg@server:~$ cat .dmrc

[Desktop]
Session=ubuntu

alkisg@server:~$ cat /etc/default/keyboard
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="us,gr"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap. Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

Result with autologin (no greeter, no problem):
===============================================
alkisg@server:~$ setxkbmap -print
xkb_keymap {
 xkb_keycodes { include "evdev+aliases(qwerty)" };
 xkb_types { include "complete" };
 xkb_compat { include "complete+ledscroll(group_lock)" };
 xkb_symbols { include "pc+us+gr:2+inet(evdev)+group(alt_shift_toggle)" };
 xkb_geometry { include "pc(pc105)" };
};

Result with lightdm-greeter (problem):
======================================
alkisg@server:~$ setxkbmap -print
xkb_keymap {
 xkb_keycodes { include "evdev+aliases(qwerty)" };
 xkb_types { include "complete" };
 xkb_compat { include "complete" };
 xkb_symbols { include "pc+us+inet(evdev)" };
 xkb_geometry { include "pc(pc105)" };
};

Changed in unity-greeter (Ubuntu Precise):
status: Fix Released → Triaged
Michael Terry (mterry) on 2013-04-30
Changed in unity-greeter (Ubuntu Precise):
assignee: Michael Terry (mterry) → nobody
Sam King (samking) wrote :

This bug still affects me in Trusty. When typing my password the first time after a reboot, it still uses QWERTY, and after I login, it still uses QWERTY even though my default keyboard layout is Dvorak.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints