Steps "Preparing to install" and "Erase disk" are unreadable with high-contrast theme enabled

Bug #744283 reported by Jean-Baptiste Lallement on 2011-03-28
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

When a high-contrast theme is enabled the text is white on white in the box on steps "Preparing to install" and "Erase disk" are unreadable.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Mon Mar 28 15:51:30 2011
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: Upgraded to natty on 2011-02-21 (34 days ago)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
tags: added: a11y
Colin Watson (cjwatson) wrote :

I think this must be specific to Unity. I can't reproduce it on non-Unity-capable systems (KVM and NVIDIA - the latter can work with Unity after installation but not straight off the live CD).

Could we get a screenshot?

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
tags: added: ubiquity-1.8.7
tags: added: hardy
Changed in ubiquity (Ubuntu):
assignee: nobody → Abhishek kumar singh (abhishekkumarsingh-cse)
status: New → In Progress
Changed in ubiquity (Ubuntu):
assignee: Abhishek kumar singh (abhishekkumarsingh-cse) → nobody
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in ubiquity (Ubuntu Quantal):
status: In Progress → Fix Committed
Jeremy Bicha (jbicha) wrote :

Dmitrijs, thanks for working on this. It looks much better in Adwaita or in High Contrast!

I did see a regression though. The partition labels at the top of the manual partition editor are now white and they should be black. It shows up as white text on white background in both Adwaita & High Contrast.

Jeremy Bicha (jbicha) wrote :

Also, while we're tweaking things to look better on Adwaita, the note on the first screen should be a darker gray or black.

By the way, do you plan to land the fix for this bug after Beta 1?

Dimitri John Ledkov (xnox) wrote :

ubiquity-white-partition-labels.png
Yeah that looks odd. That is a custom widget, but I'd expect it to use "regular" color of a "normal" label.
Is that a horizontal scrollbar I see?! There shouldn't be any.... Or do you have like 100 partitions?

ubiquity-adwaita-not-enough-contrast.png
Not sure about that one. It should be a normal label in the GtkNotebook. Maybe it has style small applied or something like that, to make it a notice... check the code/glade files and or theme definitions.

Changed in ubiquity (Ubuntu Quantal):
status: Fix Committed → In Progress
Changed in ubiquity (Ubuntu Quantal):
status: In Progress → Fix Committed
assignee: Dmitrijs Ledkovs (xnox) → nobody
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu Precise):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/744283

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.11.31

---------------
ubiquity (2.11.31) quantal; urgency=low

  [ Colin Watson ]
  * Buffer reads from debconf-copydb. Python 3 defaults to unbuffered reads
    from byte streams, which is much slower.
  * Port oem-config-remove-gtk to Python 3, now that
    python3-aptdaemon.gtk3widgets exists; the final piece!
  * Remove Python 2 support. We aren't going back now.
  * Remove the rest of the long-dead PS3 port.

  [ Dmitrijs Ledkovs ]
  * Allow going from the encryption key setup page, to the disk space
    allocation page. (LP: #1046323)
  * Correctly apply styles to the title & progress sections and not the
    centre piece. This means themes are no longer required to provide non
    standard @dark_[fb]g_color colors, instead 'menubar' Gtk CSS style is
    used. This also fixes long standing a11y issues in HighContrast themes
    & requirements for non-standard color definitions. (LP: #744283)
  * Make lables in the segmented bar use the same colours as normal labels.
  * Changing the "Add/Remove/Change Partiontion" buttons to mixed
    symbolic/text buttons should make the screen comply with Ubiquity
    Design spec ( http://goo.gl/Kokw5 ) and address confusion about the
    updated screen. (LP: #1045799)
  * Fix the disappearance of crypto password field (LP: #1045716)
  * Fix misallignment of crypto password fields (LP: #1045712)
  * Make setup security key page go back to ask page (LP: #1045698)
  * Remove powerpc/ps3 low-memory profile, as it doesn't do anything any
    more. gnome-session-remove command is no longer present, and the init
    processes it tried to stop no longer exist under those names. We do
    want a low memory profile, which ubiquity-only mode now.
  * ubiquity-wrapper: Add support for udisks2 inhibit, drop devkit-disks
    inhibit. (LP: #719338)
  * Prevent progress label to expand & shrink the window (LP: #1046241)
  * Automatic update of included source packages: base-installer
    1.122ubuntu9.

  [ Dylan McCall ]
  * Fixed slideshow_get_available_locale missing new locales in
    extra_slides_dir. (LP: #1046511)
 -- Dmitrijs Ledkovs <email address hidden> Sat, 08 Sep 2012 00:47:54 +0100

Changed in ubiquity (Ubuntu Quantal):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-09-07
Changed in ubiquity (Ubuntu Precise):
status: Confirmed → Triaged
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers