Empathy is not working behind the proxy servers SINCE Ubuntu 11.10

Bug #893031 reported by Nithin C on 2011-11-21
132
This bug affects 25 people
Affects Status Importance Assigned to Milestone
telepathy-gabble
Unknown
Medium
libproxy (Ubuntu)
High
Unassigned
Precise
High
Unassigned
telepathy-gabble (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Empathy is unable to connect behind the proxy servers whatever way we try. It doesn't utilize the proxy settings given globally to the system. There is no proxy option in the program also. I tried connecting to empathy from Ubuntu 11.10 in three systems behind a proxy server and in all cases it failed.
I tried all of the following but none worked:

1. Changing settings with gconf-editor ( Walk down the tree to system -> http_proxy . Search for use_http_proxy and check it. )
Even after doing that there is no change in behaviour of empathy
2. gksudo gedit /etc/bash.bashrc
export http_proxy=http://proxyhost:port/
export ftp_proxy=http://proxyhost:port/
save and exit
This also didnt help anything
3. Using tsocks and editing its config files also.
In that case the result was:
"tsocks dbus-launch empathy" fails to retrieve the accounts list.
"tsocks empathy" launches empathy, but it is unable to connect..

Please generate a patch for this problem and release new version of the program.

Nithin C (nithin-aneesh) on 2011-11-21
Changed in empathy (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) wrote :

thank you for taking time in filing the bug to make ubuntu better.
you can not confirm your own bug. some one else see this bug and he can confirm this but not you so marking it new again.

Changed in empathy (Ubuntu):
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Prabhjot (prabhjotsbhatia) wrote :

Confirming that it affects me too. I have tried all of the above, empathy fails to connect to server.

msreekanth (sreekanth-manga) wrote :

Yes.This affects me too.

msreekanth (sreekanth-manga) wrote :

Not only empathy ,but even google chrome doesnt pick the proxy settings.Guess if you are making major changes to the way the external programs are picking up the settings, the ubuntu development should have notified the respective teams or you should have taken care not to break anything.

Ubuntu release by release is loosing its fame !!!

Nithin C (nithin-aneesh) wrote :

Not only emapthy. Ubuntu-one is also not connecting behind a proxy server. I think the proxy problem is going to kill Ubuntu if it is not solved. I am planning to switch to some other distro if tis problem persists in 12.04 also.

SueN (sue-newland) wrote :

Yes I can also confirm that empathy is not working behind my proxy.

3. Using tsocks and editing its config files also.
In that case the result was:
"tsocks dbus-launch empathy" fails to retrieve the accounts list.
"tsocks empathy" launches empathy, but it is unable to connect..

This will never do anything useful. Empathy doesn't make network connections, Telepathy does. You might get more luck out of: GABBLE_PERSIST=1 tsocks /usr/lib/telepathy/telepathy-gabble

This bug should probably be filed against either Gabble or glib-networking. A gabble debug log might help us understand what's going on here.

Run 'GABBLE_PERSIST=1 GABBLE_DEBUG=all WOCKY_DEBUG=xmpp /usr/lib/telepathy/telepathy-gabble | tee output.log' on the command line to collect a log.

Nithin C (nithin-aneesh) wrote :

@Danielle Madeley: What is Gabble or glib-networking? I didn't find anything like that in empathy settings!!!! I followed those instructions from a website and tried. All I could find finally is that no chat clients work behind proxy server in Ubuntu. Ubuntu-one doesn't work behind a proxy. This issue is very serious and is making us to hate Ubuntu.

Bilal Shahid (s9iper1) wrote :

i have reportedyour bug to the upstream so answer there if the developer require information from you
here is the upstream link https://bugzilla.gnome.org/show_bug.cgi?id=665415
thanks

Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Bilal Shahid (s9iper1) wrote :

subcribed to the upstream bug and one of you answer him there.
thanks

Changed in empathy:
status: New → Unknown
Donagh Horgan (donagh-horgan) wrote :

I'm having the same problem. I'm using Ubuntu 11.10 with GNOME 3 behind a proxy at my university. From the bugzilla report, it looks like libproxy0 needs to be updated to version 0.4.7? I'm running 0.3.1-2ubuntu6 here.

Bilal Shahid (s9iper1) on 2011-12-14
affects: empathy (Ubuntu) → libproxy (Ubuntu)
no longer affects: empathy
Changed in libproxy (Ubuntu):
importance: Undecided → High
Changed in libproxy (Ubuntu Precise):
assignee: nobody → Ken VanDine (ken-vandine)
Leo (leohardtke) wrote :

Is not work on 12.04 beta 1 with libroxy 0.4.7.

Sharkfinger (sharkfinger) wrote :

This bug also affects me. Cannot use empathy or Ubuntu One. I am able to use APT, synaptic, firefox and chrome by entering the proxy settings into each of those but they are not picked up from the system. I defined them in the system via the 'Network' applet.

Am behind an authenticated corporate squid proxy.

Running ubuntu 11.10, libproxy0 version 0.3.1-2ubuntu6.

tags: added: rls-mgr-p-tracking
Ken VanDine (ken-vandine) wrote :

libproxy has been updated to 0.4.7 and MSN accounts now work behind a squid proxy, but in my testing telepathy-gabble never even tries to talk to my squid proxy.

Ken VanDine (ken-vandine) wrote :

Marking the libproxy task as fix released, since 0.4.7 is in precise now and it functions for at least MSN accounts.

Changed in libproxy (Ubuntu Precise):
assignee: Ken VanDine (ken-vandine) → nobody
status: Confirmed → Fix Released
Changed in telepathy-gabble (Ubuntu Precise):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

OK, so MSN working isn't a good test to see if libproxy is functioning properly, we are now using telepathy-haze for that which uses libpurple. libpurple is probably getting the proxy information from gsettings.

Created attachment 59127
WOCKY_DEBUG=xmpp with contact info stripped out

In my test scenario, I have a local squid proxy properly configured to handle HTTP CONNECT, tested with pidgin and it works. MS Live accounts works as well using telepathy-haze. However attempting to connect to gtalk or jabber.org accounts, according to the squid access log, never attempts to connect to the configured proxy.

Downstream bug report: https://bugs.launchpad.net/ubuntu/precise/+source/telepathy-gabble/+bug/893031

Ken VanDine (ken-vandine) wrote :

Added logs from WOCKY_DEBUG=xmpp

Can you provide your system configuration, and the returned configuration as seen by libproxy:

proxy xmpp-client://myserfer
proxy https://myserfer

HTTP Connect for bare jabber is currently not supported by libproxy (not support fro any non https:// protocols). Also, be aware that Pidgin erroneously reads the HTTP_PROXY rather then SECURE_PROXY gnome setting for doing HTTP Connect.

proxy xmpp-client://myserfer
direct://
proxy https://myserfer
http://localhost:3128

Looking through the gabble source, I don't see anywhere that it uses libproxy, not even an includes for proxy.h. How does it interact with libproxy?

Previously it had been suggested that it wasn't working because our version of libproxy in Ubuntu was too old, 0.3.x. We now have the 0.4.7, the latest and it still doesn't work.

So this isn't a bug so much as it is not supported yet?

(In reply to comment #2)
> proxy xmpp-client://myserfer
> direct://
> proxy https://myserfer
> http://localhost:3128
>
> Looking through the gabble source, I don't see anywhere that it uses libproxy,
> not even an includes for proxy.h. How does it interact with libproxy?
>
> Previously it had been suggested that it wasn't working because our version of
> libproxy in Ubuntu was too old, 0.3.x. We now have the 0.4.7, the latest and
> it still doesn't work.
>
> So this isn't a bug so much as it is not supported yet?

Gabble uses a library called Wocky which is base on GIO. And GIO has a libproxy and gnome plugin. I usually suggest using libproxy for distro that can run both KDE and Gnome on the same install, the Gnome plugin ignores the environment.

Currently the support for HTTP Connect is very restricted because the GIO developers did not agree it was a correct way of doing generic socket proxying. Here is how you can make it work. First thing to know is that wocky will do HTTP Connect only when you are running in Old SSL mode. Which mean the first thing you do is an TLS handshake (so it cannot be differentiated from a HTTPS connection). Then you need a correct configuration, which you have.

If you are using a google account configured with older version of Empathy, I suggest to remove it and re-create it. This will add the fallback-servers parameter to your account. Note that HTTP Connect is never the first, so connection may take a little while depending on how fat the other attempts fails. You can check the params using mc-tool show ... Here's what you should see:
(GStrv) fallback-servers = ["talkx.l.google.com", "talkx.l.google.com:443,oldssl", "talkx.l.google.com:80"]

Unless someone broke the fallbacks, wocky will try the server talk.google.com (use to do SRV, but was changed recently). In case of failure, it will fallback to talkx.l.google.com using normal TLS, if it fails again, it will try talkx.l.google.com:443 using OLD SSL mode, and if that still fails it will try cleartext on port 80 (I think this one always fails these days, not sure).

In the future, libproxy should try HTTP Connect for any type of connection, and have a direct fallback, but that couldn't be done without changing libproxy internals a lot. Also, the HTTP Connect GLIB plugin should be provided by libsoup. Feel free to contribute if you have time.

My account does have the fallback-servers set with oldssl, but does this mean that if it can connect without going through the configured proxy it will do that?

I am not actually required to use the proxy to connect, but set it up just for testing this bug. If it just ignores the proxy setting because it can connect without it, my test environment isn't really good for validating this bug.

(In reply to comment #4)
> My account does have the fallback-servers set with oldssl, but does this mean
> that if it can connect without going through the configured proxy it will do
> that?

With the current implementation, yes.

>
> I am not actually required to use the proxy to connect, but set it up just for
> testing this bug. If it just ignores the proxy setting because it can connect
> without it, my test environment isn't really good for validating this bug.

Right, to test it, you need to isolate yourself from the internet. Maybe you can try by disable dns (comment the nameserver lines in resolve.conf) and set your proxy server dns (if you have one) in /etc/hosts. If the proxy is on the same host, well at least you will see the proxy being called even if it fails in the end.

Should I conclude this bug was invalid ?

riddle (riddlepl) wrote :

Ubuntu 12.04. Latest updates. Still not working :/
This bug should be marked as critical for 12.04 release.

Nithin C (nithin-aneesh) wrote :

Even the beta version Ubuntu 12.04 has the same bug

Created attachment 60534
All-24-04-12_11-03-19.log

I tried that, with no nameserver set. Other apps work fine through the proxy, firefox, ubuntuone, etc. But when connecting with empathy it still doesn't even try to hit the proxy. I am attaching the log.

Zakwan (otaconisme) wrote :

I've upgrade to 12.04 from 11.04. Got no problem before. Now cannot connect behind a proxy.

Sharkfinger (sharkfinger) wrote :

Over 6 months and still not fixed.

Not a particularly helpful comment but wanted to mention I've found a workaround for this bug... I installed Windows 7.

Ladsy (tempo1) wrote :

Hello,

I'm using actually Ubuntu 12.10.
I parameterized succefully several account bye "All Parameters / Account in ligne /" (sorry, perhaps bad translation from me .... the text of my french desktop is : "Tous les paramètres / Comptes en ligne"
- Facebook
- IRC
- SIP
- Windows Live (yes I know, it's bad ... don't hurt me for this)
All was alright and working well.

I installed squid3 (each VM on Virtualbox inside the PC can access to this local proxy cache now with IP 192.168.1.100:3128).
I parameterized this proxy via "All Parameters / Network / Proxy server " ("Tous les paramètres / Network / Serveur mandataire")
So now the parameters are :
- Method : manual
- Proxy HTTP : 127.0.0.1:3128
- Proxy HTTPS : 127.0.0.1:3128
- Proxy FTP : 127.0.0.1:3128
- Hôte Socks : 127.0.0.1:3128

All chat was working well ... until I reboot !
I saw this help : http://anupam128.blogspot.fr/2011/03/using-empathy-behind-proxy.html
I uninstalled : account-plugin-salut, account-plugin-jabber, telepathy-core, telepathy-gnome and reinstalled telepathy-haze.
No help ... no resolve ..

After, I unsetted the proxy in "All parameters / Network"
I disconnected / then reconnected.
Empathy is working well without proxy, even the manipulation of paquet suppression.

If I set proxy another time, then disconnect / reconnect ... KO impossible to have any connection on the chat.

Waiting, my only solution is to unset the proxy ...
Parameterize the /etc/apt/apt.conf.d/02proxy for have a "cache" on the PC to proxing the VMs.
Parameterize firefox ... and work without any proxy with chromium ... bad.

Thanks for your help.

Not working behind the proxy on ubuntu 12.04 (just to inform)

Changed in telepathy-gabble (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in telepathy-gabble (Ubuntu Precise):
assignee: Ken VanDine (ken-vandine) → nobody
Dirley Rodrigues (dirleyrls) wrote :

I can confirm this was still not fixed in Ubuntu 12.10.

description: updated
summary: - Empathy is not working behind the proxy servers in Ubuntu 11.10
+ Empathy is not working behind the proxy servers SINCE Ubuntu 11.10
david.barbion (david-barbion) wrote :

Same here. I've configured all envionment variables and nothing works...
Env vars are http_proxy https_proxy and ftp_proxy.

Nithin C (nithin-aneesh) wrote :

I can actually connect to chat accounts in Ubuntu 12.10 via Pidgin. I am using the settings described here. http://nithinaneeshsct06bt.blogspot.in/2012/12/facebook-and-gtalk-via-pidgin-in-ubuntu.html
I didn't try with empathy but it works fine with Pidgin.

I'm so surprised that nobody from the UBUNTU team can't take care of this problem which is:
- old
- confirmed
- should be a staple feature of any OS

Probably that you are busy working on mobile features that nobody use?

I'm sorry, I love free softwares, but sometimes, it is really frustrating.
Nicolas

Nithin C (nithin-aneesh) wrote :

Dear Nicholas,

      I had this problem in Ubuntu 11.10 but it is no longer there in Ubuntu 12.10 or 13.04 (beta 2). I am able to connect all programs via proxy. I think the fix was committed almost one year back.

Nithin C

Changed in telepathy-gabble (Ubuntu):
status: Confirmed → Fix Released
Dan Jared (danjaredg) wrote :

the bug affect the 13.04 version

Rui Cunha (cunha-rui) wrote :

I'm still having that problem since 12.04, currently on 13.04.

I'm running 13.04 (upgrading since 12.04) , bug still exists

-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/telepathy/telepathy-gabble/issues/221.

Changed in telepathy-gabble:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.