"Facebook Requires Authorization" when already authorized

Bug #1170832 reported by bwat47 on 2013-04-19
472
This bug affects 110 people
Affects Status Importance Assigned to Milestone
telepathy-gabble
Fix Released
Medium
telepathy-gabble (Debian)
Fix Released
Unknown
telepathy-gabble (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

I am running fully updated 13.04 64-bit. I simply cannot get empathy/UOA to connect to facebook. When I add the account in UOA everything seems to go well, facebook login page loads, it logs in successfully, facebook recognizes the session as "safari on linux"; but upon completing the setup in UOA empathy refuses to connect to it and keeps telling me it requires authorization.

I've Tried the following: Removing the account from UOA
Ending all active sessions on facebook and deleting the ubuntu app
rebooting
adding account in UOA, and allowing the ubuntu app to manage my messages etc...

Didn't help at all. pidgin connects fine on the same computer.

Sometimes it does let me add it and it works for a while, but eventually this issue happens again and leaves me totally unable to successfully add a facebook account for quite some time, until it randomly decides it wants to work again. Empathy/UOA in 13.04 has been unreliable to the point of ridiculousness, the application is basically unusable and can't handle the one basic task of an instant messaging program, which is connecting to my accounts reliably.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: empathy 3.6.4-0ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Fri Apr 19 16:57:50 2013
InstallationDate: Installed on 2013-04-17 (1 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130416)
MarkForUpload: True
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

bwat47 (bwat47) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Sergio Agudelo (seagudelobe) wrote :

This affects me too, although I'm not using Pidgin. I am running 13.04 as well

Serafin Nunez (sjnunez3) wrote :

I had this problem under 12.10 and am having it again under 13.04. This happens every time I log in to Ubuntu but also happens intermittently whiled logged in.

capnasty (leo-con) wrote :

I've been having this problem on both computers, one running 12.10 and one running 13.04. Google Talk and MSN Messenger have often requested me to re-validate, too, but that's it, it works. With Facebook you have to go through hoops and prayers to see if today is the lucky day it will work. It seems like Empathy is regressing with each new version.

still (alex512) wrote :

You can check that solution:
Login to your fb page. Go to Account Settings Apps https://www.facebook.com/settings?tab=applications. Edit Ubuntu and change "When to notify you?" to Never.

Aaron Gerber (agerber85) wrote :

The suggested solution stops Empathy for asking for authorisation. However, FB contacts still aren't displayed.

Andrea Pivetta (vanpivix) wrote :

Also for me, sometimes facebook works, sometimes not.
I use only Empathy in only one computer at a time

Created attachment 85035
Patch for wocky

Right now connecting to the new Facebook server we send a disco request to chat.facebook.com. The new server responds omitting the from from in the reply.

This causes gabble to reject the reply and then disconnect because we had no DISCO reply.

Attached patch fixes this.

--

The patch could also be done by using

+stanza_is_from_server(self, should_be_from)

in the if clause below.
I chose this way to be more explicit, but the other way is maybe simpler.

Comment on attachment 85035
Patch for wocky

Review of attachment 85035:
-----------------------------------------------------------------

What's the worst that can happen?

RFC 6120 §8.1.2.1 says:

   2. When the server generates a stanza on its own behalf for delivery
       to the client from the server itself, the stanza MUST include a
       'from' attribute whose value is the bare JID

so this is not RFC-compliant XMPP. (Interop > RFC pedantry in situations where it doesn't harm security, though.)

Also,

   4. A server MUST NOT send to the client a stanza without a 'from'
       attribute if the stanza was not generated by the server on its
       own behalf

so if the server obeys §8.1.2.1.4, the worst that can happen with this change is that we see a stanza generated by the server on behalf of our account and we wrongly accept it as a valid stanza generated by the server itself, which is what we need to do to fix this interop bug.

So, I'm OK with this change in principle.

::: wocky/wocky-c2s-porter.c
@@ +859,5 @@
> goto finally;
> }
>
> + /** If we sent an IQ to the server allow the server to omit 'to'
> + * in the reply. */

omit 'from', surely?

/** is for doc-comments consumed by gtk-doc, not for ordinary comments.

Please do mention that the Facebook server now does this (preferably with "see fd.o #68829" or the URL of the bug) and that we would normally interpret this as coming from "the server on behalf of our account". Something like this:

  /* If we sent an IQ to the server itself, allow it to
   * omit 'from' in its reply, which is normally used
   * for messages from the server on behalf of our own
   * account (as of 2013-09-02, the Facebook server does
   * this). See fd.o #68829 */

The server is still returning valid disco information about itself, not about our account, I hope?

Thanks will update patch.

Disco requests/responses attached for future reference.

Facebook's beta server for me returns the following on a disco request

<!-- sent -->
<iq id="327894361669" to="beta.chat.facebook.com" type="get" xmlns="jabber:client">
 <query xmlns="http://jabber.org/protocol/disco#info"/>
</iq>

<!-- received -->
<iq id="327894361669" type="result" xmlns="jabber:client">
 <query xmlns="http://jabber.org/protocol/disco#info">
  <identity category="server" type="Facebook XMPP"/>
  <feature var="http://jabber.org/protocol/commands"/>
  <feature var="http://jabber.org/protocol/chatstates"/>
  <feature var="vcard-temp"/>
 </query>
</iq>

requesting disco info chat.facebook.com is the same

<!-- sent -->
<iq id="67671632942" to="chat.facebook.com" type="get" xmlns="jabber:client">
 <query xmlns="http://jabber.org/protocol/disco#info"/>
</iq>

<!-- received -->
<iq id="67671632942" type="result" xmlns="jabber:client">
 <query xmlns="http://jabber.org/protocol/disco#info">
  <identity category="server" type="Facebook XMPP"/>
  <feature var="http://jabber.org/protocol/commands"/>
  <feature var="http://jabber.org/protocol/chatstates"/>
  <feature var="vcard-temp"/>
 </query>
</iq>

I know Facebook rolls out services gradually, and some of my user's are hitting the same error that I am currently getting with the beta service so I suspect this will hit most user's soon.

Created attachment 85203
Updated patch

Thanks, I merged your patch to the Wocky 'master' and 'gabble-0.18' branches.

Should be in telepathy-gabble 0.18.1 and 0.19.0.

I just released telepathy-gabble 0.18.1 including this fix.

(In reply to comment #2)
> Facebook's beta server for me returns the following on a disco request
>
> <!-- sent -->
> <iq id="327894361669" to="beta.chat.facebook.com" type="get"

Are you explicitly connecting to beta.chat.facebook.com, or getting directed there via resource binding? I notice that Gabble's special cases for Facebook are all based on the stream server being "chat.facebook.com"...

I was explicitly using beta.chat.facebook.com in order to reproduce this issue and for the the IQ stanzas I posted.

Other reporters on KDE forums who appeared to have this issue were using standard chat.facebook.com. One user verified this patch solved their problem.

Reopening to fix in older branches - I need a backport for Debian anyway.

Created attachment 85494
Add a regression test for #68829

---

This passes on 0.18 and master. I haven't tried 0.16 yet.

(In reply to comment #9)
> Created attachment 85494
> Add a regression test for #68829
>
> ---
>
> This passes on 0.18 and master. I haven't tried 0.16 yet.

Also works fine on 0.16 when I cherry-pick David's Wocky patch. I'd like to do a 0.16.7 release with this: hopefully the Debian release team will let me ship that, rather than messing about with a patch series (which is annoying because Wocky is a submodule).

Comment on attachment 85494
Add a regression test for #68829

Review of attachment 85494:
-----------------------------------------------------------------

++

The same problem occurs to me on Ubuntu 13.04! I have tried removing-reinstalling empathy, Facebook Accounts Plugin, UOA; I have also deleted any temporary files using BleachBit. Nothing seems to fix the problem...
Furthermore, I noticed that the Unity Menu Tab responsible of displaying Facebook News works fine. The problem is localized to Empathy Messenger when trying to connect to a Facebook account which happens to have 2-Step Verification turned on. Is there any possibility that the Authentication Tokens (when you start Seahorse, you can see two) are mixed up after a while? Each time they are updated, their number is changed (i.e. Ubuntu Web account: id #-#); I imagine that Empathy might be looking for older tokens than the current, because this problem occurs usually after 15 days (the normal time between account re-authorisations).
It's high time someone fixed this bug! I'm bored stumbling upon this particular problem since I installed this last version of Ubuntu; and it's is a pity, because it's far the best Linux Distribution out there!!! :D
Thanks in advance...

Bruno Jesus (brunojesus) wrote :

When will someone fix this bug? It's happening to me on Ubuntu GNOME 13.04...

A patch has been worked out upstream apparently:

https://bugs.freedesktop.org/show_bug.cgi?id=68829

affects: empathy (Ubuntu) → telepathy-gabble (Ubuntu)

The new version of telepathy-gabble v0.18.1 landed on Fedora 19 recently. I cofirm it fixed the Facebook issue. Same version also landed in debian unstable.

Changed in telepathy-gabble:
importance: Unknown → Medium
status: Unknown → In Progress

Confirmation the fix is working in the debian unstable package. Should make it in Saucy as part of the debian unstable sync, but should consider backporting this patch to the versions in 12.04, 12.10 and 13.04.

Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package telepathy-gabble - 0.18.1-1

---------------
telepathy-gabble (0.18.1-1) unstable; urgency=low

  * New upstream stable release
    - work around Facebook server behaviour change so we don't consider its
      service discovery response to be spoofed (Closes: #721883)

 -- Simon McVittie <email address hidden> Mon, 09 Sep 2013 13:05:13 +0100

Changed in telepathy-gabble (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Jeremy Bicha (jbicha) on 2013-09-10
affects: empathy → empathy (Ubuntu)
Changed in empathy (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-09-10
no longer affects: empathy (Ubuntu)
Changed in telepathy-gabble (Ubuntu Raring):
status: New → Triaged
importance: Undecided → Medium
Changed in telepathy-gabble (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → Medium
Changed in telepathy-gabble (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
Changed in telepathy-gabble (Debian):
status: Unknown → Fix Released
Martin Wiebusch (mwiebusch78) wrote :

I installed the telepathy-gabble_0.18.1-1_amd64.deb package from https://launchpad.net/ubuntu/saucy/amd64/telepathy-gabble/0.18.1-1 under Ubuntu 13.04, but the problem still persists.

Dale Borum (darthearon) wrote :

same thing. on 13.04, tried all fixes in this artacle and nothing. with the new telepathy-gabble. i have attached the output from my empathy-debugger...not sure if that helps

Jeremy Bicha (jbicha) on 2013-09-12
Changed in telepathy-gabble (Ubuntu Saucy):
status: Fix Released → Confirmed
importance: Undecided → Medium
aaron-bru (aaron-bru) wrote :

telepathy-gabble_0.18.1-1_amd64.deb did not fix it for me either, still the same as before.

This was merged in the 0.16.x "old-stable" branch too, it's just waiting for a release (0.16.7).

The same code might need similar modifications for Bug #39057.

Changed in telepathy-gabble:
status: In Progress → Fix Released
Miguel (xadrezmiguelpires) wrote :

Any news about this bug?

manfreed (manfreed) wrote :

Hi! I'm running 13.10 with the latest updates, I experience this issue.

Michel Filipe (mfilipe) wrote :

I have the same problem using ubuntu-13.04 with empathy-3.6.4.

Berat Alp Erbil (beratalp) wrote :

Problem still persists on Ubuntu 13.10.

     <setting name="ClientId">302061903208115</setting>
     <setting type="as" name="AllowedSchemes">['https','http']</setting>
</group>

Above code is the part of facebook.provider in my system(13.04 64bit). I am
allowing http connection (response from facebook) but still it's not
working.

On Sat, Oct 5, 2013 at 7:12 PM, Berat Alp Erbil
<email address hidden>wrote:

> Problem still persists on Ubuntu 13.10.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1222124).
> https://bugs.launchpad.net/bugs/1170832
>
> Title:
> "Facebook Requires Authorization" when already authorized
>
> Status in Jabber/XMPP connection manager:
> Fix Released
> Status in “telepathy-gabble” package in Ubuntu:
> Confirmed
> Status in “telepathy-gabble” source package in Precise:
> Triaged
> Status in “telepathy-gabble” source package in Quantal:
> Triaged
> Status in “telepathy-gabble” source package in Raring:
> Triaged
> Status in “telepathy-gabble” source package in Saucy:
> Confirmed
> Status in “telepathy-gabble” package in Debian:
> Fix Released
>
> Bug description:
> I am running fully updated 13.04 64-bit. I simply cannot get
> empathy/UOA to connect to facebook. When I add the account in UOA
> everything seems to go well, facebook login page loads, it logs in
> successfully, facebook recognizes the session as "safari on linux";
> but upon completing the setup in UOA empathy refuses to connect to it
> and keeps telling me it requires authorization.
>
> I've Tried the following: Removing the account from UOA
> Ending all active sessions on facebook and deleting the ubuntu app
> rebooting
> adding account in UOA, and allowing the ubuntu app to manage my messages
> etc...
>
> Didn't help at all. pidgin connects fine on the same computer.
>
> Sometimes it does let me add it and it works for a while, but
> eventually this issue happens again and leaves me totally unable to
> successfully add a facebook account for quite some time, until it
> randomly decides it wants to work again. Empathy/UOA in 13.04 has been
> unreliable to the point of ridiculousness, the application is
> basically unusable and can't handle the one basic task of an instant
> messaging program, which is connecting to my accounts reliably.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.04
> Package: empathy 3.6.4-0ubuntu3
> ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
> Uname: Linux 3.8.0-19-generic x86_64
> ApportVersion: 2.9.2-0ubuntu8
> Architecture: amd64
> Date: Fri Apr 19 16:57:50 2013
> InstallationDate: Installed on 2013-04-17 (1 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64
> (20130416)
> MarkForUpload: True
> ProcEnviron:
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: empathy
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/telepathy-gabble/+bug/1170832/+subscriptions
>

Dan Jared (danjaredg) wrote :

Problem still persists on Ubuntu 13.10. any solution?

  • empathy.log Edit (1.1 MiB, text/x-log; charset=UTF-8; name="empathy.log")
  • gabble.log Edit (70.1 KiB, text/x-log; charset=US-ASCII; name="gabble.log")

I log empathy with only facebook account (http enable in
facebook.provider). I found that empathy able to fetch my fb contacts but i
am not sure it is throwing error. I am attaching empathy and
telepathy-gabble log, may be this will help.

On Tue, Oct 22, 2013 at 10:16 AM, Dan Jared <email address hidden>wrote:

> Problem still persists on Ubuntu 13.10. any solution?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1222124).
> https://bugs.launchpad.net/bugs/1170832
>
> Title:
> "Facebook Requires Authorization" when already authorized
>
> Status in Jabber/XMPP connection manager:
> Fix Released
> Status in “telepathy-gabble” package in Ubuntu:
> Confirmed
> Status in “telepathy-gabble” source package in Precise:
> Triaged
> Status in “telepathy-gabble” source package in Quantal:
> Triaged
> Status in “telepathy-gabble” source package in Raring:
> Triaged
> Status in “telepathy-gabble” source package in Saucy:
> Confirmed
> Status in “telepathy-gabble” package in Debian:
> Fix Released
>
> Bug description:
> I am running fully updated 13.04 64-bit. I simply cannot get
> empathy/UOA to connect to facebook. When I add the account in UOA
> everything seems to go well, facebook login page loads, it logs in
> successfully, facebook recognizes the session as "safari on linux";
> but upon completing the setup in UOA empathy refuses to connect to it
> and keeps telling me it requires authorization.
>
> I've Tried the following: Removing the account from UOA
> Ending all active sessions on facebook and deleting the ubuntu app
> rebooting
> adding account in UOA, and allowing the ubuntu app to manage my messages
> etc...
>
> Didn't help at all. pidgin connects fine on the same computer.
>
> Sometimes it does let me add it and it works for a while, but
> eventually this issue happens again and leaves me totally unable to
> successfully add a facebook account for quite some time, until it
> randomly decides it wants to work again. Empathy/UOA in 13.04 has been
> unreliable to the point of ridiculousness, the application is
> basically unusable and can't handle the one basic task of an instant
> messaging program, which is connecting to my accounts reliably.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.04
> Package: empathy 3.6.4-0ubuntu3
> ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
> Uname: Linux 3.8.0-19-generic x86_64
> ApportVersion: 2.9.2-0ubuntu8
> Architecture: amd64
> Date: Fri Apr 19 16:57:50 2013
> InstallationDate: Installed on 2013-04-17 (1 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64
> (20130416)
> MarkForUpload: True
> ProcEnviron:
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: empathy
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/telepathy-gabble/+bug/1170832/+subscriptions
>

cuby (cuby) wrote :

The problem persists in Ubuntu 13.10. I think this bug affects a lot of users, so it should be addressed.

last fixed released of telepathy-gabble doesn't fix the issue. Issue still exists. (ubuntu 13.10 64bit). I have installed telepathy-gabble from source but issue is not fixed.

bug fixed in version 3.8.4-1ubuntu2

On Wed, Oct 30, 2013 at 9:32 PM, shantanu saha
<email address hidden>wrote:

> last fixed released of telepathy-gabble doesn't fix the issue. Issue
> still exists. (ubuntu 13.10 64bit). I have installed telepathy-gabble
> from source but issue is not fixed.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1222124).
> https://bugs.launchpad.net/bugs/1170832
>
> Title:
> "Facebook Requires Authorization" when already authorized
>
> Status in Jabber/XMPP connection manager:
> Fix Released
> Status in “telepathy-gabble” package in Ubuntu:
> Confirmed
> Status in “telepathy-gabble” source package in Precise:
> Triaged
> Status in “telepathy-gabble” source package in Quantal:
> Triaged
> Status in “telepathy-gabble” source package in Raring:
> Triaged
> Status in “telepathy-gabble” source package in Saucy:
> Confirmed
> Status in “telepathy-gabble” package in Debian:
> Fix Released
>
> Bug description:
> I am running fully updated 13.04 64-bit. I simply cannot get
> empathy/UOA to connect to facebook. When I add the account in UOA
> everything seems to go well, facebook login page loads, it logs in
> successfully, facebook recognizes the session as "safari on linux";
> but upon completing the setup in UOA empathy refuses to connect to it
> and keeps telling me it requires authorization.
>
> I've Tried the following: Removing the account from UOA
> Ending all active sessions on facebook and deleting the ubuntu app
> rebooting
> adding account in UOA, and allowing the ubuntu app to manage my messages
> etc...
>
> Didn't help at all. pidgin connects fine on the same computer.
>
> Sometimes it does let me add it and it works for a while, but
> eventually this issue happens again and leaves me totally unable to
> successfully add a facebook account for quite some time, until it
> randomly decides it wants to work again. Empathy/UOA in 13.04 has been
> unreliable to the point of ridiculousness, the application is
> basically unusable and can't handle the one basic task of an instant
> messaging program, which is connecting to my accounts reliably.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.04
> Package: empathy 3.6.4-0ubuntu3
> ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
> Uname: Linux 3.8.0-19-generic x86_64
> ApportVersion: 2.9.2-0ubuntu8
> Architecture: amd64
> Date: Fri Apr 19 16:57:50 2013
> InstallationDate: Installed on 2013-04-17 (1 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64
> (20130416)
> MarkForUpload: True
> ProcEnviron:
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: empathy
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/telepathy-gabble/+bug/1170832/+subscriptions
>

Angelo Pantano (ghilteras) wrote :

3.8.4-1ubuntu2 of what package?

anyway the bug is still present on saucy, cant connect to google because it keeps asking for authorization.

empathy 3.8.4-1ubuntu2 fixed the facebook authentication problem. Google is
also working fine.

On Mon, Nov 18, 2013 at 5:28 PM, Angelo Pantano <email address hidden> wrote:

> 3.8.4-1ubuntu2 of what package?
>
> anyway the bug is still present on saucy, cant connect to google because
> it keeps asking for authorization.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1222124).
> https://bugs.launchpad.net/bugs/1170832
>
> Title:
> "Facebook Requires Authorization" when already authorized
>
> Status in Jabber/XMPP connection manager:
> Fix Released
> Status in “telepathy-gabble” package in Ubuntu:
> Confirmed
> Status in “telepathy-gabble” source package in Precise:
> Triaged
> Status in “telepathy-gabble” source package in Quantal:
> Triaged
> Status in “telepathy-gabble” source package in Raring:
> Triaged
> Status in “telepathy-gabble” source package in Saucy:
> Confirmed
> Status in “telepathy-gabble” package in Debian:
> Fix Released
>
> Bug description:
> I am running fully updated 13.04 64-bit. I simply cannot get
> empathy/UOA to connect to facebook. When I add the account in UOA
> everything seems to go well, facebook login page loads, it logs in
> successfully, facebook recognizes the session as "safari on linux";
> but upon completing the setup in UOA empathy refuses to connect to it
> and keeps telling me it requires authorization.
>
> I've Tried the following: Removing the account from UOA
> Ending all active sessions on facebook and deleting the ubuntu app
> rebooting
> adding account in UOA, and allowing the ubuntu app to manage my messages
> etc...
>
> Didn't help at all. pidgin connects fine on the same computer.
>
> Sometimes it does let me add it and it works for a while, but
> eventually this issue happens again and leaves me totally unable to
> successfully add a facebook account for quite some time, until it
> randomly decides it wants to work again. Empathy/UOA in 13.04 has been
> unreliable to the point of ridiculousness, the application is
> basically unusable and can't handle the one basic task of an instant
> messaging program, which is connecting to my accounts reliably.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.04
> Package: empathy 3.6.4-0ubuntu3
> ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
> Uname: Linux 3.8.0-19-generic x86_64
> ApportVersion: 2.9.2-0ubuntu8
> Architecture: amd64
> Date: Fri Apr 19 16:57:50 2013
> InstallationDate: Installed on 2013-04-17 (1 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64
> (20130416)
> MarkForUpload: True
> ProcEnviron:
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: empathy
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/telepathy-gabble/+bug/1170832/+subscriptions
>

Christian Elkjaer (c.elkjaer) wrote :
Download full text (3.7 KiB)

I can confirm that the facebook authentication bug is fixed in empathy
3.8.4-1ubuntu2 (saucy). Big thanks! :)

2013/11/18 shantanu saha <email address hidden>

> empathy 3.8.4-1ubuntu2 fixed the facebook authentication problem. Google is
> also working fine.
>
>
> On Mon, Nov 18, 2013 at 5:28 PM, Angelo Pantano <email address hidden>
> wrote:
>
> > 3.8.4-1ubuntu2 of what package?
> >
> > anyway the bug is still present on saucy, cant connect to google because
> > it keeps asking for authorization.
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1222124).
> > https://bugs.launchpad.net/bugs/1170832
> >
> > Title:
> > "Facebook Requires Authorization" when already authorized
> >
> > Status in Jabber/XMPP connection manager:
> > Fix Released
> > Status in “telepathy-gabble” package in Ubuntu:
> > Confirmed
> > Status in “telepathy-gabble” source package in Precise:
> > Triaged
> > Status in “telepathy-gabble” source package in Quantal:
> > Triaged
> > Status in “telepathy-gabble” source package in Raring:
> > Triaged
> > Status in “telepathy-gabble” source package in Saucy:
> > Confirmed
> > Status in “telepathy-gabble” package in Debian:
> > Fix Released
> >
> > Bug description:
> > I am running fully updated 13.04 64-bit. I simply cannot get
> > empathy/UOA to connect to facebook. When I add the account in UOA
> > everything seems to go well, facebook login page loads, it logs in
> > successfully, facebook recognizes the session as "safari on linux";
> > but upon completing the setup in UOA empathy refuses to connect to it
> > and keeps telling me it requires authorization.
> >
> > I've Tried the following: Removing the account from UOA
> > Ending all active sessions on facebook and deleting the ubuntu app
> > rebooting
> > adding account in UOA, and allowing the ubuntu app to manage my
> messages
> > etc...
> >
> > Didn't help at all. pidgin connects fine on the same computer.
> >
> > Sometimes it does let me add it and it works for a while, but
> > eventually this issue happens again and leaves me totally unable to
> > successfully add a facebook account for quite some time, until it
> > randomly decides it wants to work again. Empathy/UOA in 13.04 has been
> > unreliable to the point of ridiculousness, the application is
> > basically unusable and can't handle the one basic task of an instant
> > messaging program, which is connecting to my accounts reliably.
> >
> > ProblemType: Bug
> > DistroRelease: Ubuntu 13.04
> > Package: empathy 3.6.4-0ubuntu3
> > ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
> > Uname: Linux 3.8.0-19-generic x86_64
> > ApportVersion: 2.9.2-0ubuntu8
> > Architecture: amd64
> > Date: Fri Apr 19 16:57:50 2013
> > InstallationDate: Installed on 2013-04-17 (1 days ago)
> > InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64
> > (20130416)
> > MarkForUpload: True
> > ProcEnviron:
> > PATH=(custom, no user)
> > XDG_RUNTIME_DIR=<set>
> > LANG=en_US.UTF-8
> > SHELL=/bin/bash
> > SourcePackage: empathy
> > UpgradeStatus: No upgrade log present (proba...

Read more...

Adolfo Jayme (fitojb) on 2014-09-04
no longer affects: telepathy-gabble (Ubuntu Quantal)
no longer affects: telepathy-gabble (Ubuntu Raring)
no longer affects: telepathy-gabble (Ubuntu Saucy)
Changed in telepathy-gabble (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.