Ubuntu

New bug fix releases: 9.1.2, 8.4.10, 8.3.17

Reported by Martin Pitt on 2011-12-15
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned
postgresql-8.3 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
postgresql-8.4 (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
Precise
Undecided
Unassigned
postgresql-9.1 (Ubuntu)
Oneiric
Medium
Martin Pitt
Precise
Undecided
Unassigned

Bug Description

PostgreSQL published new microreleases ten days ago: http://www.postgresql.org/about/news/1366/

As per the standing microrelease exception these should go into stables. I didn't see any regression report or major problem with these so far, so it's time to get them into -proposed.

Martin Pitt (pitti) wrote :

postgresql-9.1 | 9.1.2-1 | precise | source, amd64, armel, armhf, i386, powerpc

no longer affects: postgresql-8.3 (Ubuntu Lucid)
no longer affects: postgresql-8.3 (Ubuntu Maverick)
no longer affects: postgresql-8.3 (Ubuntu Natty)
no longer affects: postgresql-8.4 (Ubuntu Hardy)
no longer affects: postgresql-8.3 (Ubuntu Oneiric)
no longer affects: postgresql-9.1 (Ubuntu)
no longer affects: postgresql-8.3 (Ubuntu Precise)
no longer affects: postgresql-9.1 (Ubuntu Hardy)
no longer affects: postgresql-9.1 (Ubuntu Natty)
no longer affects: postgresql-9.1 (Ubuntu Maverick)
no longer affects: postgresql-8.4 (Ubuntu Oneiric)
Changed in postgresql-8.3 (Ubuntu):
status: New → Invalid
Changed in postgresql-9.1 (Ubuntu Precise):
status: New → Fix Released
Martin Pitt (pitti) wrote :

postgresql-8.4 | 8.4.10-1 | precise/universe | source, amd64, armel, i386, powerpc

Changed in postgresql-8.4 (Ubuntu Precise):
status: New → Fix Released
no longer affects: postgresql-9.1 (Ubuntu Lucid)
Changed in postgresql-9.1 (Ubuntu Oneiric):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → In Progress

Hello Martin, or anyone else affected,

Accepted postgresql-8.3 into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in postgresql-8.3 (Ubuntu Hardy):
status: New → Fix Committed
tags: added: verification-needed
Changed in postgresql-8.4 (Ubuntu Lucid):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-8.4 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-8.4 into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in postgresql-8.4 (Ubuntu Maverick):
status: New → Fix Committed
Changed in postgresql-8.4 (Ubuntu Natty):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-8.4 into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Hello Martin, or anyone else affected,

Accepted postgresql-9.1 into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in postgresql-9.1 (Ubuntu Oneiric):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 * Trying to backport postgresql-8.4...
I: Extracting postgresql-8.4_8.4.10-1.dsc ... done.
I: Building backport of postgresql-8.4 as 8.4.10-1~hardy1 ... done.

Changed in hardy-backports:
status: New → Fix Released
Martin Pitt (pitti) wrote :

I reuploaded the oneiric version to also include the fix for bug 904828, so that we can actually build the package on our current builders (and of course make postgresql work on Panda boards in the first place). I did not apply the fix to lucid/maverick/natty yet, will do that in the next round. This time I just forced them to build on a babbage board.

Martin Pitt (pitti) wrote :

I ran the p-common test suite in lucid and hardy, they pass.

tags: added: verification-done-hardy verification-done-lucid
Martin Pitt (pitti) wrote :

Ran p-common tests for oneiric, pass.

tags: added: verification-done-oneiric
Martin Pitt (pitti) wrote :

Tested natty and maverick as well now.

tags: added: verification-done
removed: verification-done-hardy verification-done-lucid verification-done-oneiric verification-needed
Scott Kitterman (kitterman) wrote :

There is a regression in 9.0.6 and 9.1.2 that has been succinctly described to me as:

"run any of the latest "stable" postgres versions + use indexed inet columns = fail"

A fix for this issue has been committed upstream and I understand a new release is forthcoming. In the meantime, I don't think 9.1.2 should be copied to updates (thus the verification failed).

tags: added: verification-failed-oneiric
Martin Pitt (pitti) wrote :

This is most likely referring to http://archives.postgresql.org/pgsql-bugs/2011-12/msg00068.php.

Trunk fix:
http://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=8409b60476a4112e654d1a5099dd67a54f197afd

This was also backported to the 9.1 and 8.4 branches, so I think we should hold back all pending SRUs because of this, not just oneiric.

tags: added: regression-proposed verification-failed
removed: verification-done verification-failed-oneiric

It might be worth considering if the SRU tests should be enhanced to catch
issues like this. I only caught it because a project I'm working on tripped
over it on BSD.

Martin Pitt (pitti) wrote :

I uploaded new versions to -proposed which fix the problem above.

tags: added: verification-needed
removed: regression-proposed verification-failed
Martin Pitt (pitti) wrote :

I ran the p-common regression tests against yesterday's fixed packages in all releases successfully. Upstream tests also succeeded on all architectures for all releases.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package postgresql-8.3 - 8.3.17-0ubuntu0.8.04.1

---------------
postgresql-8.3 (8.3.17-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * Add 00git_inet_cidr_unpack.patch: Revert the behavior of inet/cidr
    functions to not unpack the arguments. This fixes the memory leak when
    sorting inet values. Patch taken from upstream git HEAD. Spotted during
    testing in LP #904631.

postgresql-8.3 (8.3.17-0ubuntu0.8.04) hardy-proposed; urgency=low

  * New upstream bug fix release: (LP: #904631)
    - Fix bugs in information_schema.referential_constraints view.
      This view was being insufficiently careful about matching the
      foreign-key constraint to the depended-on primary or unique key
      constraint. That could result in failure to show a foreign key
      constraint at all, or showing it multiple times, or claiming that
      it depends on a different constraint than the one it really does.
      Since the view definition is installed by initdb, merely upgrading
      will not fix the problem. If you need to fix this in an existing
      installation, you can (as a superuser) drop the information_schema
      schema then re-create it by sourcing
      "SHAREDIR/information_schema.sql". (Run pg_config --sharedir if
      you're uncertain where "SHAREDIR" is.) This must be repeated in
      each database to be fixed.
    - Fix TOAST-related data corruption during CREATE TABLE dest AS
      SELECT - FROM src or INSERT INTO dest SELECT * FROM src.
      If a table has been modified by "ALTER TABLE ADD COLUMN", attempts
      to copy its data verbatim to another table could produce corrupt
      results in certain corner cases. The problem can only manifest in
      this precise form in 8.4 and later, but we patched earlier versions
      as well in case there are other code paths that could trigger the
      same bug.
    - Fix race condition during toast table access from stale syscache
      entries. The typical symptom was transient errors like "missing chunk
      number 0 for toast value NNNNN in pg_toast_2619", where the cited toast
      table would always belong to a system catalog.
    - Make DatumGetInetP() unpack inet datums that have a 1-byte header,
      and add a new macro, DatumGetInetPP(), that does not.
    - Improve locale support in money type's input and output.
      Aside from not supporting all standard lc_monetary formatting
      options, the input and output functions were inconsistent, meaning
      there were locales in which dumped money values could not be
      re-read.
    - Don't let transform_null_equals affect CASE foo WHEN NULL ...
      constructs.
    - Change foreign-key trigger creation order to better support
      self-referential foreign keys.
    - Avoid floating-point underflow while tracking buffer allocation
      rate.
    - Preserve blank lines within commands in psql's command history.
      The former behavior could cause problems if an empty line was
      removed from within a string literal, for example.
    - Fix pg_dump to dump user-defined casts between auto-generated
      types, such as table rowtypes.
    - Use the preferred version of xsubpp to bu...

Read more...

Changed in postgresql-8.3 (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.6 KiB)

This bug was fixed in the package postgresql-9.1 - 9.1.2-0ubuntu0.11.10.2

---------------
postgresql-9.1 (9.1.2-0ubuntu0.11.10.2) oneiric-proposed; urgency=low

  * Add 00git_inet_cidr_unpack.patch: Revert the behavior of inet/cidr
    functions to not unpack the arguments. This fixes the memory leak when
    sorting inet values. Patch taken from upstream git HEAD. Spotted during
    testing in LP #904631.

postgresql-9.1 (9.1.2-0ubuntu0.11.10.1) oneiric-proposed; urgency=low

  * 01-armel-tas.patch: Turn slock_t datatype into an int, and define
    S_UNLOCK() to call __sync_lock_release() instead of using the default
    implementation. This complies to the gcc built-in atomic operations
    specifiction more strictly and now also works on the Panda boards.
    (LP: #904828)

postgresql-9.1 (9.1.2-0ubuntu0.11.10) oneiric-proposed; urgency=low

  * New upstream release (LP: #904631):
    - Fix bugs in information_schema.referential_constraints view.
      This view was being insufficiently careful about matching the
      foreign-key constraint to the depended-on primary or unique key
      constraint. That could result in failure to show a foreign key
      constraint at all, or showing it multiple times, or claiming that
      it depends on a different constraint than the one it really does.
      Since the view definition is installed by initdb, merely upgrading
      will not fix the problem. If you need to fix this in an existing
      installation, you can (as a superuser) drop the information_schema
      schema then re-create it by sourcing
      "SHAREDIR/information_schema.sql". (Run pg_config --sharedir if
      you're uncertain where "SHAREDIR" is.) This must be repeated in
      each database to be fixed.
    - Make "contrib/citext"'s upgrade script fix collations of citext
      columns and indexes.
      Existing citext columns and indexes aren't correctly marked as
      being of a collatable data type during pg_upgrade from a pre-9.1
      server. That leads to operations on them failing with errors such
      as "could not determine which collation to use for string
      comparison". This change allows them to be fixed by the same script
      that upgrades the citext module into a proper 9.1 extension during
      CREATE EXTENSION citext FROM unpackaged.
      If you have a previously-upgraded database that is suffering from
      this problem, and you already ran the "CREATE EXTENSION" command,
      you can manually run (as superuser) the "UPDATE" commands found at
      the end of "SHAREDIR/extension/citext--unpackaged--1.0.sql". (Run
      pg_config --sharedir if you're uncertain where "SHAREDIR" is.)
    - Fix possible crash during "UPDATE" or "DELETE" that joins to the
      output of a scalar-returning function.
    - Fix incorrect replay of WAL records for GIN index updates.
    - Fix TOAST-related data corruption during CREATE TABLE dest AS
      SELECT - FROM src or INSERT INTO dest SELECT * FROM src.
    - Fix possible failures during hot standby startup.
    - Start hot standby faster when initial snapshot is incomplete.
    - Fix race condition during toast table access from stale syscache
      entries. The ...

Read more...

Changed in postgresql-9.1 (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package postgresql-8.4 - 8.4.10-0ubuntu0.10.04.1

---------------
postgresql-8.4 (8.4.10-0ubuntu0.10.04.1) lucid-proposed; urgency=low

  * Add 00git_inet_cidr_unpack.patch: Revert the behavior of inet/cidr
    functions to not unpack the arguments. This fixes the memory leak when
    sorting inet values. Patch taken from upstream git HEAD. Spotted during
    testing in LP #904631.
  * 01-armel-tas.patch: Turn slock_t datatype into an int, and define
    S_UNLOCK() to call __sync_lock_release() instead of using the default
    implementation. This complies to the gcc built-in atomic operations
    specifiction more strictly and now also works on the Panda boards.
    (LP: #904828)

postgresql-8.4 (8.4.10-0ubuntu0.10.04) lucid-proposed; urgency=low

  * New upstream release: (LP: #904631)
    - Fix bugs in information_schema.referential_constraints view.
      This view was being insufficiently careful about matching the
      foreign-key constraint to the depended-on primary or unique key
      constraint. That could result in failure to show a foreign key
      constraint at all, or showing it multiple times, or claiming that
      it depends on a different constraint than the one it really does.
      Since the view definition is installed by initdb, merely upgrading
      will not fix the problem. If you need to fix this in an existing
      installation, you can (as a superuser) drop the information_schema
      schema then re-create it by sourcing
      "SHAREDIR/information_schema.sql". (Run pg_config --sharedir if
      you're uncertain where "SHAREDIR" is.) This must be repeated in
      each database to be fixed.
    - Fix incorrect replay of WAL records for GIN index updates.
      This could result in transiently failing to find index entries
      after a crash, or on a hot-standby server. The problem would be
      repaired by the next "VACUUM" of the index, however.
    - Fix TOAST-related data corruption during CREATE TABLE dest AS
      SELECT - FROM src or INSERT INTO dest SELECT * FROM src.
      If a table has been modified by "ALTER TABLE ADD COLUMN", attempts
      to copy its data verbatim to another table could produce corrupt
      results in certain corner cases. The problem can only manifest in
      this precise form in 8.4 and later, but we patched earlier versions
      as well in case there are other code paths that could trigger the
      same bug.
    - Fix race condition during toast table access from stale syscache
      entries.
    - Track dependencies of functions on items used in parameter default
      expressions. Previously, a referenced object could be dropped without
      having dropped or modified the function, leading to misbehavior when the
      function was used. Note that merely installing this update will not fix
      the missing dependency entries; to do that, you'd need to "CREATE OR
      REPLACE" each such function afterwards. If you have functions whose
      defaults depend on non-built-in objects, doing so is recommended.
    - Allow inlining of set-returning SQL functions with multiple OUT
      parameters.
    - Make DatumGetInetP() unpack inet datums that ...

Read more...

Changed in postgresql-8.4 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package postgresql-8.4 - 8.4.10-0ubuntu0.10.10.1

---------------
postgresql-8.4 (8.4.10-0ubuntu0.10.10.1) maverick-proposed; urgency=low

  * Add 00git_inet_cidr_unpack.patch: Revert the behavior of inet/cidr
    functions to not unpack the arguments. This fixes the memory leak when
    sorting inet values. Patch taken from upstream git HEAD. Spotted during
    testing in LP #904631.
  * 01-armel-tas.patch: Turn slock_t datatype into an int, and define
    S_UNLOCK() to call __sync_lock_release() instead of using the default
    implementation. This complies to the gcc built-in atomic operations
    specifiction more strictly and now also works on the Panda boards.
    (LP: #904828)

postgresql-8.4 (8.4.10-0ubuntu0.10.10) maverick-proposed; urgency=low

  * New upstream release (LP: #904631)
    - Fix bugs in information_schema.referential_constraints view.
      This view was being insufficiently careful about matching the
      foreign-key constraint to the depended-on primary or unique key
      constraint. That could result in failure to show a foreign key
      constraint at all, or showing it multiple times, or claiming that
      it depends on a different constraint than the one it really does.
      Since the view definition is installed by initdb, merely upgrading
      will not fix the problem. If you need to fix this in an existing
      installation, you can (as a superuser) drop the information_schema
      schema then re-create it by sourcing
      "SHAREDIR/information_schema.sql". (Run pg_config --sharedir if
      you're uncertain where "SHAREDIR" is.) This must be repeated in
      each database to be fixed.
    - Fix incorrect replay of WAL records for GIN index updates.
      This could result in transiently failing to find index entries
      after a crash, or on a hot-standby server. The problem would be
      repaired by the next "VACUUM" of the index, however.
    - Fix TOAST-related data corruption during CREATE TABLE dest AS
      SELECT - FROM src or INSERT INTO dest SELECT * FROM src.
      If a table has been modified by "ALTER TABLE ADD COLUMN", attempts
      to copy its data verbatim to another table could produce corrupt
      results in certain corner cases. The problem can only manifest in
      this precise form in 8.4 and later, but we patched earlier versions
      as well in case there are other code paths that could trigger the
      same bug.
    - Fix race condition during toast table access from stale syscache
      entries.
    - Track dependencies of functions on items used in parameter default
      expressions. Previously, a referenced object could be dropped without
      having dropped or modified the function, leading to misbehavior when the
      function was used. Note that merely installing this update will not fix
      the missing dependency entries; to do that, you'd need to "CREATE OR
      REPLACE" each such function afterwards. If you have functions whose
      defaults depend on non-built-in objects, doing so is recommended.
    - Allow inlining of set-returning SQL functions with multiple OUT
      parameters.
    - Make DatumGetInetP() unpack inet datums ...

Read more...

Changed in postgresql-8.4 (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package postgresql-8.4 - 8.4.10-0ubuntu0.11.04.1

---------------
postgresql-8.4 (8.4.10-0ubuntu0.11.04.1) natty-proposed; urgency=low

  * Add 00git_inet_cidr_unpack.patch: Revert the behavior of inet/cidr
    functions to not unpack the arguments. This fixes the memory leak when
    sorting inet values. Patch taken from upstream git HEAD. Spotted during
    testing in LP #904631.
  * 01-armel-tas.patch: Turn slock_t datatype into an int, and define
    S_UNLOCK() to call __sync_lock_release() instead of using the default
    implementation. This complies to the gcc built-in atomic operations
    specifiction more strictly and now also works on the Panda boards.
    (LP: #904828)

postgresql-8.4 (8.4.10-0ubuntu0.11.04) natty-proposed; urgency=low

  * New upstream release (LP: #904631):
    - Fix bugs in information_schema.referential_constraints view.
      This view was being insufficiently careful about matching the
      foreign-key constraint to the depended-on primary or unique key
      constraint. That could result in failure to show a foreign key
      constraint at all, or showing it multiple times, or claiming that
      it depends on a different constraint than the one it really does.
      Since the view definition is installed by initdb, merely upgrading
      will not fix the problem. If you need to fix this in an existing
      installation, you can (as a superuser) drop the information_schema
      schema then re-create it by sourcing
      "SHAREDIR/information_schema.sql". (Run pg_config --sharedir if
      you're uncertain where "SHAREDIR" is.) This must be repeated in
      each database to be fixed.
    - Fix incorrect replay of WAL records for GIN index updates.
      This could result in transiently failing to find index entries
      after a crash, or on a hot-standby server. The problem would be
      repaired by the next "VACUUM" of the index, however.
    - Fix TOAST-related data corruption during CREATE TABLE dest AS
      SELECT - FROM src or INSERT INTO dest SELECT * FROM src.
      If a table has been modified by "ALTER TABLE ADD COLUMN", attempts
      to copy its data verbatim to another table could produce corrupt
      results in certain corner cases. The problem can only manifest in
      this precise form in 8.4 and later, but we patched earlier versions
      as well in case there are other code paths that could trigger the
      same bug.
    - Fix race condition during toast table access from stale syscache
      entries.
    - Track dependencies of functions on items used in parameter default
      expressions. Previously, a referenced object could be dropped without
      having dropped or modified the function, leading to misbehavior when the
      function was used. Note that merely installing this update will not fix
      the missing dependency entries; to do that, you'd need to "CREATE OR
      REPLACE" each such function afterwards. If you have functions whose
      defaults depend on non-built-in objects, doing so is recommended.
    - Allow inlining of set-returning SQL functions with multiple OUT
      parameters.
    - Make DatumGetInetP() unpack inet datums that ...

Read more...

Changed in postgresql-8.4 (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers