Ubuntu

Please SRU to PiTiVi 0.15.2

Reported by Jason Gerard DeRose on 2012-05-19
50
This bug affects 13 people
Affects Status Importance Assigned to Milestone
pitivi (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

TESTCASE: test the "render" function, it was broken before update and should work after

Impact: the bug makes one of the key features of pitivi not usable in precise
Dev Fix: 0.15.1 is in quantal
Stable Fix: the update to 0.15.1 is one fix and translation updates
Regression Potential: the software is not installed by default and is not working, the fix should only improve things

PiTiVi 0.15.1 is badly broken in Precise, to the point of being completely unusable.

PiTiVi 0.15.2 fixes this breakage, seemingly restoring PiTiVi to a state at least as usable and stable as in Oneiric. I've been using it quite a bit the last week and haven't found any regressions yet... plus "working" is nice :P

I consider this a low risk update worthy of an SRU as going from completely broken to seemingly usable is clearly a step in the right direction, plus this is a dire regression from Oneiric.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: pitivi 0.15.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Fri May 18 20:16:17 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120122)
PackageArchitecture: all
SourcePackage: pitivi
UpgradeStatus: No upgrade log present (probably fresh install)

Jason Gerard DeRose (jderose) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pitivi (Ubuntu):
status: New → Confirmed
Christian Reis (kiko) wrote :

An application in main is completely broken; bumping to high.

Crashers that would be fixed by this: bug 916791, bug 861867, bug 916791, bug 916667 and possibly others.

Changed in pitivi (Ubuntu):
importance: Undecided → High
Jason Gerard DeRose (jderose) wrote :

Thanks, Kiko!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pitivi (Ubuntu Precise):
status: New → Confirmed
Changed in pitivi (Ubuntu Precise):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

How is it "completely broken"? Having some details would help.

It would also make things easier if upstream had their git in an useful state... neither http://git.pitivi.org/?p=pitivi.git;a=summary nor http://git.gnome.org/browse/pitivi have tagged 0.15.1 and 0.15.2 and the git history on http://git.gnome.org/browse/pitivi/log/ shows no commit out of translations between feb 24 and march 03 (the tarball dates for both versions on http://ftp.acc.umu.se/pub/GNOME/sources/pitivi/0.15/)

Does anyone knows where 0.15.2 is coming from and what it includes?

Sebastien, thanks for making me realize that "git push" does not push tags alongside commits. This is done now, on git.gnome.org/pitivi master *

There was
https://mail.gnome.org/archives/gnome-i18n/2012-February/msg00085.html
and
http://gstreamer-devel.966125.n4.nabble.com/ANNOUNCE-PiTiVi-0-15-2-release-td4606649.html

Alongside the "NEWS" file.

*: http://jeff.ecchi.ca/blog/2012/03/15/switching-pitivis-main-git-repository/

Also, for your info,
http://jeff.ecchi.ca/blog/2012/05/19/break-the-kettles-and-sink-the-boats/

Sebastien Bacher (seb128) wrote :

Thanks Jean-François, I will do the update but the git log still doesn't make any sense to me, on http://git.gnome.org/browse/pitivi it indicates that 0.15.2 happened 3 weeks ago (which doesn't match at all the ftp tarball timestamp) and there is over an hundred commits in the log between those versions ... was 0.15.2 made out of a vcs, or is there a stable serie that didn't get pushed anywhere?

Sebastien Bacher (seb128) wrote :

sorry about the "doesn't match at all the ftp tarball timestamp", I misread may for march... well at least we didn't overlook an update which was available before the precise freeze, I will SRU the bugfix version

Changed in pitivi (Ubuntu Precise):
status: Confirmed → In Progress
Changed in pitivi (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pitivi - 0.15.2-0ubuntu1

---------------
pitivi (0.15.2-0ubuntu1) quantal; urgency=low

  * New upstream version (lp: #1001516)
 -- Sebastien Bacher <email address hidden> Tue, 22 May 2012 19:46:11 +0200

Changed in pitivi (Ubuntu):
status: Fix Committed → Fix Released
Changed in pitivi (Ubuntu Precise):
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

Does anyone has a testcase which describing something which doesn't work with 0.15.1 and works with 0.15.2? I didn't use pitivi a lot but importing a video and dragging it in the timeline area works fine in 0.15.1, the video preview works as well, I can't really write how to test the stable update...

My test case for this particular release is to check whether rendering
works or not. I don't know of other bugs beyond that, perhaps Jason can
share his findings on that front, if any.

Jason Gerard DeRose (jderose) wrote :

Yup, that's my exact experience too... I've haven't got a single render to work with 0.15.1 under Precise. Hit render, and the render hangs, never finishing.

description: updated
Sebastien Bacher (seb128) wrote :

Thanks guys, I tried to update the description but I'm not sure it's convincing, I'm not a pitivi user myself and it's not very obvious how to use it, I added a 13Mb ogv video, dnd it to the bottom area in the ui, then picked "render" in the toolbar ... that seems to do something but on an i5 config it announces 25 minutes of work for a 13 mb video which is over the time I wanted to wait, I let it run for a minute, stopped the job and checked the video but get a dark screen only rendered for 15 seconds in it

Summary: I don't know enough about pitivi to write a good testcase for the stable update so if you want to see that version go in precise please help writing a correct one ;-)

Clint Byrum (clint-fewbar) wrote :

The test case is fine here, thanks for adding it . Can somebody please add the required headers from the SRU process here:

https://wiki.ubuntu.com/StableReleaseUpdates

Namely Impact, Dev Fix, Stable Fix, Regression Potential

The upload currently waiting for precise-proposed will not be considered until those fields are added to the description, per the process.

Thanks!

description: updated

Hello Jason, or anyone else affected,

Accepted pitivi into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Dustin Kirkland  (kirkland) wrote :

I was having the same problem, couldn't render videos under 0.15.1 in precise, when I found this bug and the SRU proposal.

I have now upgraded to 0.15.2-0ubuntu0.1, but I'm still unable to render. It just hangs on the "Estimating" dialog. Is there something else I need to upgrade as well, in addition to pitivi?

Dustin Kirkland  (kirkland) wrote :

Here are the errors I'm getting:

kirkland@x220:~$ pitivi
ERROR: Could not load classifier cascade /usr/share/opencv/haarcascades/haarcascade_frontalface_alt2.xml
ERROR [ 5267] [0x7fbefe84a700] "<Pipeline at 0x330ea90>" pipeline Jun 03 17:12:18 _handleErrorMessage: error from /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition0/GnlSource:gnlsource: FileSourceFactory0/GstBin:bin1/pitivi+elements+singledecodebin+SingleDecodeBin:pitivi+elements+singledecodebin+singledecodebin0/GstQTDemux:qtdemux15 (__main__.GstQTDemux): GStreamer encountered a general stream error. (qtdemux.c(3891): gst_qtdemux_loop (): /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition0/GnlSource:gnlsource: FileSourceFactory0/GstBin:bin1/pitivi+elements+singledecodebin+SingleDecodeBin:pitivi+elements+singledecodebin+singledecodebin0/GstQTDemux:qtdemux15:
streaming stopped, reason not-negotiated) (/usr/lib/pitivi/python/pitivi/pipeline.py:858)
ERROR [ 5267] [0x7fbefe84a700] "<Pipeline at 0x330ea90>" pipeline Jun 03 17:12:19 _handleErrorMessage: error from /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition0/GnlSource:gnlsource: FileSourceFactory0/GstBin:bin1/GstAlpha:internal-alpha (__main__.GstAlpha): Element doesn't implement handling of this stream. Please file a bug. (gstbasetransform.c(2525): gst_base_transform_handle_buffer (): /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition0/GnlSource:gnlsource: FileSourceFactory0/GstBin:bin1/GstAlpha:internal-alpha:
not negotiated) (/usr/lib/pitivi/python/pitivi/pipeline.py:858)
ERROR [ 5267] [0x7fbefe84a700] "<Pipeline at 0x330ea90>" pipeline Jun 03 17:12:19 _handleErrorMessage: error from /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition0/GnlSource:gnlsource: FileSourceFactory0/GstBin:bin1/pitivi+elements+singledecodebin+SingleDecodeBin:pitivi+elements+singledecodebin+singledecodebin0/GstQTDemux:qtdemux17 (__main__.GstQTDemux): GStreamer encountered a general stream error. (qtdemux.c(3891): gst_qtdemux_loop (): /GstPipeline:pipeline0/GstBin:bin0/GnlComposition:gnlcomposition0/GnlSource:gnlsource: FileSourceFactory0/GstBin:bin1/pitivi+elements+singledecodebin+SingleDecodeBin:pitivi+elements+singledecodebin+singledecodebin0/GstQTDemux:qtdemux17:
streaming stopped, reason not-negotiated) (/usr/lib/pitivi/python/pitivi/pipeline.py:858)

Dustin Kirkland  (kirkland) wrote :

Hmm, I've upgraded and downgraded Pitivi both, and none of them (oneiric, precise, precise-updates, quantal) are solving my rendering problem. Looks like the issue is elsewhere, perhaps in a library?

Here's some other interesting python tracebacks, having let it run for a long time "Estimating". Note the recursion error message...

    self._closeLink(element)
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 169, in _closeLink
    self._closePadLink(element, pad, pad.get_caps())
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 280, in _closePadLink
    self._tryToLink1(element, pad, facts)
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 233, in _tryToLink1
    self._closeLink(element)
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 169, in _closeLink
    self._closePadLink(element, pad, pad.get_caps())
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 280, in _closePadLink
    self._tryToLink1(element, pad, facts)
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 233, in _tryToLink1
    self._closeLink(element)
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 169, in _closeLink
    self._closePadLink(element, pad, pad.get_caps())
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 280, in _closePadLink
    self._tryToLink1(element, pad, facts)
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 233, in _tryToLink1
    self._closeLink(element)
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 169, in _closeLink
    self._closePadLink(element, pad, pad.get_caps())
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 280, in _closePadLink
    self._tryToLink1(element, pad, facts)
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 233, in _tryToLink1
    self._closeLink(element)
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 169, in _closeLink
    self._closePadLink(element, pad, pad.get_caps())
  File "/usr/lib/pitivi/python/pitivi/elements/singledecodebin.py", line 263, in _closePadLink
    elif is_raw(caps) and pad_compatible_stream(pad, self.stream):
RuntimeError: maximum recursion depth exceeded
Traceback (most recent call last):
  File "/usr/lib/pitivi/python/pitivi/ui/encodingdialog.py", line 692, in _renderButtonClickedCb
    self.startAction()
  File "/usr/lib/pitivi/python/pitivi/actioner.py", line 151, in startAction
    self.addAction()
  File "/usr/lib/pitivi/python/pitivi/actioner.py", line 102, in addAction
    self.action = self._createAction(sources)
  File "/usr/lib/pitivi/python/pitivi/actioner.py", line 230, in _createAction
    self.have_video, self.have_audio)
  File "/usr/lib/pitivi/python/pitivi/settings.py", line 605, in export_settings_to_render_settings
    astream = get_stream_for_caps(export.getAudioCaps())
  File "/usr/lib/pitivi/python/pitivi/stream.py", line 345, in get_stream_for_caps
    log.debug("stream", "caps:%s, pad:%r" % (caps.to_string(), pad))
AttributeError: 'NoneType' object has no attribute 'to_string'

Sebastien Bacher (seb128) wrote :

@Jason, do you get the same issue, since you reported the bug could you try the update?

@Dustin: not sure but it seems it could be a gstreamer issue

Dustin, your issue is most likely something else. Try a different combination of codecs (and when these errors happen make sure to restart pitivi for your next try), and maybe ask around on the irc channel to investigate this issue more easily.

Jason Gerard DeRose (jderose) wrote :

@Sebastian: okay, I had a chance to play with the packaged from proposed, and for my combination of video clips and render settings, things are working for me. It appears to fix the regressions from Oneiric.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pitivi - 0.15.2-0ubuntu0.1

---------------
pitivi (0.15.2-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream version (lp: #1001516)
 -- Sebastien Bacher <email address hidden> Tue, 22 May 2012 19:46:11 +0200

Changed in pitivi (Ubuntu Precise):
status: Fix Committed → Fix Released

Version 0.15.2-0ubuntu0.1 allows me to render videos. If I start pitivi from the console, I see some Python stack traces and other errors, but they are not preventing me from rendering the videos. The main bug seems to be fixed.

There's a page with automatically generated packages on the SRU waiting list:

http://people.canonical.com/~ubuntu-archive/pending-sru.html

This page does not mention pitivi. So if the package is in precise-proposed, but not on the SRU list, what's the state and how to go forward?

Jason Gerard DeRose (jderose) wrote :

Maciej, I already see 0.15.2-0ubuntu0.1 in precise-updates, so I think this fix has already been pushed through.

Am I missing something?

Apologies, it was a case of PEBKAC.

$ apt-cache policy pitivi
pitivi:
  Instalado: 0.15.2-0ubuntu0.1
  Candidato: 0.15.2-0ubuntu0.1
  Tabela de Versão:
 *** 0.15.2-0ubuntu0.1 0
        500 http://ie.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     0.15.1-0ubuntu1 0
        500 http://ie.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

All is good. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers