Ubuntu

package libxml-sax-expat-perl 0.40-2 failed to install/upgrade: ErrorMessage: subprocess installed pre-removal script returned error exit status 2

Reported by Peter Belew on 2012-04-28
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libxml-sax-perl (Debian)
Fix Released
Unknown
libxml-sax-perl (Ubuntu)
High
Stéphane Graber
Precise
Critical
Stéphane Graber
Quantal
High
Stéphane Graber
perl (Ubuntu)
Undecided
Unassigned
Precise
Critical
Stéphane Graber
Quantal
Undecided
Unassigned

Bug Description

[rationale]
libxml-sax-expat-perl has a prerm calling a script from libxml-sax-perl, this script uses SAX.pm which uses Basename for the dirname function. This function is broken at the time the code runs.

This breaks 10.04 to 12.04 upgrades when done without connectivity and may cause breakage in other cases too.

[test case]
1) Install Ubuntu 10.04 desktop
2) Update it
3) Disconnect from the internet
4) Insert 12.04.1 alternate media
5) Upgrade

[regression potential]
Implementation was copy/pasted from that in doc-base, matching perl changes were also copied from what was done in doc-base, so risk of regression should be very low.

In the last day or so, I upgraded Ubuntu from 11.04 to 11.10, then to 12.04. The upgrade to 12.04 was first done using an alternate install CD, then further updates were made from the Internet. A partial upgrade was made after rebooting. This error showed up more than one time before I reported it. The computer is a gBox P4 model around 8-10 years old.

Ubuntu version and kernel version
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"
Linux billy 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:52 UTC 2012 i686 i686 i386 GNU/Linux
model name : Intel(R) Celeron(R) CPU 1.70GHz
cpu MHz : 1691.518
MemTotal: 2029480 kB
SwapTotal: 522076 kB

After installing apt-show-versions, I was able to determine this:

$ apt-show-versions libxml-sax-expat-perl
libxml-sax-expat-perl/precise uptodate 0.40-2

So the error is a bit of a mystery to me.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libxml-sax-expat-perl 0.40-2
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Fri Apr 27 11:27:06 2012
ErrorMessage: ErrorMessage: subprocess installed pre-removal script returned error exit status 2
PackageArchitecture: all
SourcePackage: libxml-sax-expat-perl
Title: package libxml-sax-expat-perl 0.40-2 failed to install/upgrade: ErrorMessage: subprocess installed pre-removal script returned error exit status 2
UpgradeStatus: Upgraded to precise on 2012-04-27 (0 days ago)

Peter Belew (peterbe) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libxml-sax-expat-perl (Ubuntu):
status: New → Confirmed
Arun S L (arun-sl) wrote :

Work around found:

activate update from internet and then do an update it resolved the issue.

Some packages that was now updated over internet solved the dependency issue.

Maybe the alternate cd lacked those packages and did not knew how to deal with the situation.

Peter Belew (peterbe) wrote :

This problem has not reoccurred since I updated from the Internet. I suspect Arun is right about some dependency not being in the Alternate install ISO.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libxml-sax-perl (Ubuntu Precise):
status: New → Confirmed
affects: libxml-sax-expat-perl (Ubuntu Precise) → libxml-sax-perl (Ubuntu Precise)
Changed in libxml-sax-perl (Ubuntu Precise):
status: New → Triaged
assignee: nobody → Stéphane Graber (stgraber)
milestone: none → ubuntu-12.04.1
importance: Undecided → Critical
Changed in libxml-sax-perl (Ubuntu Quantal):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Stéphane Graber (stgraber)
Changed in libxml-sax-perl (Ubuntu Precise):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxml-sax-perl - 0.99+dfsg-2ubuntu1

---------------
libxml-sax-perl (0.99+dfsg-2ubuntu1) quantal; urgency=low

  * SAX.pm: provide our own local dirname() function and use it
    instead of File::Basename. Copied from doc-base. (LP: #990256)
 -- Stephane Graber <email address hidden> Fri, 10 Aug 2012 15:49:30 -0400

Changed in libxml-sax-perl (Ubuntu Quantal):
status: Triaged → Fix Released
Changed in perl (Ubuntu Precise):
status: New → Invalid
Changed in perl (Ubuntu Quantal):
status: New → Invalid
Changed in perl (Ubuntu Precise):
status: Invalid → In Progress
assignee: nobody → Stéphane Graber (stgraber)
importance: Undecided → Critical
milestone: none → ubuntu-12.04.1
description: updated

Hello Peter, or anyone else affected,

Accepted libxml-sax-perl into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libxml-sax-perl/0.99+dfsg-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libxml-sax-perl (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
description: updated
Changed in libxml-sax-perl (Debian):
status: Unknown → Fix Released
Steve Langasek (vorlon) wrote :

Hello Peter, or anyone else affected,

Accepted perl into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/perl/5.14.2-6ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in perl (Ubuntu Precise):
status: In Progress → Fix Committed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Precise:
I have reproduced the problem with perl 5.14.2-6ubuntu2 and libxml-sax-perl 0.99+dfsg-1 in precise and have verified that the versions of perl 5.14.2-6ubuntu2.1 and libxml-sax-perl 0.99+dfsg-1ubuntu0.1 in -proposed fixes the issue.

I have upgraded successfully and without error from 10.04.4 i386 and amd64 to 12.04.1 without a network connection using the alternate images.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package perl - 5.14.2-6ubuntu2.1

---------------
perl (5.14.2-6ubuntu2.1) precise-proposed; urgency=low

  * Add versioned conflict against libxml-sax-perl to ensure it's upgraded
    to a version that doesn't use Files::Basename or is removed from the
    system. This fixes upgrades from 10.04. (LP: #990256)
 -- Stephane Graber <email address hidden> Fri, 10 Aug 2012 15:51:31 -0400

Changed in perl (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxml-sax-perl - 0.99+dfsg-1ubuntu0.1

---------------
libxml-sax-perl (0.99+dfsg-1ubuntu0.1) precise-proposed; urgency=low

  * SAX.pm: provide our own local dirname() function and use it
    instead of File::Basename. Copied from doc-base. (LP: #990256)
 -- Stephane Graber <email address hidden> Fri, 10 Aug 2012 15:39:14 -0400

Changed in libxml-sax-perl (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.