PostScript output is invalid on non-english locales

Bug #988503 reported by Traumflug on 2012-04-25
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
pcb
Undecided
Unassigned
pcb (Ubuntu)
Low
Unassigned
Precise
Low
Vibhav Pant

Bug Description

[Impact]
Low, Since the bug only replaces a decimal dot with a comma

[Development Fix]
https://launchpadlibrarian.net/103076603/0001-Fixed-command-line-batch-output-for-some-exporters.patch

[Stable Fix]
Probably, https://launchpadlibrarian.net/103076603/0001-Fixed-command-line-batch-output-for-some-exporters.patch

[Text Case]

1. Install PCB (sudo apt-get install pcb)
2. Using a german locale, export to a PostScript using the command line
Broken Behavior: decimal dots inside the file are replaced by commas.
Fixed Behavior:

[Regression Potential]
Low

[Original Report]When exporting or printing to PostScript from the command line, the resulting output is invalid. With a german locale, decimal dots inside the file are replaced by commas.

Fix is known.

$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

$ apt-cache policy pcb
pcb:
  Installiert: 20110918-4
  Kandidat: 20110918-4
  Versionstabelle:
 *** 20110918-4 0
        500 http://ch.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Traumflug (mah-jump-ing) wrote :

Fix attached, it's a one-liner. Taken as-is from pcb's git repository.

Changed in pcb (Ubuntu):
status: New → Confirmed
Traumflug (mah-jump-ing) wrote :

Now I hope somebody who knows how to forward this fix into the package update system picks up (or shows me how to do it myself).

The attachment "0001-Fixed-command-line-batch-output-for-some-exporters.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Traumflug (mah-jump-ing) wrote :
Changed in pcb (Ubuntu):
status: Confirmed → Fix Committed
Traumflug (mah-jump-ing) wrote :

The previous merge request accidently included a temporary file, a new merge request followed:

https://code.launchpad.net/~mah-jump-ing/ubuntu/precise/pcb/fix-for-988503-2/+merge/103767

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pcb - 20110918-5

---------------
pcb (20110918-5) unstable; urgency=low

  * Added 0001-Fixed-command-line-batch-output-for-some-exporters.patch from
    upstream git to fix command line batch output for some exporters.
    Thanks to Traumflug <email address hidden> (LP: #988503)
  * Bumped compat level to 9
  * debian/control: Updated Standards-Version to 3.9.3
  * debian/copyright: Updated copyright format & years.

 -- أحمد المحمودي (Ahmed El-Mahmoudy) <email address hidden> Tue, 08 May 2012 21:30:17 +0200

Changed in pcb (Ubuntu):
status: Fix Committed → Fix Released
Bryce Harrington (bryce) on 2012-05-17
description: updated
Traumflug (mah-jump-ing) wrote :

As of today, this package doesn't show up in my installation:

$ date && dpkg -s pcb
Di 5. Jun 01:04:53 CEST 2012
Package: pcb
Status: install ok installed
[...]
Version: 20110918-4
[...]

I'm subscribed to precise-updates, precise-proposed and precise-backports. What is going wrong?

Changed in pcb (Ubuntu):
importance: Undecided → Low
Changed in pcb (Ubuntu Precise):
importance: Undecided → Low
Vibhav Pant (vibhavp) on 2012-06-06
Changed in pcb (Ubuntu Precise):
assignee: nobody → Vibhav Pant (vibhavp)
Vibhav Pant (vibhavp) on 2012-06-06
description: updated
Vibhav Pant (vibhavp) on 2012-06-06
Changed in pcb:
status: New → Fix Committed
Fabrice Coutadeur (fabricesp) wrote :

Hi,

I'm very sorry but I'm not able to reproduce the bug, even after switching to german locale (I'm a spanish user).
And I need to be sure that the fix works before uploading it.

Could you please indicate what is the value of your LANG variable?

Thanks,
Fabrice

Traumflug (mah-jump-ing) wrote :

To reproduce the bug, you have to use a locale which has something different than a dot for the decimal separator. Also, the bug is sometimes not obvious, as the output looks the same on the first page, but contains invalid PostScript for additional pages.

I've attached my environment, it's the default german environment.

Changed in pcb:
status: Fix Committed → Fix Released
Changed in pcb:
milestone: none → pcb-20140316
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers