oss4-dkms 4.2-build2005-2ubuntu1: oss4 kernel module failed to build (cp: cannot stat `/lib/modules/3.2.0-23-generic/source/include/linux/limits.h': No such file or directory)

Bug #969733 reported by lobo on 2012-03-31
786
This bug affects 106 people
Affects Status Importance Assigned to Milestone
oss4 (Ubuntu)
Critical
Unassigned
Precise
Critical
Unassigned

Bug Description

.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: oss4-dkms
Uname: Linux 3.2.0-20-generic-pae i686
Architecture: i386
DKMSKernelVersion: 3.2.0-20-generic-pae
Date: Fri Mar 30 19:59:35 2012
PackageVersion: 4.2-build2005-2ubuntu1
SourcePackage: oss4
Title: oss4-dkms 4.2-build2005-2ubuntu1: oss4 kernel module failed to build

There is two reason
First, "limits.h" migrate from "xxx/include/linux" to "/include/uapi/linux" WHY ???

secundly the file "pci_wrapper.inc" in "/usr/src/oss4-4.2-build2005/drivers/"
contain wrong declarations and must be change like this

.....
/* static int __devinit */wrong !!!
static int
osspci_probe (struct pci_dev *pcidev, const struct pci_device_id *pciid)
{
.....
.....

/* static void __devexit */wrong !!!
static void
osspci_remove (struct pci_dev *pcidev)
{
.....

after doing the change, just run as root:

dkms install -m oss4/4.2-build2005

and reboot
Please can you correct this from deb sources SVP, THANK'S

lobo (ricardolobo) wrote :
summary: oss4-dkms 4.2-build2005-2ubuntu1: oss4 kernel module failed to build
+ (cp: impossível obter estado de "/lib/modules/3.2.0-20-generic-
+ pae/source/include/linux/limits.h": Arquivo ou diretório não encontrado)
tags: removed: need-duplicate-check
summary: oss4-dkms 4.2-build2005-2ubuntu1: oss4 kernel module failed to build
- (cp: impossível obter estado de "/lib/modules/3.2.0-20-generic-
- pae/source/include/linux/limits.h": Arquivo ou diretório não encontrado)
+ (cp: cannot stat
+ `/lib/modules/3.2.0-23-generic/source/include/linux/limits.h': No such
+ file or directory)

This is pretty much a duplicate of https://bugs.launchpad.net/ubuntu/+source/oss4/+bug/601342

The patch has changed slightly though. Attached is the new version.

The attachment "dkmspatch.txt" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
lobo2016 (lobo2016) on 2012-05-24
tags: removed: patch

@Ricardo: comment #3 contains a patch. Please do not remove the patch tag.

tags: added: patch

Since it's a simple fix, I applied the patch and uploaded the package to my ppa: https://launchpad.net/~dtl131/+archive/ppa/+packages

(64-bit is still in the build queue)

tags: added: precise quantal
Changed in oss4 (Ubuntu):
importance: Undecided → Critical
Daniel van Vugt (vanvugt) wrote :

Dave,

Please upload a debdiff so the ubuntu-sponsors team can get your fix into the next release
[https://wiki.ubuntu.com/SponsorshipProcess]

Changed in oss4 (Ubuntu):
assignee: nobody → Dave Lentz (dtl131)
status: Confirmed → In Progress
Brian Murray (brian-murray) wrote :

There is no debdiff here to sponsor so I am unsubscribing the sponsors team.

The real solution here is to sync a newer version of oss4 from Debian so that this bug (and others) is fixed in Ubuntu Raring/13.04 and later.

Debian bug link: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=587191

debdiff uploaded

I wonder if this will work with 3.7 and 3.8 kernels because for example NVIDIA and VirtualBox needed some fixes for building modules with those kernels.

The 3.7 kernels don't boot on my machine (known problem for AMD processors) https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1077822

The 3.8rc2 from Ubuntu Mainline Kernels won't build modules for NVIDIA (Beta driver 313.09 from xorg-edgers PPA) so I can't test it either.

I'm also using self compiled package of OSSv4 because that way I have the freshest code (even though the last change was 10 moths ago) and I can enable Production quality resampler in vmix.

I know that version.h file was moved from:

/include/linux/version.h

to

/include/generated/uapi/linux/version.h

Heads up - linux 3.7-rc* header file reorg - nV News Forums http://www.nvnews.net/vbulletin/showthread.php?p=2578811#post2578811

I don't know if those changes affect also OSSv4 kernel modules building procedure but people that can actually boot kernels newer than 3.5 should check that before it will be too late for Raring / 13.04.

I installed today 3.8rc3 from Mainline Kernel PPA and finally it booted. There was no problem with OSSv4 building kernel modules but I'm using self created .deb package of 4.2 build 2007 from Mercurial repository.

Changed in oss4 (Ubuntu Precise):
assignee: nobody → Dave Lentz (dtl131)
status: New → In Progress
Changed in oss4 (Ubuntu Raring):
assignee: Dave Lentz (dtl131) → nobody
status: In Progress → Triaged
Changed in oss4 (Ubuntu Quantal):
status: New → Triaged
Jamie Strandboge (jdstrand) wrote :

Thanks for your patch! This is a Stable Release Update (SRU) request, therefore for it to be included in a stable release of Ubuntu, it must first be fixed in the development release (raring), as per https://wiki.ubuntu.com/StableReleaseUpdates#Procedure. I have created tasks for Raring, Quantal and Precise.

Can someone reproduce the problem on raring then either create a debdiff or perform a merge with what is in Debian and report back on if it fixes the problem? I am going to unsubscribe ubuntu-sponsors for now since the precise debdiff is blocked on this. Please feel free to resubscribe ubuntu-sponsors if there is something new to review.

Thanks again.

Changed in oss4 (Ubuntu Precise):
assignee: Dave Lentz (dtl131) → nobody
Ivan STOL (ivan-stol-is) on 2013-05-09
description: updated
Changed in oss4 (Ubuntu Raring):
status: Triaged → Confirmed
asu (corcodel-marian) wrote :

This file solve this bug

Anders (eddiedog988) on 2014-03-13
Changed in oss4 (Ubuntu Quantal):
status: Triaged → Confirmed
Changed in oss4 (Ubuntu):
status: Triaged → Confirmed
Changed in oss4 (Ubuntu):
status: Confirmed → Triaged
Changed in oss4 (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in oss4 (Ubuntu Raring):
status: Confirmed → Triaged
no longer affects: oss4 (Ubuntu Raring)

oss4 (4.2-build2007-2) unstable; urgency=medium

  * Revert changes from the previous NMU, it breaks more things
    than it fixes.
  * Until a *tested* patch is proposed, VMIX is now using
    fixed point arithmetic in the kernel.

no longer affects: oss4 (Ubuntu Quantal)
Changed in oss4 (Ubuntu):
status: Triaged → Fix Released
Changed in oss4 (Ubuntu Precise):
status: In Progress → Triaged
importance: Undecided → Critical
Mirko (jugal) wrote :

Dear software Maintainers:
Are you aware that this 4-year-old bug right now affects installing the new hardware support of 12.04 and thus makes 12.04 unusable if you depend on oss4?

On 21.07.2014 07:33, Mirko wrote:
> Dear software Maintainers:
> Are you aware that this 4-year-old bug right now affects installing the new hardware support of 12.04 and thus makes 12.04 unusable if you depend on oss4?
>

Hello Mirko,

the errormessage doesn't come anymore. I don't know why.

The file

"pci_wrapper.inc" in"/usr/src/oss4-4.2-build2005/drivers/"

doesn't exists, only pci_wrapper.old

Fact is since the Update from Ubuntu 10.04 to 12.04 the sound is not
working and the thermal config of the graphic-card come with an
errormessage while booting.(adress already in use).

So, the only right way is to save /home/* and to install with newest
Ubuntuversion.

If you want, you can close this bug report

best regards

Jürgen

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.