Ubuntu

[SRU] openvswitch 1.4.0 not compatible with lts-raring HWE kernel

Reported by James Page on 2013-08-16
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openvswitch (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
openvswitch-lts-raring (Ubuntu)
Undecided
Unassigned
Precise
High
James Page

Bug Description

SRU information

[Impact]
openvswitch dkms modules fail to build with the raring HWE kernel on 12.04. This limits ovs usability as the native kernel module does not have the same set of features.

[Test Case]
sudo apt-get install linux-image-generic-lts-raring linux-headers-generic-lts-raring
sudo apt-get install openvswitch-datapath-dkms
(dkms module fails to build)
sudo apt-get install openvswitch-datapath-lts-raring-dkms
(openvswitch-datapath-dkms uninstalled, dkms module builds)

[Regression Potential]
Limited; the approach proposed is to backport -dkms and -source packages for openvswitch-datapath from raring renamed to support the lts-raring kernels:

openvswitch-datapath-lts-raring-dkms
openvswitch-datapath-lts-raring-source

These packages Provides/Conflicts with the equivalent standard packages; this does mean that an explicit user action is required to enable ovs support with linux 3.8 on 12.04.

[Original bug report]
openvswitch-datapath-dkms fails to build with the latest lts-raring HWE kernel.

Backporting all required fixes to 1.4.0 is risky; instead an openvswitch-datapath-lts-raring-dkms package will be provided based on 1.9.0 to support the 3.8 kernel on 12.04.

James Page (james-page) on 2013-08-16
Changed in openvswitch (Ubuntu):
status: New → Invalid
Changed in openvswitch (Ubuntu Precise):
importance: Undecided → High
description: updated
James Page (james-page) on 2013-08-16
Changed in openvswitch (Ubuntu Precise):
assignee: nobody → James Page (james-page)
status: New → In Progress
summary: - openvswitch 1.4.0 not compatible with lts-raring HWE kernel
+ [SRU] openvswitch 1.4.0 not compatible with lts-raring HWE kernel
James Page (james-page) on 2013-08-16
description: updated

Hello James, or anyone else affected,

Accepted openvswitch-lts-raring into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/openvswitch-lts-raring/1.9.0-0ubuntu1~ubuntu12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in openvswitch (Ubuntu Precise):
status: In Progress → Fix Committed
Dave Walker (davewalker) wrote :

Hello James, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in openvswitch-lts-raring (Ubuntu):
status: New → Invalid
Changed in openvswitch (Ubuntu Precise):
status: Fix Committed → Won't Fix
Changed in openvswitch-lts-raring (Ubuntu Precise):
status: New → Fix Committed
assignee: nobody → James Page (james-page)
Changed in openvswitch (Ubuntu Precise):
assignee: James Page (james-page) → nobody
importance: High → Undecided
Changed in openvswitch-lts-raring (Ubuntu Precise):
importance: Undecided → High
Adam Gandelman (gandelman-a) wrote :

Confirmed the issue is solved by installing openvswitch-datapath-lts-raring-dkms with the 3.8 HWE kernel, instead of the standard openvswitch-datapath-dkms package. Attached is a log of steps I took to reproduce and test.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openvswitch-lts-raring - 1.9.0-0ubuntu1~ubuntu12.04.1

---------------
openvswitch-lts-raring (1.9.0-0ubuntu1~ubuntu12.04.1) precise-proposed; urgency=low

  * Backport of 1.9.0 DKMS packages to Ubuntu 12.04 to support Linux 3.8
    LTS hardware enablement kernel (LP: #1213021):
    - d/control: Drop all packages apart from -source and -dkms, add lts-raring
      identify to source and binary packages.
    - d/p/rename-packages-lts-raring.patch: Patch upstream Makefile to use
      lts-raring for dkms and source packages.
    - d/rules,*: Rework for new lts-raring naming.
    - d/tests/ma,dkms: Update for new lts-raring naming.
    - d/tests/control: Disable openflow test as mininet post-dates 12.04.
 -- James Page <email address hidden> Mon, 19 Aug 2013 09:03:12 +0100

Changed in openvswitch-lts-raring (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments