SRU: update to onboard 0.97.1 bugfix release (debian source supplied)

Bug #999111 reported by Francesco Fumanti on 2012-05-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
onboard (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Version 0.97.1 of Onboard, which is a bugfix release release for Onboard 0.97.1 has been released yesterday. Could you please consider making it available in your repositories for precise?

In fact, there is no real package depending on Onboard and this new release should fix a number of bugfix in Onboard (for example some translations bug that makes Onboard crash). From the terminal in my precise installation:
:~$ apt-cache rdepends onboard
onboard
Reverse Depends:
  onboard:i386
  xubuntu-desktop
  ubuntu-sugar-remix
  ubuntu-desktop

Finally, here the relevant part of the changelog of the debian package that I am adding to this bug thread:

onboard (0.97.1-0ubuntu1) precise; urgency=low

  * Request for sponsorship: New bugfix release available (LP: #999111)
  * debian/control:
    - add moustetweaks (>= 3.3.90) to recommends
    - update standards-version 3.9.3
  * debian/patches: remove fix_encoding_mismatch.patch and update series
  * Improve auto-show:
    - unhide for combo boxes (helps in qtoctave) and date editors
    - add focused attribute to debug output
    - fix iconifying by title bar button
    - fix bad repositioning the very first time onboard pops up
    - fix non-critical backtraces for auto-show
    - fix keyboard not being hidden on startup in Metacity
  * Detect running environment to better care for its specificities
    - fix and make also window type hints environment specific
  * Add command line option to override automatic environment detection
  * Fix Onboard not being shown in taskbar (LP: #990486)
  * Prevent zombie process when launching preferences (LP: #936332)
  * Only appear in gnome-screen-saver if onboard was running (LP: #938302)
  * Don't check for running Onboard if "Typing Assistant" is on (LP: #938302)
  * Fix potential encoding mismatches in exception handlers (LP #958385)
  * Fix idle transparency kicking in while typing into firefox awesomebar
  * Change spelling of the unity property to ONSCREEN_KEYBOARD
  * Properly set up WM_CLASS to be above dash (LP: 915250, LP: #931331)
  * Switch window property to type XA_CARDINAL for compiz
  * Release all keys before quitting Onboard (LP #978430)
  * Simplify opacity transitions to fix some transparency glitches
  * Stop blocking the unity launcher icon for some seconds after each click
  * Skip transition delays on screens without compositing
  * Suppress python error messages when stdin or stderr are lost
  * Fix glitches when toggling force-to-top mode or decoration
  * Don't flash the icon palette in lightdm
  * Don't create the icon palette when embedding
  * Improve robustness of showing/hiding the icon palette on startup
  * Keep keyboard and icon palette above unity-2d dash
  * Don't get resized by compiz grid plugin
  * Try to honor rotating screens in gnome-shell
  * Use deiconify for metacity when minimized by titlebar
  * Remove wnck dependency as gtk3's window-state-event reports iconification
  * Don't save window position for maximized or iconified windows
  * Stop endless loop of auto-showing and hiding hiding onboard in dash
  * Fix visibility of active modifier keys in scanning mode
  * Make sure to remove the maximize button on recreating the keyboard window
  * Don't try to hide keyboard when turning on force-to-top while iconified
  * Switch all translated strings to unicode (LP: #933030)
  * Improve robustness against errors in translations (LP: 968044)
  * Import translations from the Ubuntu Translators team as of 6th May 2012
  * Fix geometries not being saved when exiting from the very first launch
  * Briefly present the keyboard when unhiding
  * Add middle click in hover click mode; requires mousetweaks >= 3.3.90
  * Make improvements in Onboard's appearance
  * Add more information to README
  * Fix typos (LP: #951754)
  * Code cleanup

Francesco Fumanti (frafu) wrote :
description: updated
Francesco Fumanti (frafu) wrote :

onboard_0.97.1-0ubuntu2 because I forgot to remove the wnck from debian/control; this dependency is not needed anymore in Onboard 0.97.1.

Francesco Fumanti (frafu) wrote :

Please, ignore comment #6. As the debian package of Onboard 0.97.1-0ubuntu1 is not in the repositories yet, I decided to integrate the 0.97.1-0ubuntu2 change into 0.97.1-0ubuntu1.

Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :
Daniel Holbach (dholbach) wrote :

0.97.1 is in quantal already.

Changed in onboard (Ubuntu):
status: New → Fix Released
Daniel Holbach (dholbach) wrote :

Uploaded. I took the liberty of changing the version number to 0.97.1-0ubuntu0.1 and the target to precise-proposed.

Changed in onboard (Ubuntu Precise):
status: New → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Per the SRU process documented at https://wiki.ubuntu.com/StableReleaseUpdates , please add a [Test Case] to each bug being fixed, and discuss the [Regression Potential] in the description of this bug. Please include a plan for regression testing as well.

Also, the debdiff here is *89356* lines long. We review every SRU diff before accepting it, so can you please provide some insight into how to filter out any non-code changes?

Thanks!

marmuta (marmuta) wrote :

Sorry about the size of the diff, this is my fault. I just kept going on and on, merging all of trunks bug fixes upstream without much regard to the SRU process. Some of those changes, like fixes for the glitchy opacity transitions touched a lot of code, but generally simplified things and are supposed to be more robust as a result. Similarly, last minute changes of Precise allowed us to rip out clunky workarounds, namely detecting iconifying by libwnck instead of formerly broken GTK3.

I understand your frustration, perhaps 0.97.1 really isn't SRU material. It was well intentioned from our side, though. Regression testing for all releases is (still) done manually by checklist in four desktop environments: unity, unity-2d, gnome-shell and gnome classic (with and without compositing). If it helps in any way I'd send you the list.

Going through all the bugs again and creating test cases would take a lot of time. Most bugs and their fixes are only briefly documented in bazaar. If the SRU depends on a complete set of test cases we'd probably have to forgo it. Onboard 0.97.0 has been rather resilient anyway and people can get the update from our PPA(s) if needed.

I think at least one good reason for a SRU may be the ongoing troubles with translations crashing Onboard (for various reasons). See fresh bug #1013279 for example, but there have been plenty of others. The proposed update is much more robust in that regard and simply falls back to English for unexpected translations. There are usually workarounds available for the current version too, though.

Chris Halse Rogers (raof) wrote :

It's difficult - there are clearly a lot of fixes that would be nice to get in, but it's a huge change and some of it is not really bug-fixing. I'm reluctantly rejecting this upload.

The crashing when encountering unexpected translations sounds like a good SRU candidate, however - how hard would it be to cherry-pick just that fix?

marmuta (marmuta) wrote :

Ok, so I've talked this through with Francesco. What we'd like to do is to just suggest a (few) patch(es) for the Ubuntu source package instead. This would only cover the translation related crashes.

I'll have to double check, but IIRC there have been two issues, a fix for Exception handlers like in bug #958385 and another one for common format exceptions like in above bug #1013279. The former was already added to the Ubuntu package by Micah Gersten some time ago. I'm going to suggest adding
http://bazaar.launchpad.net/~onboard/onboard/0.97/revision/772
for the latter.

For whoever needs it (or hates the opacity flickering), the full update is then available in Quantal and as usual in our PPA.

Francesco Fumanti (frafu) wrote :

@ Chris

marmuta cherry-picked the changes for the translation fix and created a patch for onboard_0.97.0-0ubuntu3.

onboard_0.97.0-0ubuntu4 containing the patch is now available in this request for sponsorship:
https://bugs.launchpad.net/ubuntu/+source/onboard/+bug/1023434

@ All

We have put Onboard 0.97.1 in our stable PPA for those who would like to use it (please, take the PPA description into account before using it):
https://launchpad.net/~onboard/+archive/stable

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers