[nvidia-prime] Cannot adjust brightness in guest session and results in black screen while changing the resolution

Bug #1326257 reported by Tammy Yang on 2014-06-04
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
Nvidia
Undecided
Unassigned
OEM Priority Project
High
OEM Priority Team
Trusty
Undecided
Unassigned
nvidia-prime (Ubuntu)
Undecided
Alberto Milone
Precise
High
Alberto Milone
Trusty
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
Medium
Alberto Milone
Precise
Undecided
Unassigned
Trusty
High
Alberto Milone
xorg-server-lts-saucy (Ubuntu)
Precise
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

SRU Request

Systems with Optimus (Intel+NVIDIA GPUs) can have problems with the backlight (private bug #1290694) and when detecting and switching to different resolutions (private bug #1285062). Using the intel driver (with SNA) works better than the current solution (the modesetting driver).

[Impact]
 * Backlight control and resolution changes fail on some Optimus systems.

[Test Case]
 * Select performance mode from the nvidia-settings panel and try to adjust the backlight or to cycle through the available resolutions
    - Expected: the backlight can be adjusted, and changing the resolution works.
    - Bad behavior: the backlight can't be adjusted and changing the resolution can some times result in a black screen.

[Regression Potential]
 * Low, as the intel driver is more feature complete than modesetting.

[Other Info]
 * N/A

--

Running the proprietary nvidia drivers in an Optimus config works (Intel+NVIDIA) can discover two issues:

1. Cannot adjust brightness in the guest session (private bug #1290694)
[Test Case]
 * Switch to guest session and adjust brightness from settings or hotkey or command line
    - Expected: Can adjust the brightness
    - Bad behavior: Cannot adjust brightness

2. Black screen while changing the resolution (private bug #1285062)
but switching to the guest session results in a black screen.
[Test Case]
 * Go to display setting, set rotation to counterclockwise/clockwise/180 degrees and click apply
  - Expected results: Can switch display rotation successfully
  - Actual results: Black screen when switching display rotation

Tammy Yang (wanchingy) wrote :

Alberto has provided a fix in nvidia-prime to change xorg*.template

from
Driver "modesetting"
to
Driver "intel"

and add

Option "AccelMethod" "UXA"

The modified testing package is attached.
With the update of xorg-server for bug #1322212, this nvidia-prime package can pass all OEM QA tests.

Tammy Yang (wanchingy) wrote :

The package mentioned in comment #1

Tammy Yang (wanchingy) on 2014-06-04
Changed in oem-priority:
assignee: nobody → OEM Priority Team (oem-priority)
importance: Undecided → High
Alberto Milone (albertomilone) wrote :

We are disabling rotations in hybrid mode since it's not really supported (see the pending SRU in LP: #1308515). Also switching to the guest session will work.

What the Intel+UXA combination should fix is issues with the backlight i.e. point 1) that you mentioned. I'm not sure about 2).

Alberto Milone (albertomilone) wrote :

Also, wouldn't SNA be a better choice (vs UXA)? It seems to solve the issue with resolutions too.

Changed in nvidia-prime (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
status: New → In Progress
Changed in nvidia-prime (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → In Progress
Changed in nvidia-prime (Ubuntu Trusty):
status: New → Triaged
Changed in ubuntu-drivers-common (Ubuntu Precise):
status: New → Invalid
Changed in ubuntu-drivers-common (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
status: New → In Progress
Changed in ubuntu-drivers-common (Ubuntu Trusty):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
status: New → Triaged
Changed in nvidia-prime (Ubuntu Precise):
importance: Undecided → High
no longer affects: xorg-server-lts-saucy (Ubuntu)
Changed in nvidia-prime (Ubuntu Trusty):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.96

---------------
ubuntu-drivers-common (1:0.2.96) utopic; urgency=medium

  * gpu-manager.c:
    - Try harder when loading bbswitch (LP: #1310023).
      If loading bbswitch fails try with or without the
      "skip_optimus_dsm=1" option.
    - Switch to intel/SNA for optimus systems (LP: #1326257).
 -- Alberto Milone <email address hidden> Wed, 04 Jun 2014 15:59:24 +0200

Changed in ubuntu-drivers-common (Ubuntu):
status: In Progress → Fix Released
description: updated
Changed in ubuntu-drivers-common (Ubuntu Trusty):
importance: Medium → High
status: Triaged → In Progress
Ara Pulido (ara) on 2014-06-12
Changed in oem-priority:
status: New → In Progress

Hello Tammy, or anyone else affected,

Accepted ubuntu-drivers-common into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.2.91.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Kai-Heng Feng (kaihengfeng) wrote :

This package also fixes Bug #1330425, caused by xrandr reporting excessive list of resolution/refresh-rate, which makes wrong res/rate value being picked under mirror mode.

tags: added: blocks-hwcert-enablement
gerald.yang (gerald-yang-tw) wrote :

This package fixes backlight issue.

tags: added: verification-done
removed: verification-needed
gerald.yang (gerald-yang-tw) wrote :

Tested with ubuntu-drivers-common 1:0.2.91.6 in trusty-proposed, it's fixes the backlight issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.91.6

---------------
ubuntu-drivers-common (1:0.2.91.6) trusty-proposed; urgency=medium

  * UbuntuDrivers/detect.py, debian/tests/system, tests/ubuntu_drivers.py:
    - Do not autoinstall the broadcom driver. The open driver should be a
      better solution now (LP: #1306928), as the binary driver prevents
      a number of systems from using the wireless card.
    - Autoinstall linux-firmware-nonfree. This will help now that we no
      longer autoinstall Broadcom's binary driver.
    - Fix the relevant tests now that linux-firmware-nonfree has replaced
      bcmwl.
  * gpu-manager.c, tests/gpu-manager.py:
    - Ignore CRT displays when using PRIME. This works around systems whose
      BIOS provides a ghost output (LP: #1296020).
    - Check that we don't remove xorg.confs on 1st boot (as per the
      previous SRU).
    - Try harder when loading bbswitch (LP: #1310023). If loading bbswitch
      fails try with or without the "skip_optimus_dsm=1" option. Also, make
      sure that we trim dmi resources or matching will give us false
      positives.
    - Switch to intel/SNA for optimus systems (LP: #1326257).
    - Make sure to unload nvidia-uvm or nvidia won't be
      unloaded.
    - Make sure to walk properly the /dev/dri dir. This
      prevents the program from stopping when, for example
      /dev/dri/card1 is available while /dev/dri/card0 is
      not.
 -- Alberto Milone <email address hidden> Fri, 06 Jun 2014 11:20:28 +0200

Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-drivers-common has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Ara Pulido (ara) on 2014-09-03
Changed in oem-priority:
status: In Progress → Fix Released
Changed in hwe-next:
status: New → Fix Released
madbiologist (me-again) wrote :

The black screen after display rotation could be bug 1410238, which is fixed in Trusty's xserver-xorg-video-intel 2:2.99.910-0ubuntu1.4. This bug is also fixed on Utopic and Vivid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers