Ubuntu

dash doesn't ever respond to <enter> when the previous search is recalled

Reported by Alistair Buxton on 2012-04-12
92
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Nux
Low
Andrea Azzarone
Unity
Low
Andrea Azzarone
nux (Ubuntu)
Undecided
Andrea Azzarone
Precise
Undecided
Andrea Azzarone

Bug Description

to reproduce:

1. open the dash, search for a program and wait for search to complete (see bug 971130)
2. press enter to load the first item

This loads the program but only after waiting for the search to complete. Now:

3. open the dash again. search is saved, program you want is already the first item listed
4. press enter to load it

Result: nothing happens. It is as if the dash is still waiting for a search to complete before allowing you to press enter, but because the search is cached, no search takes place and therefore no completion event can be received. So in this case no matter how long you wait, you'll never be able to press enter.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Thu Apr 12 20:10:02 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Alistair Buxton (a-j-buxton) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Alan Pope ㋛ (popey) wrote :

Whilst the bug 971130 referenced is fixed, so you can now press enter earlier, I agree you can't if the search box is already filled in.

Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Changed in unity (Ubuntu Precise):
status: Confirmed → Triaged
Changed in unity:
milestone: none → 5.12.0
Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux:
status: New → In Progress
Changed in nux (Ubuntu Precise):
status: New → In Progress
Changed in nux:
assignee: nobody → Andrea Azzarone (andyrock)
importance: Undecided → Low
Changed in nux (Ubuntu Precise):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux:
status: In Progress → Fix Committed
Changed in nux (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-04-26
no longer affects: unity (Ubuntu Precise)
no longer affects: unity (Ubuntu)
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released

Hello Alistair, or anyone else affected,

Accepted nux into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
B Clausius (barcc) wrote :

The bug is only partially solved. It depends on the position of the mouse.
(Compare to comment 3 in bug 987294)

1. press super key to open the dash
2. type: gedit
3. press super key to close the dash
4. press super key to open the dash
5a. case: the mouse is not over an icon in the dash -> press enter: gedit opens as expected
5b. case: the mouse is over an icon in the dash -> press enter: noting happens

When the dash is opened with the super key the keyboard focus should in the edit area. In 5b that is not the case. You can verify this by pressing left or right key and then enter. -> the item at the left or right of the mouse is opened and not the item in the edit area.

sanmiguel9 (againsttcpa84) wrote :

I confirm B Clausius observation. Pressing Enter launches first item, but only if the mouse does not highlight an other item in the dash.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.12.0-0ubuntu1

---------------
nux (2.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - [regression] Dash - Arrow keys not working in the search bar on second
      use (LP: #987294)
    - dash doesn't ever respond to <enter> when the previous search is
      recalled (LP: #980184)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 07:57:55 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in nux (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers