nfs-common < 1.2.6 idmapd.conf parsing errors

Bug #1051262 reported by Jiri Horky on 2012-09-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nfs-utils (Ubuntu)
Undecided
Unassigned
Precise
Medium
Unassigned

Bug Description

Hi,

in Ubuntu 12.04, the version 1:1.2.5-3ubuntu3 of nfs-common (nfs-utils) suffers from the bug already reported upstream:

https://bugzilla.linux-nfs.org/show_bug.cgi?id=205

This causes failures when parsing idmapd.conf. The fix is pretty simple and is already explained in the linked ticket. The bug is fixed in upstream nfs-utils v1.2.6,

Cheers
Jiri Horky

Steve Langasek (vorlon) wrote :

Jiri,

Could you provide a reproducible test case demonstrating the problem?

Changed in nfs-utils (Ubuntu):
status: New → Fix Released
Changed in nfs-utils (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High

Hi,

I could not resist to say that pointing at a quite common bug in a C
program (non terminating string with a 0 character) together with a link
to the fix should be enough in my opinion. As the exact result of the
idmapd behavior with this bug depends on a way glibc/kernel allocates
the memory, it may be hard to hit a problem reproducibly, but it does
not mean it is not there. I mainly writes it because the way I have hit
the problem may say too non-standard.

I came across this problem with the idmapd.conf file below with a Static
mapping plugin (that is only available in a git of libnfsidmapd that I
used via LD_LIBRARY_PATH). The problem observed was:

root@elvys:~# LD_LIBRARY_PATH=~/libnfsidmap/.libs/ rpc.idmapd -f -vvv
rpc.idmapd: libnfsidmap: Unable to determine the NFSv4 domain; Using
'localdomain' as the NFSv4 domain which means UIDs will be mapped to the
'Nobody-User' user defined in /etc/idmapd.conf

root@elvys:~# cat /etc/idmapd.conf
[General]

Verbosity = 0
Pipefs-Directory = /run/rpc_pipefs
# set your own domain here, if id differs from FQDN minus hostname
Domain = EINFRA

[Mapping]

Nobody-User = nobody
Nobody-Group = nogroup

[Translation]
Method = static, nsswitch

[Static]

uzivatel@EINFRA = lokalniuzivatel
uzivatel2@EINFRA = jinylokalniuzivatel
storage@EINFRA = users

Regards,
Jiri Horky

On 09/18/2012 09:00 AM, Steve Langasek wrote:
> Jiri,
>
> Could you provide a reproducible test case demonstrating the problem?
>
> ** Changed in: nfs-utils (Ubuntu)
> Status: New => Fix Released
>
> ** Also affects: nfs-utils (Ubuntu Precise)
> Importance: Undecided
> Status: New
>
> ** Changed in: nfs-utils (Ubuntu Precise)
> Status: New => Triaged
>
> ** Changed in: nfs-utils (Ubuntu Precise)
> Importance: Undecided => High
>

Steve Langasek (vorlon) wrote :

Thanks. The point of having a reproducible test case is to confirm that the change fixes the problem you're experienced. It also helps us assess the practical impact of the bug.

In this particular case, it sounds like this bug only impacts users who are using local versions of Ubuntu packages. That reduces the severity somewhat; marking as 'medium' rather than 'high'.

Changed in nfs-utils (Ubuntu Precise):
importance: High → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers