[network]: gnome-control-center crashed with SIGSEGV in nm_device_get_udi()

Bug #1076458 reported by Dan Woodson on 2012-11-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Critical
network-manager (Debian)
Fix Released
Unknown
network-manager (Ubuntu)
Medium
Unassigned
Precise
High
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

 * gnome-control-center will crash when you get into network panel.

[Test Case]

 * open gnome-control-center
 * click network --2
 * go back to main panel --3
 * repeat step 2 and 3

[Regression Potential]

 * https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=696143 it has been accepted by upstream for a very long time. And our qe has verified it.

Dan Woodson (woodson-dan) wrote :

StacktraceTop:
 nm_device_get_udi (device=0xb91fcd20) at nm-device.c:873
 ?? () from /tmp/tmpZiSAOl/usr/lib/control-center-1/panels/libnetwork.so
 g_cclosure_marshal_VOID__PARAM (closure=0xb97b26a8, return_value=0x0, n_param_values=2, param_values=0xbf8f2f90, invocation_hint=0xbf8f2f10, marshal_data=0x0) at /build/buildd/glib2.0-2.32.3/./gobject/gmarshal.c:1042
 g_closure_invoke (closure=0xb97b26a8, return_value=0x0, n_param_values=2, param_values=0xbf8f2f90, invocation_hint=0xbf8f2f10) at /build/buildd/glib2.0-2.32.3/./gobject/gclosure.c:777
 signal_emit_unlocked_R (node=0xb9177118, detail=1918, instance=0xb925e578, emission_return=0x0, instance_and_params=0xbf8f2f90) at /build/buildd/glib2.0-2.32.3/./gobject/gsignal.c:3547

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
information type: Private → Public
affects: gnome-control-center (Ubuntu) → network-manager (Ubuntu)
Madper Xie (bbboson) wrote :

upstream fix: cgit.freedesktop.org/NetworkManager/NetworkManager/commit/libnm-glib/nm-active-connection.c?id=be18dd06cd138be232ff68ec7af19cfcf2f969ed

description: updated
Ara Pulido (ara) wrote :

This cannot be reproduced in Trusty.

Changed in network-manager (Ubuntu Trusty):
status: New → Invalid
description: updated
Changed in network-manager (Ubuntu):
status: New → Fix Released
Changed in network-manager (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High

Hello Dan, or anyone else affected,

Accepted network-manager into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/network-manager/0.9.4.0-0ubuntu4.4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in network-manager:
importance: Unknown → Critical
status: Unknown → Fix Released
Changed in network-manager (Debian):
status: Unknown → Fix Released
Bartosz Kosiorek (gang65) wrote :

I reproduced this crash on my local Precise machine:
gnome-control-center

(gnome-control-center:501): Gtk-WARNING **: Overriding tab label for notebook

(gnome-control-center:501): Gtk-WARNING **: Overriding tab label for notebook

** (gnome-control-center:501): CRITICAL **: nm_device_get_udi: assertion `NM_IS_DEVICE (device)' failed
Segmentation fault

Bartosz Kosiorek (gang65) wrote :

More details about crash:

Program received signal SIGSEGV, Segmentation fault.
0x00007fffd582323e in nm_device_get_udi () from /usr/lib/libnm-glib.so.4
(gdb) bt
#0 0x00007fffd582323e in nm_device_get_udi () from /usr/lib/libnm-glib.so.4
#1 0x00007fffd5ed5e10 in ?? () from /usr/lib/control-center-1/panels/libnetwork.so
#2 0x00007ffff61f7ca2 in g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#3 0x00007ffff6208d71 in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#4 0x00007ffff6211069 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#5 0x00007ffff6211212 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#6 0x00007ffff61fc957 in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#7 0x00007ffff61fe233 in g_object_notify () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#8 0x00007fffd581c08b in ?? () from /usr/lib/libnm-glib.so.4
#9 0x00007ffff5f3ad13 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007ffff5f3b060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007ffff5f3b124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007ffff64cedd4 in g_application_run () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#13 0x000055555555b7aa in main ()

Bartosz Kosiorek (gang65) wrote :

Unfortunately crash still exists on my hardware (Precise)

apt-cache policy network-manager
network-manager:
  Installed: 0.9.4.0-0ubuntu4.4.2
  Candidate: 0.9.4.0-0ubuntu4.4.2
  Version table:
 *** 0.9.4.0-0ubuntu4.4.2 0
        100 /var/lib/dpkg/status
     0.9.4.0-0ubuntu4.4.1 0
        500 http://ftp.icm.edu.pl/pub/Linux/ubuntu/ precise-updates/main amd64 Packages
     0.9.4.0-0ubuntu3 0
        500 http://ftp.icm.edu.pl/pub/Linux/ubuntu/ precise/main amd64 Packages

Bartosz Kosiorek (gang65) wrote :

Backtrace:

Program received signal SIGSEGV, Segmentation fault.
0x00007fffd582323e in nm_device_get_udi () from /usr/lib/libnm-glib.so.4
(gdb) bt
#0 0x00007fffd582323e in nm_device_get_udi () from /usr/lib/libnm-glib.so.4
#1 0x00007fffd5ed5dda in ?? () from /usr/lib/control-center-1/panels/libnetwork.so
#2 0x00007ffff61f7ca2 in g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#3 0x00007ffff6208d71 in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#4 0x00007ffff6211069 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#5 0x00007ffff6211212 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#6 0x00007ffff61fc957 in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#7 0x00007ffff61fe233 in g_object_notify () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#8 0x00007fffd581c08b in ?? () from /usr/lib/libnm-glib.so.4
#9 0x00007ffff5f3ad13 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007ffff5f3b060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007ffff5f3b124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007ffff64cedd4 in g_application_run () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#13 0x000055555555b7aa in main ()

tags: added: verification-failed
removed: verification-needed
Changed in network-manager (Ubuntu Precise):
status: Fix Committed → In Progress

The version of network-manager in the proposed pocket of Precise that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.