Yelp always displays Unity user guide

Bug #852911 reported by Jan Hoffmann on 2011-09-17
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-contacts (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
gnome-control-center (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned
Precise
Low
Unassigned
nautilus (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned
Precise
Low
Unassigned
yelp (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Yelp displays the Unity user guide even on a system with only Gnome Shell installed. Insted it should display the Unity guide in Unity sessions and the Gnome guide in Gnome sessions. Currently the default page seems to be hard-coded.
Sadly I do not know how to get the current session in C, but for one of the developers this should be a rather quick fix.

Jan Hoffmann (jan-hoffmann) wrote :

I just checked on the Oneiric Live CD. The environment variable XDG_CURRENT_SESSION is either "Unity" or "GNOME", so using that for differentiating between the session types should be very easy.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in yelp (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yelp - 3.1.4-0ubuntu1

---------------
yelp (3.1.4-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Fixed loading HTML & TXT documents
  * debian/patches/06_make_ubuntu_docs_default.patch:
    - Use GNOME help if running GNOME Shell or Fallback (LP: #852911)
 -- Jeremy Bicha <email address hidden> Thu, 22 Sep 2011 03:18:01 -0400

Changed in yelp (Ubuntu):
status: Confirmed → Fix Released
Jan Hoffmann (jan-hoffmann) wrote :

In Nautilus the help menu items are still hard-coded to the Unity user guide, instead to detect the session.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.2.0-0ubuntu3

---------------
gnome-control-center (1:3.2.0-0ubuntu3) oneiric; urgency=low

  [ Rodrigo Moya ]
  * debian/patches/00git_show_search_view.patch:
    - Make sure we gtk_widget_show the search view (LP: #860950)
  * debian/UbuntuLogo.png:
    - Use the correct version of the icon (LP: #860497)
  * debian/control:
    - Add missing NetworkManager build dependencies (LP: #861443)
  * debian/patches/12_add_never_turn_screen_off.patch:
    - Add back the "never turn screen off" option (LP: #862154)

  [ Jeremy Bicha ]
  * debian/patches/53_use_ubuntu_help.patch: Use gnome-help when running
    GNOME or GNOME Fallback (LP: #852911)
 -- Rodrigo Moya <email address hidden> Thu, 29 Sep 2011 12:47:53 +0200

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
Jeremy Bicha (jbicha) wrote :

I was only able to fix 1 of the 2 help strings in System Settings. The other one is more complicated.

Changed in gnome-control-center (Ubuntu):
status: Fix Released → Triaged
Sebastien Bacher (seb128) wrote :

Jeremy could you describe the issue there? Do you need help to fix it?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Changed in nautilus (Ubuntu):
importance: Undecided → Low
Changed in yelp (Ubuntu):
importance: Undecided → Low
Jeremy Bicha (jbicha) wrote :

Basically, the request is that we use gnome-help instead of ubuntu-help when the user is running GNOME Shell & GNOME Fallback. I fixed this for yelp's default homepage and 1 of the 2 strings in System Settings. The other one is hidden in a .ui file which looked more complicated to tweak.

Also, the vino & nautilus help patches should be updated but I need some help as I haven't been able to figure out how to do it yet.

Long term, I'd like to still show Ubuntu's help in GNOME Fallback since neither the GNOME or Ubuntu help covers that environment but the Ubuntu help has quite a bit of other adjustments for Ubuntu instead of the generic GNOME guidance.

Sebastien Bacher (seb128) wrote :

ok, for the .ui you probably need to use gtk_builder_get_object() to get the object you need and then change it from the code... I'm wondering if instead patching applications we couldn't create an "yelp" wrapper which does those url conversions under unity and then call the real yelp binary on the right url

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu Oneiric):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package gnome-control-center - 1:3.2.2-2ubuntu1

---------------
gnome-control-center (1:3.2.2-2ubuntu1) precise; urgency=low

  * Rebase on Debian, remaining Ubuntu changes:
  * debian/control:
    - Build-Depend on hardening-wrapper, dpkg-dev and dh-autoreconf
    - Add dependency on ubuntu-system-service
    - Don't depend on cheese, cups-pk-helper, libsocialweb, or mesa-utils
      since they're in universe
    - Depend on ubuntu-docs instead of gnome-user-guide
  * debian/rules:
    - Add binary-post-install rule for gnome-control-center-data
    - Don't build with cheese or libsocialweb
  * debian/gnome-control-center-data.install:
  * debian/source/include-binaries:
    - Install UbuntuLogo.png & apport hook
  * debian/gnome-control-center.dirs:
  * debian/gnome-control-center.links:
    - Add a link to the control center shell for indicators
  * debian/patches/04_add_theme_selection.patch:
    - Add theme selection to User Interface panel
    - Refreshed for Precise design and renamed to User Interface
  * debian/patches/01_allow_external_panels.patch:
    - Allow running external (non-embedded) panels (LP: #787694)
  * debian/patches/02_no_assert_on_null_streams.patch:
    - Temporary patch to not assert on NULL streams (LP: #741155)
  * debian/patches/03_show_wacom_under_unity.patch:
    - show the wacom panel under unity (lp: #840555)
  * debian/patches/05_run_update_manager.patch:
    - Run update-manager instead of PackageKit updater (LP: #801335)
  * debian/patches/07_make_window_wider.patch
    - Make the System Settings window a bit wider to reduce need for scrolling
  * debian/patches/10_keyboard_layout_on_unity.patch:
    - Show keyboard layout bits on Unity (LP: #834523)
  * Add 11_power-configure_lid_action.patch: Add back configuration for lid
    action. (LP: #792636, GNOME#659045)
  * debian/patches/12_add_never_turn_screen_off.patch:
    - Add back the "never turn screen off" option (LP: #862154)
  * debian/patches/50_ubuntu_systemwide_prefs.patch:
    - Add back system-wide proxy settings (LP: #795519)
  * debian/patches/52_ubuntu_language_list_mods.patch:
    - Change the list of options, when setting language from User
      Accounts, to items representing available translations, and with
      that make it similar to the language list in language-selector.
    - Make items representing language @variants be displayed as such.
  * debian/patches/53_use_ubuntu_help.patch: Use gnome-help when running
    GNOME or GNOME Fallback (LP: #852911)
  * debian/patches/55_user_accounts_hide_controls.patch:
    - When not using GDM, hide certain controls in the User Accounts
      panel that only apply to it. (LP: #821766, LP: #821771)
    - When a user is using an ecryptfs home directory, do not allow
      the user to log in without a password
  * debian/patches/56_use_ubuntu_info_branding.patch:
    - Use Ubuntu branding in System info panel (LP: #860497)
  * debian/patches/57_use_nonsymbolic_keyboard_icon.patch: Use the non-monochrome
    icon for the Keyboard panel (LP: #862027)
  * debian/patches/90_git_sound_tab_order.patch: Reorder the tabs, the sound
    effect one is the less used and should...

Read more...

Changed in gnome-control-center (Ubuntu Precise):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) on 2012-11-03
Changed in nautilus (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
Changed in nautilus (Ubuntu Precise):
status: Fix Released → Confirmed
Changed in gnome-control-center (Ubuntu):
status: Fix Released → Confirmed
status: Confirmed → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
status: In Progress → Fix Committed
Changed in nautilus (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.6.2-0ubuntu2

---------------
nautilus (1:3.6.2-0ubuntu2) raring; urgency=low

  * debian/patches/15_use-ubuntu-help.patch:
    - Updated to not point to Ubuntu help when running GNOME (LP: #852911)
 -- Jeremy Bicha <email address hidden> Fri, 02 Nov 2012 22:27:11 -0400

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2013-06-27
Changed in gnome-contacts (Ubuntu Oneiric):
status: New → Won't Fix
Changed in nautilus (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in gnome-control-center (Ubuntu Oneiric):
status: Triaged → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-contacts - 3.8.3-0ubuntu1

---------------
gnome-contacts (3.8.3-0ubuntu1) saucy; urgency=low

  * New upstream release.
  * debian/control.in:
    - Build-depend on cheese for webcam integration (LP: #1189180)
  * debian/patches/unity_no_goa.patch:
    - Update to point Online Accounts link to UOA when running Unity
      since UOA can do address books via evolution-data-server now
  * debian/patches/fix_help_link.patch:
    - Point to ubuntu-help when running Unity (LP: #852911)
 -- Jeremy Bicha <email address hidden> Fri, 02 Aug 2013 09:30:31 -0400

Changed in gnome-contacts (Ubuntu):
status: New → Fix Released
Jeremy Bicha (jbicha) on 2016-05-15
Changed in gnome-control-center (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers