C-state C3 does not work after disconnecting the AC power from notebook

Bug #995005 reported by Thomas Schlichter on 2012-05-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

On my Samsung NC20 Netbook the BIOS hides the C3 C-state when the AC power is connected, but it should show up and work as soon as the AC power is disconnected.

This expected behavior worked fine as long as I used Oneiric. But now I upgraded to Precise and now C3 does not work anymore after disconnecting the AC power.

I have verified, that booting the Oneiric kernel 3.0.0-19.33 instead of the Precise Kernel 3.2.0-24.37 (same userspace) fixes the problem.

To gather some information, I executed this command with the Precise kernel
  grep -r "" /sys/devices/system/cpu/cpu0/cpuidle/
in different system states:
1. newly booted without having the AC power attached
2. having the AC power attached (without C3, as expected)
3. now after having the AC power disconnected (not functional C3 --> bug)

The output is combined in the attached file "cpuidle.txt".
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: VT82xx [HDA VIA VT82xx], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: VT82xx [HDA VIA VT82xx], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: schlicht 2920 F.... kded4
                      schlicht 3190 F.... kmix
Card0.Amixer.info:
 Card hw:0 'VT82xx'/'HDA VIA VT82xx at 0xf5400000 irq 67'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,144dc04e,00100001'
   Controls : 18
   Simple ctrls : 10
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=/dev/sda6
MachineType: SAMSUNG ELECTRONICS CO., LTD. NC20/NB20
Package: linux 3.2.0.24.26
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=de_DE
 TERM=xterm
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic-pae root=UUID=28a00041-0781-44a2-8a24-684926bf9ea9 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic-pae N/A
 linux-backports-modules-3.2.0-24-generic-pae N/A
 linux-firmware 1.79
Tags: precise
Uname: Linux 3.2.0-24-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/25/2009
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 10MQ
dmi.board.name: NC20/NB20
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr10MQ:bd11/25/2009:svnSAMSUNGELECTRONICSCO.,LTD.:pnNC20/NB20:pvr04MQ:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNC20/NB20:rvr:cvnSAMSUNGELECTRONICSCO.,LTD.:ct10:cvrN/A:
dmi.product.name: NC20/NB20
dmi.product.version: 04MQ
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Thomas Schlichter (bigboss77) wrote :
tags: added: apport-collected precise
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Brad Figg (brad-figg) on 2012-05-05
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc7-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: kernel-da-key needs-upstream-testing
Thomas Schlichter (bigboss77) wrote :

I've been testing
   linux-image-3.4.0-030400rc6-generic-pae_3.4.0-030400rc6.201205061835_i386.deb
unfortunately it has the same buggy behavior.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
importance: Medium → Unknown
status: Confirmed → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Incomplete
Thomas Schlichter (bigboss77) wrote :

FInally two patches have been merged upstream that together fix this bug:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commitdiff;h=8aef33a7cf40ca9da188e8578b2abe7267a38c52
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commitdiff;h=f427e5f1cf75bba84cccdac1d8a90552d9ae1065

It would be great if you could also merge these commits to fix this bug in Precise and Quantal.

Kind regards,
  Thomas

Joseph Salisbury (jsalisbury) wrote :

It looks like commit f427e5f1cf75bba84cccdac1d8a90552d9ae1065 was sent to stable.

However, commit 8aef33a7cf40ca9da188e8578b2abe7267a38c52 did not cc stable. Do you know if the second commit will be requested for inclusion in upstream stable?

Changed in linux (Ubuntu Precise):
status: New → Triaged
Changed in linux (Ubuntu Quantal):
status: New → Triaged
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu Quantal):
importance: Undecided → Medium
Thomas Schlichter (bigboss77) wrote :

You are right, I just recognized that only one of the patches went to stable. But as both are required to fix the bug, I think I'll ask if the other patch could go to stable, too.

Kind regards,
  Thomas

Joseph Salisbury (jsalisbury) wrote :

Thanks, Thomas. That would be great. Then the fixes will make it into the Ubuntu stable kernels through the usual update process.

Changed in linux:
status: Incomplete → Fix Released
Julian Wiedmann (jwiedmann) wrote :

Merged during the raring cycle, but the second patch is still missing in Precise/Quantal.

Changed in linux (Ubuntu):
status: Triaged → Fix Released

This bug was nominated against a series that is no longer supported, ie quantal. The bug task representing the quantal nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Quantal):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.