Thinkpad X120e doesn't suspend/resume

Bug #903999 reported by Martin Albisetti on 2011-12-13
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Suspend/resume doesn't seem to work, I tried running the script specified in: https://wiki.ubuntu.com/KernelTeam/SuspendResumeTesting
The first says it couldn't sleep, and the second test takes the laptop into a blank screen which I can't recover from (that's usually what happens when I try to resume).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-4-generic-pae 3.2.0-4.10
ProcVersionSignature: Ubuntu 3.2.0-4.10-generic-pae 3.2.0-rc5
Uname: Linux 3.2.0-4-generic-pae i686
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.90-0ubuntu1
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: beuno 1638 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xf0244000 irq 44'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 5
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'SB'/'HDA ATI SB at 0xf0240000 irq 16'
   Mixer name : 'Conexant CX20582 (Pebble)'
   Components : 'HDA:14f15066,17aa21df,00100302'
   Controls : 8
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Dec 13 20:13:16 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: LENOVO 05962RU
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-generic-pae root=UUID=c9ef48cc-ddc5-4873-ac9b-2a14fe2329d3 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-4-generic-pae N/A
 linux-backports-modules-3.2.0-4-generic-pae N/A
 linux-firmware 1.62
SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2011-12-10 (3 days ago)
dmi.bios.date: 08/25/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8FET31WW (1.15 )
dmi.board.asset.tag: Not Available
dmi.board.name: 05962RU
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8FET31WW(1.15):bd08/25/2011:svnLENOVO:pn05962RU:pvrThinkPadX120e:rvnLENOVO:rn05962RU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 05962RU
dmi.product.version: ThinkPad X120e
dmi.sys.vendor: LENOVO

Martin Albisetti (beuno) wrote :
Brad Figg (brad-figg) on 2011-12-13
Changed in linux (Ubuntu):
status: New → Confirmed
Tim Gardner (timg-tpi) wrote :

Martin - As far as I can tell I have identical hardware, purchased about a month ago. Same BIOS even. The major difference that I've noticed is that you are using a 32 bit kernel whereas I'm running 64. Could you pop in a live CDROM image on a USB stick to see if your suspend/resume problems persist? Remember that Precise images can be dd'd, so you need not use usb-creator.

Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Tim Gardner (timg-tpi) wrote :

Doh! Why don't _I_ just pop in a 32 bit Live CD image and try for myself ?

Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Tim Gardner (timg-tpi) wrote :

Drat. Booted from a 32 bit daily. Works fine. I tried twice from the menu and once by closing the lid.

Martin Albisetti (beuno) wrote :

So, I can confirm that with the live CD 64bit, I can suspend/resume just fine. Maybe this is a by-product of the upgrade from Oneiric.
If there's any value in debugging the problem, I'm happy to do that. If not, I'll wipe it clean and do a fresh install (probably 32bit, because flash and skype).

Tim Gardner (timg-tpi) wrote :

Martin - with multi-arch support in Precise you should be able to use flash and skype even though they are 32 bit applications.

The upgrade issue is likely of some interest to foundations, though I guarantee there is a kernel component to the problem. Perhaps something in /etc/modprobe.d ? or a bogus script in pm-utils ?

Martin Albisetti (beuno) wrote :
Download full text (4.2 KiB)

beuno@martin-lenovo:~$ ls -l /etc/modprobe.d/
total 40
-rw-r--r-- 1 root root 2507 May 5 2011 alsa-base.conf
-rw-r--r-- 1 root root 325 Jun 15 13:57 blacklist-ath_pci.conf
-rw-r--r-- 1 root root 1644 Dec 10 13:19 blacklist.conf
-rw-r--r-- 1 root root 108 Sep 27 09:47 blacklist-cups-usblp.conf
-rw-r--r-- 1 root root 210 Jun 15 13:57 blacklist-firewire.conf
-rw-r--r-- 1 root root 661 Jun 15 13:57 blacklist-framebuffer.conf
-rw-r--r-- 1 root root 156 May 5 2011 blacklist-modem.conf
lrwxrwxrwx 1 root root 41 Dec 10 12:20 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
-rw-r--r-- 1 root root 583 Jun 15 13:57 blacklist-rare-network.conf
-rw-r--r-- 1 root root 1077 Jun 15 13:57 blacklist-watchdog.conf
-rw-r--r-- 1 root root 127 Dec 8 17:36 dkms.conf
lrwxrwxrwx 1 root root 46 Dec 7 22:12 fglrx.conf -> /etc/alternatives/i386-linux-gnu_fglrx_modconf

beuno@martin-lenovo:~$ ls -l /usr/lib/pm-utils/
total 44
drwxr-xr-x 2 root root 4096 Dec 10 12:02 bin
-rw-r--r-- 1 root root 2019 Nov 7 23:49 defaults
-rwxr-xr-x 1 root root 5267 Nov 7 23:49 functions
drwxr-xr-x 2 root root 4096 Dec 10 12:02 module.d
-rwxr-xr-x 1 root root 9782 Nov 7 23:49 pm-functions
drwxr-xr-x 2 root root 4096 Dec 10 12:02 power.d
drwxr-xr-x 2 root root 4096 Dec 10 12:06 sleep.d
drwxr-xr-x 2 root root 4096 Dec 10 12:02 video-quirks
beuno@martin-lenovo:~$ ls -l /usr/lib/pm-utils/sleep.d/
total 72
-rwxr-xr-x 1 root root 292 Nov 7 23:49 000kernel-change
-rwxr-xr-x 1 root root 274 Nov 7 23:49 00logging
-rwxr-xr-x 1 root root 203 Nov 7 23:49 00powersave
-rwxr-xr-x 1 root root 2693 Dec 5 17:10 01PulseAudio
-rwxr-xr-x 1 root root 886 Nov 7 23:49 49bluetooth
-rwxr-xr-x 1 root root 1228 Nov 7 23:49 55NetworkManager
-rwxr-xr-x 1 root root 267 Oct 28 06:22 60_wpa_supplicant
-rwxr-xr-x 1 root root 453 Nov 7 23:49 75modules
-rwxr-xr-x 1 root root 614 Nov 7 23:49 90clock
-rwxr-xr-x 1 root root 1098 Nov 7 23:49 94cpufreq
-rwxr-xr-x 1 root root 727 Jun 20 2010 95anacron
lrwxrwxrwx 1 root root 23 Dec 5 15:12 95hdparm-apm -> ../power.d/95hdparm-apm
-rwxr-xr-x 1 root root 297 Nov 7 23:49 95led
-rwxr-xr-x 1 root root 13893 Nov 7 23:49 98video-quirk-db-handler
-rwxr-xr-x 1 root root 5667 Nov 7 23:49 99video
beuno@martin-lenovo:~$ ls -l /usr/lib/pm-utils/power.d/
total 52
-rwxr-xr-x 1 root root 2251 Jun 7 2011 95hdparm-apm
-rwxr-xr-x 1 root root 644 Jun 20 2010 anacron
-rwxr-xr-x 1 root root 562 Nov 7 23:49 disable_wol
-rwxr-xr-x 1 root root 1316 Nov 7 23:49 hal-cd-polling
-rwxr-xr-x 1 root root 870 Nov 7 23:49 intel-audio-powersave
-rwxr-xr-x 1 root root 1290 Nov 7 23:49 journal-commit
-rwxr-xr-x 1 root root 2722 Nov 7 23:49 laptop-mode
-rwxr-xr-x 1 root root 201 Nov 7 23:49 pcie_aspm
-rwxr-xr-x 1 root root 1222 Nov 7 23:49 readahead
-rwxr-xr-x 1 root root 1131 Nov 7 23:49 sata_alpm
-rwxr-xr-x 1 root root 652 Nov 7 23:49 sched-powersave
-rwxr-xr-x 1 root root 2495 Nov 7 23:49 wireless
-rwxr-xr-x 1 root root 1642 Nov 7 23:49 xfs_buffer
beuno@martin-lenovo:~$ ls -l /usr/lib/pm-utils/module.d/
total 12
-rwxr-xr-x 1 root root 120 Nov 7 23:49 kernel
-rwxr-xr-x 1 root root 1564 Nov 7 23:49 tuxonice
-rwxr-xr-x 1 root ...

Read more...

Martin Albisetti (beuno) wrote :

Following up, and to make things wierder, after installing from scratch, 64bit (the same one that suspends fine in a live cd), it still doesn't suspend. Exact same symptoms, so I guess it's not an upgrade issue.

Martin Albisetti (beuno) wrote :

This seems to been have fixed in the latest upgrades.

Changed in linux (Ubuntu Precise):
status: In Progress → Fix Released
Martin Albisetti (beuno) wrote :

Back to not working :(

Changed in linux (Ubuntu Precise):
status: Fix Released → New
Brad Figg (brad-figg) on 2012-01-25
Changed in linux (Ubuntu):
status: New → Confirmed
Eric (enordenstam) wrote :

This workaround worked for me in fedora. It may work in ubuntu too, since I suspect it is a bios issue. I had the same problem in Fedora. I installed ubuntu to see if that would work better, but it did not. I installed fedora again. What finally solved the problem for me was going into the bios settings (by pressing F1 at boot) and there pressing F9 to reset everything to defaults. Then save and reboot. This messed up the UEFI settings so I had to reinstall Fedora. After this, suspend and resume work beautifully. The bios version on my machine is 1.16.

tags: added: resume suspend
Justin Force (justin-force) wrote :

I don't think that this issue is related to BIOS settings since my X120e has no trouble sleeping/waking when booted to Windows. I'm running 12.04 64-bit desktop.

summary: - Thinkpad x120e doesn't suspend/resume
+ Thinkpad X120e doesn't suspend/resume
Tim Gardner (timg-tpi) on 2012-08-20
Changed in linux (Ubuntu):
assignee: Tim Gardner (timg-tpi) → nobody
Changed in linux (Ubuntu Precise):
assignee: Tim Gardner (timg-tpi) → nobody
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux (Ubuntu Precise):
status: Confirmed → Triaged
Chris J Arges (arges) wrote :

Tested this on Martin Stadtler's X120e with AMD E350, BIOS version 1.13.
On Precise 64, was not able to resume from suspend using Fn-F4, Suspend from the menu, the screen remained blank, with the suspend light on. However; I was able to suspend occasionally from a virtual console using pm-suspend; however this also failed a few times.
On Quantal 64, was not able to resume from suspend using Fn-F4. Upon resume the screen starting alternating between black and white screens.

Martin Albisetti, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder, but the one all the way at the bottom) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-1.17 needs-upstream-testing
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers