Dell Precision M6600 laptop hangs on reboot

Bug #841264 reported by nickgsd on 2011-09-04
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Precise
Medium
Leann Ogasawara

Bug Description

Description: Ubuntu oneiric (development branch)
Release: 11.10

Reboot on 11.10-beta1 (fully up-to-date as at 2011-09-04 19:30 BST) hangs at

[ xxxx.yyyyyy] Restarting system

It requires a forced power-off. Also experienced the same with 11.04.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-10-generic 3.0.0-10.16
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: nick 1631 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xe1e60000 irq 54'
   Mixer name : 'IDT 92HD90BXX'
   Components : 'HDA:111d76e7,102804a4,00100102'
   Controls : 15
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xe0080000 irq 17'
   Mixer name : 'Nvidia GPU 12 HDMI/DP'
   Components : 'HDA:10de0012,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Sun Sep 4 19:52:23 2011
HibernationDevice: RESUME=UUID=6a9d1034-a54e-4ea8-8939-9856661e27b0
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
MachineType: Dell Inc. Precision M6600
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-10-generic root=/dev/mapper/hostname-root ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-10-generic N/A
 linux-backports-modules-3.0.0-10-generic N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/24/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 04YY4M
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd05/24/2011:svnDellInc.:pnPrecisionM6600:pvr01:rvnDellInc.:rn04YY4M:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Precision M6600
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

nickgsd (nickgsd) wrote :
Brad Figg (brad-figg) on 2011-09-04
Changed in linux (Ubuntu):
status: New → Confirmed

Hi nickgsd,

If you try booting with reboot=bios or reboot=pci via the kernel command line, do either of those allow you to successfully reboot? Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
nickgsd (nickgsd) wrote :

Hi Leann,

I changed the kernel command line as you requested, following instructions from http://lists.debian.org/debian-user/2011/06/msg00480.html to modify "/etc/default/grub" then running "sudo update-grub", followed by a grep on the /boot/grub/grub.cfg to check the change had taken OK.

NOTE: System updated/patched fully via standard system update as of 2011-09-09 at 17:00 BST.

TEST 1 - with "reboot=bios"
Shutdown system after making change to grub configuration, then power on. Did "Restart" from Ubuntu GUI, same hang as before.

TEST 2 - with "reboot=pci"
Shutdown system after making change to grub configuration, then power on. Did "Restart" from Ubuntu GUI, system looks like it is about to restart, then powers off completely requiring power button touch to boot.

Please let me know if there is anything further I can test.

Thanks,
Nick

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
nickgsd (nickgsd) wrote :

Dell released a new BIOS (revision A04) for the Dell Precision M6600 about a week ago. After updating to this new BIOS it has now resolved the reboot hang problem.

Per comment #4 this was resolved with a BIOS update. Closing the linux kernel task.

Changed in linux (Ubuntu):
status: Triaged → Invalid
Joshua Kugler (jkugler) wrote :

This bug is back (?). I have a newly acquired M6600 with an A07 bios. It hangs on reboot (and shutdown). I have not tried the reboot=XXXXX work arounds yet.

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Joshua Kugler (jkugler) wrote :

Sorry: This is with Ubuntu 11.04.

Andrew Boie (andrewboie) wrote :

I see this issue with 12.04 and BIOS A08 on a Dell M4600 (similar machine but 15" form factor). Adding "reboot=pci" to the kernel command line fixes it; laptop reboots normally.

madbiologist (me-again) wrote :

This is fixed in the upstream 3.5 kernel. From the changelog:

author Zhang Rui
Mon, 20 Feb 2012 06:20:06 +0000 (14:20 +0800)
committer Len Brown
Tue, 5 Jun 2012 04:16:12 +0000 (00:16 -0400)
commit 76eb9a30db4bc8fd172f9155247264b5f2686d7b
tree 50da04a2a05f779e19cac7d0b52155797b82f772
parent 9f132652d94c96476b0b0a8caf0c10e96ab10fa8

ACPI, x86: fix Dell M6600 ACPI reboot regression via DMI

Dell Precision M6600 is known to require PCI reboot, so add it to
the reboot blacklist in pci_reboot_dmi_table[].

https://bugzilla.kernel.org/show_bug.cgi?id=42749

cc: x86 at kernel.org
Signed-off-by: Zhang Rui
Signed-off-by: Len Brown

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed

The Quantal 12.10 kernel was recently rebased to upstream v3.5 final and uploaded. I'm therefore marking this Fix Released for Quantal. Thanks.

ubuntu-quantal$ git describe --contains 76eb9a30db4bc8fd172f9155247264b5f2686d7b
v3.5-rc5~4^2^5

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
madbiologist (me-again) wrote :

Any chance of an SRU for Precise? Should be very safe.

Indeed it seems reasonable to SRU for Precise. However, per the SRU process and policy, I'll need to get test confirmation for Precise. Would anyone with the affected hardware be willing to first test Precise and confirm the issue remains. I can then build a test kernel to get confirmation for the patch and submit for SRU. Thanks

Changed in linux (Ubuntu Precise):
status: New → Incomplete
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
Paul Archer (geek65535) wrote :

I have a 17.3" M6600. I just upgraded the BIOS from version A7 to version A9, and the problem (which had been happening 100% of the time) has gone away. This is with Ubuntu 12.04 and latest kernel.

NB: Dell only supplies the BIOS update as a Windows/DOS exe. Use netbootin to install FreeDOS to a USB drive, and copy the .exe to the drive.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.