video switch hot key will return "super key and p" and no response to switch video mode

Bug #1218810 reported by Taihsiang Ho on 2013-08-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
New
Medium
Unassigned
linux (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

CID 201209-11735

For some machines, for example, HP laptop "HP 1000" has a hot key on F4 to perform the shorcut "super + p" to switch video modes.
Use command "sudo showkey -k" to capture the key code of the hot key you will see the key code of "super key" and "p"
This key combination is expected to change the video mode.

platfrom: HP laptop "HP 1000"
image: 12.04.3

Steps to reproduce:
1. open an terminal,
2. plugin an external monitor
3. press the video switch hotkey, for "HP 1000" it is the F4 key

Expected result:
1. Video mode is changed by the hotkey
2. no character is printed on terminal

Actual result
1. Video mode is not changed.
2. a "p" will be printed on the terminal screen

The other information:
1. A similar bug was reported on LP:#539477 before.
2. The hotkey in 13.04 works

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.8.0-29-generic 3.8.0-29.42~precise1 [modified: boot/vmlinuz-3.8.0-29-generic]
ProcVersionSignature: Ubuntu 3.8.0-29.42~precise1-generic 3.8.13.5
Uname: Linux 3.8.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
Date: Fri Aug 30 17:34:56 2013
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-lts-raring
UpgradeStatus: No upgrade log present (probably fresh install)
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.8.0-29-generic.
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1675 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0x63600000 irq 47'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0269,103c1855,00100202 HDA:80862806,80860101,00100000'
   Controls : 27
   Simple ctrls : 10
CurrentDmesg:
 [ 45.884915] ISO 9660 Extensions: RRIP_1991A
 [ 60.442781] audit_printk_skb: 3 callbacks suppressed
 [ 60.442785] type=1400 audit(1378093422.964:31): apparmor="DENIED" operation="open" parent=1 profile="/usr/lib/telepathy/mission-control-5" name="/usr/share/gvfs/remote-volume-monitors/" pid=1849 comm="mission-control" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
 [ 65.385488] r8169 0000:0e:00.0 eth0: link up
 [ 65.385510] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=932733cb-db60-4153-8565-3e3ccb1a6f6d
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
Lsusb:
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 003: ID 05c8:0223 Cheng Uei Precision Industry Co., Ltd (Foxlink)
MachineType: Hewlett-Packard HP 1000 Notebook PC
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 radeondrmfb
 1 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-29-generic root=UUID=770667e1-92a4-4f2e-a434-b9998d55cb30 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-29.42~precise1-generic 3.8.13.5
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-29-generic N/A
 linux-backports-modules-3.8.0-29-generic N/A
 linux-firmware 1.79.6
Tags: precise running-unity
Uname: Linux 3.8.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/25/2012
dmi.bios.vendor: Insyde
dmi.bios.version: B.50
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 1855
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 64.22
dmi.chassis.asset.tag: Classis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrB.50:bd12/25/2012:svnHewlett-Packard:pnHP1000NotebookPC:pvr0698100000005300000630000:rvnHewlett-Packard:rn1855:rvr64.22:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP 1000 Notebook PC
dmi.product.version: 0698100000005300000630000
dmi.sys.vendor: Hewlett-Packard

Taihsiang Ho (taihsiangho) wrote :
Taihsiang Ho (taihsiangho) wrote :

LP: #539477 is similar but very old

affects: linux-lts-raring (Ubuntu) → linux (Ubuntu)
Taihsiang Ho (taihsiangho) wrote :

The following machines has the same bug with 12.04.3:

CID 201208-11466 HP Pavilion Sleekbook 14
CID 201209-11840 Dell XPS 13 (L322X)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1218810

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Po-Hsu Lin (cypressyew) wrote :

Also affects:
201302-12844 Dell Latitude 3330

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: 201208-11466 201209-11840 201302-12844 secondary-keys taipei-lab
tags: added: 201209-11735
Joseph Salisbury (jsalisbury) wrote :

Does this issue go away if you boot back into the 13.04 kernel?

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Taihsiang Ho (taihsiangho) wrote :

Yes it goes away with 13.04

Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
Joseph Salisbury (jsalisbury) wrote :

12.04.3 and 13.04 both use the 3.8 kernel. There may be a regression in the 3.8.13.5 kernel. Do you happen to know the kernel version you were running in 13.04? Can you run uname -a on the 13.04 system?

Also, it would be helpful to test a few kernel to confirm if this is a regression or not. Can you test the following kernels on the 12.04.3 system:

3.8.13.2: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13.2-raring/
3.8.13.3: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13.3-raring/
3.8.13.4: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13.4-raring/
3.8.13.5: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13.5-raring/

You don't have to test every kernel, just up until the first kernel that exhibits the bug.

Po-Hsu Lin (cypressyew) wrote :

Also affects 201302-12843 Dell Latitude 3330

tags: added: 201302-12843
Taihsiang Ho (taihsiangho) wrote :

CID 201208-11466 with 12.04.3 has this bug as well

Kernel
3.8.13.2: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13.2-raring/
3.8.13.7: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13.7-raring/
have this bug.

Taihsiang Ho (taihsiangho) wrote :

13.04 works and "uname -a" showed the kernel is:

3.8.0-19-generic #29-Ubuntu

Taihsiang Ho (taihsiangho) wrote :

comment #29 was tested on CID 201208-11466

Joseph Salisbury (jsalisbury) wrote :

Thanks for the additional info. The 3.8.0-19-generic #29-Ubuntu kernel is fairly old and was based off the upstream 3.8.8 kernel. The latest 13.04 kernel in -updates is 3.8.0-31. You would probably hit this bug if you applied the latest updates on the 13.04 system.

We now know the bug did not exist in upstream 3.8.8, but it does in 3.8.13.2. We need to narrow it down further to know the last good 3.8 version and first bad. Can you test the following kernel:

3.8.9: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.9-raring/
3.8.11: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.11-raring/
3.8.13: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13-raring/

Changed in linux (Ubuntu):
status: Incomplete → In Progress
Taihsiang Ho (taihsiangho) wrote :

CID 201208-11466 with 13.04 does NOT has this bug with
3.8.9: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.9-raring/
3.8.13: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13-raring/

CID 201208-11466 with 12.04.3 has this bug with
3.8.9: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.9-raring/
3.8.13: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13-raring/

CID 201208-11466 with 12.04.3 and 13.04 will hang when booting by
3.8.11: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.11-raring/

Joseph Salisbury (jsalisbury) wrote :

It sounds like the issue may be outside of the kernel due to comment #32. Can you boot any kernel version on 12.04.3 that does not have the bug?

Changed in linux (Ubuntu):
status: In Progress → Incomplete
assignee: Joseph Salisbury (jsalisbury) → nobody
tags: added: kernel-da-key
tags: added: 201206-11167
Taihsiang Ho (taihsiangho) wrote :

for updated 12.04.3 on CID 201305-13636 (Dell Inspiron 5737),
the hotkey (Fn+F1) returns keycode: 125, 25 and 28

The return keycode is different but I file the information here because I think they may be the same issue.

tags: added: taipei-lab201305-13636
removed: taipei-lab
tags: added: 201305-13636 taipei-lab
removed: taipei-lab201305-13636
Ara Pulido (ara) on 2013-11-12
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Po-Hsu Lin (cypressyew) wrote :

Also affects 201306-13836 HP Pavilion 15

tags: added: 201306-13836

Taihsiang Ho, could you please provide the full computer model as noted on the sticker (ex. Compaq Presario 1000 Notebook PC series)?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Taihsiang Ho (taihsiangho) wrote :

Christopher:
This bug report was riased by HP 1000 laptop at first but we found there are systems with similar problem as well, including:
  * HP 1000 laptop
  * HP Pavilion Sleekbook 14
  * HP Pavilion 15 Notebook PC
  * Dell XPS 13 (L322X)
  * Dell Latitude 3330
  * Dell Inspiron 5737

Please let me know if anything unclear

Taihsiang Ho, thank you for your comment. So, just to clarify the computer originally reported with, would this be:
HP Pavilion tx1000 Notebook PC series

or something different on the sticker?

Taihsiang Ho (taihsiangho) wrote :

@ Christopher

I could not confirm the statement "HP Pavilion tx1000 Notebook PC series" as well
because the name "HP 1000" is based on this page:
    http://www.ubuntu.com/certification/hardware/201209-11735/

I think what you need is the details about the components of this computer, and
this information could be accessed
    by clicking the "View all components"
of the page from the link above.

Changed in unity (Ubuntu):
importance: Undecided → Medium
Po-Hsu Lin (cypressyew) on 2014-01-24
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Po-Hsu Lin (cypressyew) wrote :

This bug is also affecting 12.04.4, 201304-13407 Dell Latitude E7240

tags: added: 201304-13407
Taihsiang Ho (taihsiangho) wrote :

Dell Latitude E6540 (CID 201306-13679) on 12.04.4 has this issue.

1. Fn + F8
2. "sudo showkey" returned keycode 125 and 25 were pressed.

tags: added: 201306-13679
Taihsiang Ho (taihsiangho) wrote :

Dell Latitude E7440 (CID 201304-13408) on 12.04.4 has this issue.

1. Fn + F8
2. "sudo showkey" returned keycode 125 and 25 were pressed.

tags: added: 201304-13408
Taihsiang Ho (taihsiangho) wrote :

CID 201305-13636 on 14.04 could not reproduce this bug.

tags: added: verification-needed verification-needed-14.04
Taihsiang Ho (taihsiangho) wrote :

let's verify whether the other systems could not reproduce this bug on 14.04 as well.

Changed in linux (Ubuntu Trusty):
status: New → Fix Released
Changed in unity (Ubuntu Trusty):
status: New → Fix Released
tags: removed: verification-needed-14.04
Taihsiang Ho (taihsiangho) wrote :

CID 201306-13679 on 14.04 could not reproduce this bug.

Mathew Hodson (mathew-hodson) wrote :

The verification-needed tag is added by the SRU team when the upload is approved in the -proposed pocket.

tags: removed: verification-needed
Changed in unity:
importance: Undecided → Medium
Po-Hsu Lin (cypressyew) wrote :

Still exist on 12.04.5

no longer affects: linux (Ubuntu Trusty)
no longer affects: unity (Ubuntu Trusty)
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in unity (Ubuntu Precise):
importance: Undecided → Medium
Rodrigo (rodhos-hp) on 2015-11-16
tags: added: multimonitor
tags: removed: multimonitor
Po-Hsu Lin (cypressyew) wrote :

Precise EOL

Changed in linux (Ubuntu Precise):
status: New → Won't Fix
Changed in unity (Ubuntu Precise):
status: New → Won't Fix
Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Changed in unity (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers