[Lenovo-T430s]: Internal Mic does not work.

Bug #1038188 reported by Jeff Marcom on 2012-08-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Canonical Hardware Enablement
Nominated for Quantal by Jeff Marcom
Nominated for Raring by Jeff Marcom
Precise
Medium
Unassigned

Bug Description

[Lenovo-T430s]: Internal Mic does not work.

201202-10635

kernel: Linux 201202-10635 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Problem:
Internal Mic is detected and input meter changes but not from outside noise.
If you open sound recorder the recorded track is just static. Changing the input volume or pressing the mute microphone button does not do anything.

I've adjusted all the mic volumes in alsamixer to max, and that did not fix the issue.

00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)

sound card info:

Welcome to PulseAudio! Use "help" for usage information.
>>> 1 card(s) available.
    index: 0
 name: <alsa_card.pci-0000_00_1b.0>
 driver: <module-alsa-card.c>
 owner module: 4
 properties:
  alsa.card = "0"
  alsa.card_name = "HDA Intel PCH"
  alsa.long_card_name = "HDA Intel PCH at 0xb3530000 irq 46"
  alsa.driver_name = "snd_hda_intel"
  device.bus_path = "pci-0000:00:1b.0"
  sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
  device.bus = "pci"
  device.vendor.id = "8086"
  device.vendor.name = "Intel Corporation"
  device.product.name = "Panther Point High Definition Audio Controller"
  device.form_factor = "internal"
  device.string = "0"
  device.description = "Built-in Audio"
  module-udev-detect.discovered = "1"
  device.icon_name = "audio-card-pci"
 profiles:
  output:analog-stereo: Analog Stereo Output (priority 6000)
  output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060)
  output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5400)
  output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5460)
  output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 300)
  output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) Output + Analog Stereo Input (priority 360)
  output:hdmi-stereo-extra1: Digital Stereo (HDMI) Output (priority 5200)
  output:hdmi-stereo-extra1+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5260)
  output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI) Output (priority 100)
  output:hdmi-surround-extra1+input:analog-stereo: Digital Surround 5.1 (HDMI) Output + Analog Stereo Input (priority 160)
  output:hdmi-stereo-extra2: Digital Stereo (HDMI) Output (priority 5200)
  output:hdmi-stereo-extra2+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5260)
  output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI) Output (priority 100)
  output:hdmi-surround-extra2+input:analog-stereo: Digital Surround 5.1 (HDMI) Output + Analog Stereo Input (priority 160)
  input:analog-stereo: Analog Stereo Input (priority 60)
  off: Off (priority 0)
 active profile: <output:analog-stereo+input:analog-stereo>
 sinks:
  alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Built-in Audio Analog Stereo
 sources:
  alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
  alsa_input.pci-0000_00_1b.0.analog-stereo/#1: Built-in Audio Analog Stereo
 ports:
  analog-output-speaker: Speakers (priority 10000, available: unknown)
   properties:

  analog-output-headphones: Headphones (priority 9000, available: no)
   properties:

  analog-input-microphone-internal: Internal Microphone (priority 8900, available: unknown)
   properties:

  analog-input-microphone: Microphone (priority 8700, available: no)
   properties:

  hdmi-output-0: HDMI / DisplayPort (priority 5900, available: no)
   properties:

  hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, available: no)
   properties:

  hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, available: no)
   properties:

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-23-generic 3.2.0-23.36
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1660 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xb3530000 irq 46'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0269,17aa21fb,00100203 HDA:80862806,80860101,00100000'
   Controls : 36
   Simple ctrls : 13
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Fri Aug 17 13:25:39 2012
HibernationDevice: RESUME=UUID=f5c0be8d-26f4-4dec-83cc-25f05df105b8
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: LENOVO 814Q18G
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=15352ee3-bd29-46dc-ac61-afb3864aff9c ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-23-generic N/A
 linux-backports-modules-3.2.0-23-generic N/A
 linux-firmware 1.79
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/27/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G7ET25WW (1.07 )
dmi.board.asset.tag: Not Available
dmi.board.name: 814Q18G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG7ET25WW(1.07):bd04/27/2012:svnLENOVO:pn814Q18G:pvrThinkPadT430s:rvnLENOVO:rn814Q18G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 814Q18G
dmi.product.version: ThinkPad T430s
dmi.sys.vendor: LENOVO
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1660 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xb3530000 irq 46'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0269,17aa21fb,00100203 HDA:80862806,80860101,00100000'
   Controls : 36
   Simple ctrls : 13
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=f5c0be8d-26f4-4dec-83cc-25f05df105b8
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: LENOVO 814Q18G
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=15352ee3-bd29-46dc-ac61-afb3864aff9c ro quiet splash initcall_debug vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-23-generic N/A
 linux-backports-modules-3.2.0-23-generic N/A
 linux-firmware 1.79
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: mei
Tags: precise staging precise staging
Uname: Linux 3.2.0-23-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 04/27/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G7ET25WW (1.07 )
dmi.board.asset.tag: Not Available
dmi.board.name: 814Q18G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG7ET25WW(1.07):bd04/27/2012:svnLENOVO:pn814Q18G:pvrThinkPadT430s:rvnLENOVO:rn814Q18G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 814Q18G
dmi.product.version: ThinkPad T430s
dmi.sys.vendor: LENOVO

Jeff Marcom (jeffmarcom) wrote :
tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

tags: added: blocks-hwcert
Brad Figg (brad-figg) on 2012-08-17
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Do you know if this issue happened in a previous version of Ubuntu, or is this a new issue?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.6 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc2-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu Precise):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu Precise) because there has been no activity for 60 days.]

Changed in linux (Ubuntu Precise):
status: Incomplete → Expired
Jeff Marcom (jeffmarcom) wrote :

Problem still exists in latest kernel rev 3.8.0999

tags: added: kernel-bug-exists-upstream quantal raring
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Expired → New
Changed in linux (Ubuntu Precise):
status: Expired → New
Changed in linux (Ubuntu):
assignee: nobody → Canonical Hardware Enablement Team (canonical-hwe-team)

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Precise):
status: New → Confirmed

Jeff Marcom, as per http://download.lenovo.com/express/ddfm.html an update is available for your BIOS (2.55). If you update to this, does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Thank you for your understanding.

tags: added: bios-outdated-2.55 regression-potential
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.