Ubuntu

Libre office default style settings are poor.

Reported by Jussi Schultink on 2012-03-18
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Invalid
Undecided
Unassigned
One Hundred Papercuts
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
The Ubuntu Templates Curators
Precise
Undecided
The Ubuntu Templates Curators

Bug Description

Libreoffice has very poor default style settings, such as headings, colours, font selections etc. We need to get these fixed to make it a better, easier to work with application.

Part of the Ubuntu offering is about excellent defaults, so this really needs doing.

I think there are 3 things that need particular attention:

Default heading styles - the style of headings is particularly poor, with strange size, font and style choices
Default font - I haven't checked precise, but this of course needs to be the Ubuntu font
Default colours for drawing objects: that light blue is hideous, we need to choose something more modern, more professional, more Ubuntu.

I am sure there are more to be done, but perhaps people can report separate bugs for them or add in the comments.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libreoffice 1:3.4.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-16.29-generic 3.0.20
Uname: Linux 3.0.0-16-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Sun Mar 18 09:54:08 2012
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: Upgraded to oneiric on 2011-10-12 (157 days ago)

Jussi Schultink (jussi01) wrote :
Changed in df-libreoffice:
status: New → Incomplete

Jussi Schultink, thank you for your suggestion. However, the changes you are requesting aren't really a bug and require more discussion, which should be done on an appropriate mailing list or forum. http://www.ubuntu.com/support/community/mailinglists might be a good start for determining which mailing list to use.

Changed in libreoffice (Ubuntu):
status: New → Invalid
Changed in df-libreoffice:
status: Incomplete → Invalid

Please propose this upstream on the ux-advise list at http://nabble.documentfoundation.org/UX-Advise-f3619688.html so that an EasyHack http://wiki.documentfoundation.org/Development/Easy_Hacks can be created from it.

Jussi Schultink (jussi01) wrote :

Hi Björn and Christopher,

With all due respect, I would like to ask you to re-open this bug. The reasoning behind this request is that this is not something we want to send upstream - I don't think they would want Ubuntu font as default, nor various oranges and purples in the default colour palate. I guess the bug titling wasn't exactly ideal, it perhaps should have mentioned that the styles should be more ubuntu styled.

Thoughts?

Changed in libreoffice (Ubuntu):
status: Invalid → Opinion
Alan Bell (alanbell) on 2012-03-18
Changed in libreoffice (Ubuntu):
assignee: nobody → The Ubuntu Templates Curators (ubuntutemplates)
status: Opinion → In Progress

see also related bug 940405

I dont know if we even want Ubuntu font as default in Ubuntu. Remember that ODF files do not include the fonts, so opening the file on a system where they are not installed (e.g. Windows) fill cause fallbacks and thus a different layout, which most of the users perceive as broken and will blame on Ubuntu for it.

So, if one goes with Ubuntu as default, IMHO one has to make sure it will be included in upstream LibreOffice releases for Widows and OS X at least. And even then people will complain about the regression when opening the file with Microsoft Office.

Timothy Arceri (t-fridey) wrote :

I agree Unbuntu font as default is a very bad idea

Mozaic (mozaic) wrote :

I check what fonts is common between Ubuntu and Windows if the user use LibreOffice
-Liberation
-Deja Vu
-Open Symbol
Another could be add: Linux Libertine. LibreOffice add this one since 3.3 (see https://www.libreoffice.org/download/3-3-new-features-and-fixes/ http://wiki.documentfoundation.org/ReleaseNotes/3.5#Writer) But Ubuntu not, i create a bug for that https://bugs.launchpad.net/ubuntu/+source/fonts-linuxlibertine/+bug/969123

I don't know what font are in OOo but it should change with the Apache OpenOffice 3.4 (coming soon). AOo's licence is an Apache license and somme fonts could be deleted.

For font Ubuntu, it's could propose for LibreOffice to add them in their program ? Or the licence of font Ubuntu don't allow by the GPL ??

Hello Jussi, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libreoffice (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Metabug -> verified.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package libreoffice - 1:3.5.3-0ubuntu1

---------------
libreoffice (1:3.5.3-0ubuntu1) precise-proposed; urgency=low

  * bump version to final, use debian tarballs

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa2) precise; urgency=low

  * reduce l10n set for ppa builds

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa1) precise; urgency=low

  * cherry-pick 496346c9e692b7ba8ec0aa78c78cac7b71d830a5 from
    debian (LP: #986205)
    - guard libdbalo.so mv with feq PACKAGE_BASE=y...
  * upstream bugfix release 3.5.3:
    - fix colorspace conversion for greyscale bitmaps fdo#34324 [Michael Meeks]
    - cache calls to mdds:mixed_type_matrix::size, related fdo#47299 [Markus Mohrhard]
    - clrContourCache for SwAnchoredDrawObjects fdo#45376 [Andreas Schierl]
    - copy column privileges into table privileges fdo#47937 [Lionel Elie Mamane]
    - cppcanvas: processEMFPlus: fix valgrind warning: fdo#42252 [Michael Stahl]
    - disable cairo canvas on Windows fdo#46532, fdo#46901, fdo#45584 [Michael Meeks]
    - do not increase height of checkboxes fdo#47963 [David Tardon]
    - do not play sound in presenter console fdo#33914 [David Tardon]
    - docx, no mso-fit-shape-to-text means the textbox size is fixed bnc#751573 [Cédric Bosdonnat]
    - export all style information to xls/xlsx, fdo#46738 [Markus Mohrhard]
    - fdo43752: PPTX import fix affected odp imports. bnc#719989, bnc#719997 [Muthu Subramanian]
    - find install location during help pack install fdo#48411 [Andras Timar]
    - fix - edge-case trans gradients came out empty fdo#33591 [Thorsten Behrens]
    - fix - use older ODF encryption by default fdo#47484 [Thorsten Behrens]
    - fix RTF import of \page in inner groups fdo#48104 [Miklos Vajna]
    - fix RTF import of all capitals char prop fdo#46955 [Miklos Vajna]
    - fix RTF import of character encoding in footnotes fdo#45182 [Miklos Vajna]
    - fix RTF import of custom fonts in substreams fdo#45394 [Miklos Vajna]
    - fix RTF import of mixed super/nonsuper text fdo#47326 [Miklos Vajna]
    - fix RTF import of multi-paragraph exact height textboxes fdo#47036 [Miklos Vajna]
    - fix RTF import of shapes inside text frames at the start of the doc fdo#47036 [Miklos Vajna]
    - fix RTF import of tables with empty first row fdo#45394 [Miklos Vajna]
    - fix RTL menu rendering on Windows fdo#42537 [Ivan Timofeev]
    - fix border printing: fdo#38635 [Michael Stahl]
    - fix crash on RTF import of shapes inside tables fdo#47802 [Miklos Vajna]
    - fix the fix so it doesn't crash lp#905355, fdo#43895 [Michael Stahl]
    - fix vcl alpha blending bnc#714787 [Thorsten Behrens]
    - fix vertical align when switching mode in multibar fdo#44140 [Noel Power]
    - fixed pdf export (of images). bnc#717947 [Muthu Subramanian]
    - handle various busted rtf docs without hanging fdo#48640 [Caolán McNamara]
    - improved label/BC wizard - set paper size fdo#44516 [Winfried Donkers]
    - increase nCol before next iteratation to prevent loop, fdo#46220 [Markus Mohrhard]
    - macros: Macro to set filter in Calc does not work with .StringValue fdo#46983 [Takeshi Abe]
    - make "Replace All" work with REs fdo#44861 [David Tardon]
    - ...

Read more...

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released
Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released
Chris Wilson (notgary) on 2012-06-12
Changed in hundredpapercuts:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers