failed to upgrade from oneiric to precise: /usr/lib/libreoffice/program/unopkg.bin: error while loading shared libraries: libicule.so.48: cannot open shared object file: No such file or directory

Bug #917153 reported by Jean-Baptiste Lallement
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
High
Björn Michaelsen
Precise
High
Björn Michaelsen

Bug Description

Automated upgrade testing Oneiric to Precise AMD64/i386
https://jenkins.qa.ubuntu.com/view/Precise%20Upgrade%20Testing%20Dashboard/job/precise-upgrade-amd64/PROFILE=universe-amd64,label=wazn-upgrade/

Upgrade fails with
Processing triggers for libreoffice-common ...
/usr/lib/libreoffice/program/unopkg.bin: error while loading shared libraries: libicule.so.48: cannot open shared object file: No such file or directory
dpkg: error processing libreoffice-common (--unpack):
 subprocess installed post-installation script returned error exit status 127

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
ApportVersion: 1.90-0ubuntu2
Architecture: amd64
Date: Mon Jan 16 14:24:14 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Changed in libreoffice (Ubuntu Precise):
importance: Undecided → High
tags: added: dist-upgrade oneiric2precise qa-daily-testing rls-mgr-p-tracking
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Changed in libreoffice (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
description: updated
Martin Pitt (pitti)
Changed in libreoffice (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Björn Michaelsen (bjoern-michaelsen)
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

Seems like libreoffice-common (in whose postinst we are) misses a dep on libreoffice-core, which contains unopkg.bin and has a good dep on icu itself.

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

Oh, fun: libreoffice-common is a dep of libreoffice-core and thus cant depend on -core without introducing a circular dep. Possible solution: split out unopkg out of -core and depend on in from both -common and -core.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

I'm not sure splitting unopkg out into a separate package would actually help, given that it would need to have the libraries it depends on also included, which is some 13 libs from libreoffice-core.

$ ldd /usr/lib/libreoffice/program/unopkg.bin | awk '/=>/ { print $3 }'| xargs -n1 readlink -f | sort -u | xargs dpkg -S | grep -c libreoffice-core
18
$

Why does this trigger belong to libreoffice-common in the first place? Wouldn't it be better to have the postinst trigger in the libreoffice-core package?

Note that regardless of whether the package is split or the trigger is moved, precise libreoffice-core probably needs to declare a Breaks: on the old version of libreoffice-common, since libreoffice-common hasn't yet been touched as part of this upgrade when this breakage happened.

Changed in libreoffice (Ubuntu Precise):
status: Confirmed → Triaged
Revision history for this message
Martin Pitt (pitti) wrote :

The current oneiric->precise auto dist-upgrade has a similar crash, just not for libicule:

Processing triggers for libreoffice-common ...
/usr/lib/libreoffice/program/unopkg.bin: error while loading shared libraries: libjvmaccessgcc3.so.3: cannot open shared object file: No such file or directory

I guess it's the very same reason, but for the records.

tags: added: rls-p-tracking
removed: rls-mgr-p-tracking
Changed in libreoffice (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package libreoffice - 1:3.5.0-1ubuntu1

---------------
libreoffice (1:3.5.0-1ubuntu1) precise; urgency=low

  * Ubuntufy splash progress
  * merge from debian-experimental-3.5

libreoffice (1:3.5.0-2) UNRELEASED; urgency=low

  [ Rene Engelhard ]
  * debian/patches/armhf-bridges*.diff: add armhf bridges fixes from
    Jani Monoses (LP: #900636)
  * debian/patches/revert-468fe685e3c58c84bce6d9a48b931dcc21682679.diff:
    remove, obsolete
  * debian/patches/icu-arm.diff: fix internal icu build on arm.

  * debian/rules:
    - remove obsolete (and buggy) conditional icu-on-arm-fails breaking
      the build

  [ Bjoern Michaelsen ]
  * debian/libreoffice-common.postrm.in: remove mismerged superfluous fi

libreoffice (1:3.5.0-1ubuntu1~ppa2) precise; urgency=low

  * remove failing smoketest cleanup code for now

libreoffice (1:3.5.0-1ubuntu1~ppa1) precise; urgency=low

  * reenable EVO2 and MEDIAWIKI extensions (reduces delta to debian)
  * move unopkg wrapper from -common to -core to allow extension
    registration
  * do extension registration from -common to -core because we actually
    have the binaries (unopkg.bin etc.) to do it there (LP: #917153)
  * cherry-picked from debian-experimental-3.5:
    debian/libreoffice-common.postrm.in: remove mismerged superfluous fi
  * use source tarballs from debian

libreoffice (1:3.5.0-1) experimental; urgency=low

  * LibreOffice 3.5.0 final release (identical to rc3)

  * debian/patches/no-rcX-in-final.diff: don't show rc3, it's not a rc
    amymore...
  * debian/patches/patches/make-gengal-work-again.diff: register gengal.bin
    executable to get proper rpath and remove gengalrc
  * debian/patches/odk-fix-rdb-paths.diff: backport fix to fix rdb path
    in settings/std.mk in the SDK

  * debian/rules:
    - install found .gdb-py files into respective -dbg packages
    - add additional libpoppler-private-dev build-dep for new popplers
  * debian/control.in, debian/libreofice-common.p*:
    apply patch from Colin Watson to use Pre-Depends rather than
    'dpkg-maintscript-helper supports' guards (closes: #659867)
  * debian/watch: point to download.documentfoundation.org/libreoffice/src
    instead of dev-builds

libreoffice (1:3.5.0~rc3-1) experimental; urgency=low

  * new upstream release candidate

  * debian/patches/SwTblBoxFormula-destructor.diff: work around link error
    on armel by specifying explicit SwTblBoxFormula destructor, thanks
    Michael Meeks
  * debian/patches/ia64-oox-size.diff: build oox on ia64 with -Os
    as otherwise it gets too big to link
  * debian/patches/mediwiki-oor-replace.diff: replace oor:fuse by oor:replace
    for -wiki-publishers config (hopefully closes: #616011)

  * debian/rules:
    - give gb_FULLDEPS= to actual make check call, not debian/rules
      check
    - simplify -dbg/--enable-symbols conditionals
    - build with default boost again but add build-dep on g++-4.6 (>= 4.6.2-12)

libreoffice (1:3.5.0~rc2-2) experimental; urgency=low

  * debian/rules:
    - fix another merge error to really fix patch rule in check
    - enable ca-XV, put into -{l10n,help}-ca

libreoffice (1:3.5.0~rc2-1) experimental; urgency=low

  * new up...

Read more...

Changed in libreoffice (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers