H264 MOV files from Canon DSLR resolution reported as 1920x1088

Bug #937561 reported by Jason Gerard DeRose on 2012-02-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libav (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

I'm not sure exactly when this happened, but sometime since February 10 or so, GStreamer is reporting these 1920x1080 videos as being 1920x1088. This might be an libavcodecs but, not sure yet.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gstreamer0.10-ffmpeg 0.10.13-1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
Date: Tue Feb 21 01:05:01 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120122)
SourcePackage: gstreamer0.10-ffmpeg
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jason Gerard DeRose (jderose) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer0.10-ffmpeg (Ubuntu):
status: New → Confirmed
Jason Gerard DeRose (jderose) wrote :

Måns Rullgård confirmed that this is a bug in libav, and he proposed an upstream fix for this. I'll track down the upstream bug report, if there is one...

affects: gstreamer0.10-ffmpeg (Ubuntu) → libav (Ubuntu)
Reinhard Tartler (siretart) wrote :

I've backported that commit to the upstream release branches for 0.8, 0.7 and 0.6. It will be included on the next upstream update

Changed in libav (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Committed
Jason Gerard DeRose (jderose) wrote :

Reinhard,

Thanks! But FYI, this regression is only in 0.8, so you might be a bit leery of side-effects that could be caused by back-porting this to 0.7 and 0.6.

Also, this bug here is just tracking the status in the Ubuntu package, so I'm changing the status back to Triaged as this hasn't yet been fixed in the Ubuntu Precise package.

Cheer,
Jason

Changed in libav (Ubuntu):
status: Fix Committed → In Progress
Jason Gerard DeRose (jderose) wrote :

Here's a debdiff that adds Måns Rullgård's patch as 05-H264-AVCodecContext-cropping.patch

The attachment "libav_0.8.3-0ubuntu0.12.04.1_to_libav_0.8.3-0ubuntu0.12.04.2.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Steve Langasek (vorlon) on 2012-07-30
Changed in libav (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libav - 4:0.8.3-0ubuntu3

---------------
libav (4:0.8.3-0ubuntu3) quantal; urgency=low

  * debian/patches/05-H264-AVCodecContext-cropping.patch: Added patch from
    Måns Rullgård to fix H264 video size from Canon DSLR cameras (LP: #937561)
 -- Jason Gerard DeRose <email address hidden> Mon, 30 Jul 2012 14:55:29 -0600

Changed in libav (Ubuntu Quantal):
status: In Progress → Fix Released
Steve Langasek (vorlon) wrote :

18:50 < jderose> slangasek: so that libav fix was just pushed to quantal-proposed so far, right? could you back this
                 change out, cancel it for now? there is more digging i need to do
18:50 < jderose> in working on a test case, i just discovered that this bug doesn't occur when i remove
                 gstreamer0.10-plugins-bad... only when it's installed. so although there is an issue in libav, there
                 is something more subtle going on from gstreamer, so i'd like to dig deeper into this before this hits
                 quantal

Rejecting the package from precise-proposed.

Reinhard Tartler (siretart) wrote :

Sorry for not jumping in earlier, but the debian package revision 6:0.8.3-2 and later include the patch for this.

For quantal, I think it would be most appropriate to do would be to merge with the latest debian package. I've not done so yet, because I'm currently working on a 6:0.8.3-6, targeted for wheezy, which I'd like to use as base for merging as soon as its ready (hopefully still this week)

Jason Gerard DeRose (jderose) wrote :

Reinhard,

Thanks! I'm all about getting the Debian package merged or synced, so please let me know what I can do to help. For Quantal, does a sync make more sense than a merge?

I have a test case for this here (uses GStreamer, includes a sample Canon MOV file):

http://bazaar.launchpad.net/~jderose/+junk/testcase-937561/view/head:/testcase.py

But in writing that test case, I realized that there are deeper issues going on with this, at least from the GStreamer side of things. Although there was certainly the bug in libav that Måns Rullgård found, my test case only fails when gstreamer0.10-plugins-bad is installed. Remove -bad, and the correct height is reported.

This might suggest that an element in -bad has the wrong priority, but it also suggests that gstreamer0.10-ffmpeg isn't actually using the broken code path in libav in the first place. I'll keep digging into this.

Jason Gerard DeRose (jderose) wrote :

One more thing: did you see this other patch that Måns said is needed to fix this?

http://git.libav.org/?p=libav.git;a=commit;h=8aa93e900449c88c3169ff5636fed03f41779cac

Just is case that hasn't been included in the latest Debian package. Cheers!

On Do, Aug 02, 2012 at 02:17:27 (CEST), Jason Gerard DeRose wrote:

> Thanks! I'm all about getting the Debian package merged or synced, so
> please let me know what I can do to help. For Quantal, does a sync make
> more sense than a merge?

Unfortunately, we need to merge. In Debian, the libav-extra package has
been merged into a common 'libav' package. In Ubuntu, we unfortunately
cannot do that because of the extra build dependencies that libav-extra
requires.

A merge of libav therefore requires two uploads in ubuntu, one for libav
and one for libav-extra.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

James Page (james-page) wrote :

Un-subscribing ubuntu-sponsors for the time being; please re-subscribe when you need something sponsored into Quantal.

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers