Authenticated printing on remote servers broken

Bug #1064140 reported by Matthias Schiffer on 2012-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Low
Unassigned
Precise
High
Unassigned

Bug Description

Currently, Gtk2 applications (e.g. Firefox) can't print on printers that require authentication if they don't connect to the IPP server via a local unix socket, but over TCP. (the authentication dialog pops up once, but the client only sends an empty password to the server after that).

This was fixed in the upstream Gtk3 branch some time ago (commit f807f7834fea0db7b0b68cd1a0dfa3dbe0985ec2), but still hasn't been applied to the Gtk2 branch. The upstream bug report is https://bugzilla.gnome.org/show_bug.cgi?id=664640

I have confirmed that the Gtk3 patch also fixes the problem for Gtk2; it would be nice to have the fix included in the Precise Gtk2 packages as I need this feature to work. It probably also affects other Ubuntu releases.

System:

Description: Ubuntu 12.04.1 LTS
Release: 12.04

libgtk2.0-0 2.24.10-0ubuntu6

Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue is fixed in the raring version, we should probably backport the commit to precise as well:
https://git.gnome.org/browse/gtk+/commit/?h=gtk-2-24&id=85825ebaf2c16bb48602d5d3ced5e9ecd6605852

affects: gtk+2.0 (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → Low
status: New → Fix Released
affects: ubuntu → gtk+2.0 (Ubuntu)
Revision history for this message
Matthias Schiffer (neoraider) wrote :

A backport would be highly appreciated. We'll stick to Precise till the next LTS, and compiling a patched Gtk2 ourselves on each update (which luckily hasn't happened for some time) is a hassle we could rather well live without ;)

Revision history for this message
Matthias Schiffer (neoraider) wrote :

So... can I expect that the fix will ever be ported to Precise? I'd also accept a no, but getting an answer at all would be nice.

Revision history for this message
Sebastien Bacher (seb128) wrote :

> So... can I expect that the fix will ever be ported to Precise?

yes, as stated in comment #1 on this bug...

The issue is mostly a manpower one, if you want to do the backport/attach a debdiff to the bug/file the stable update informations (https://wiki.ubuntu.com/StableReleaseUpdates: impact/test case/regression potential) that would help, I can review/sponsor the update

Changed in gtk+2.0 (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers