totem cannot play quicktime file after upgrade to oneiric

Bug #856988 reported by Rocko on 2011-09-23
210
This bug affects 51 people
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Totem can't play quicktime files on a PC upgraded from natty to oneiric. On a VM with oneiric installed from scratch, however, totem can play the same files, so it seems to be a configuration error. Both the PC and VM run 64 bit oneiric, have the same kernel version, and both have ia32 libs installed

A sample file that fails to play can be found in comment 5 of bug #851481.

On the PC that fails to play the files, totem prompts to install the plugin for 'Quicktime demuxer' but then gnome-codec-install can't find a suitable plugin.

On the VM that *can* play the files, totem prompted to install the same plugin and gnome-codec-install found and installed gstreamer0.10-ffmpeg and gstreamer0.10-plugins-bad. (These are both already installed on the PC that cannot play the files.)

The output from gst-launch-0.10 uridecodebin=file:///<file in question> is:

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
WARNING: from element /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0: No decoder available for type 'video/quicktime, variant=(string)iso'.
Additional debug info:
gsturidecodebin.c(867): unknown_type_cb (): /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0
ERROR: from element /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20: Your GStreamer installation is missing a plug-in.
Additional debug info:
gstdecodebin2.c(3233): gst_decode_bin_expose (): /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20:
no suitable plugins found
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
Freeing pipeline ...

I have tried reinstalling all the installed gstreamer packages as well totem, but to no avail.

How does gstreamer match plugins against the video type, eg 'video/quicktime, variant=(string)iso'?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gstreamer-tools 0.10.35-1
Uname: Linux 3.1.0-rc7-git-20110923.0546 x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Fri Sep 23 10:13:28 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
SourcePackage: gstreamer0.10
UpgradeStatus: Upgraded to oneiric on 2011-09-22 (0 days ago)

Revision history for this message
Rocko (rockorequin) wrote :
Revision history for this message
Rocko (rockorequin) wrote :

It looks like it is a strange configuration issue. I tried the following commands, where /natty points to my natty installation:

1) I tried my Natty plugins:

GST_PLUGIN_PATH=/natty/usr/lib/gstreamer-0.10 totem guardian-intro.mp4

and totem played the file successfully.

2) I tried the Oneiric plugins:

GST_PLUGIN_PATH=/usr/lib/gstreamer-0.10 totem guardian-intro.mp4

but totem still couldn't find the plugin.

3) I tried the Oneiric 32-bit plugins:

GST_PLUGIN_PATH=/usr/lib32/gstreamer-0.10 totem guardian-intro.mp4

and gst-plugin-scanner complained that everything was a 32-bit library, but totem DID play the file.

And after 3), totem plays the file without setting GST_PLUGIN_PATH. I'm not sure what changed, though. I guess it was a problem caused by upgrading from Natty to the new multi-architecture.

Rocko (rockorequin) on 2011-09-24
tags: added: multi-arch multiarch
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
Revision history for this message
aortega (ortegaalfredo) wrote :

I fixed it on oneiric with:
$ rm .gstreamer-0.10;gst-inspect

Revision history for this message
Ilya Barygin (randomaction) wrote :

Confirming the workaround: just do
rm -r ~/.gstreamer-0.10

Revision history for this message
deboon (debiboon) wrote :

Worls well to me:
rm -r ~/.gstreamer-0.10

Revision history for this message
klasiphyd (klasiphyd) wrote :

While 'rm -r ~/.gstreamer-0.10' allows me to now view mp4 video playback, right clicking a file, selecting properties, and selecting the 'Audio/Video' tab displays no audio/video information about the file at all.

Rolf Leggewie (r0lf) on 2011-10-19
tags: removed: multi-arch
Steve Langasek (vorlon) on 2011-10-19
tags: removed: multiarch
Revision history for this message
Sebastien Bacher (seb128) wrote :

Could somebody backup their buggy .gstreamer-0.10 and add it to the bug?

Revision history for this message
Sebastien Bacher (seb128) wrote :

Rocko, what do you call natty and oneiric plugins? what do you have in the natty directory? Could you diff the directory between the buggy and working version?

Revision history for this message
Rocko (rockorequin) wrote :

The Natty plugins are the files in the /usr/lib/gstreamer-0.10 directory in a Natty installation, while the Oneiric plugins are the files in the /usr/lib/gstreamer-0.10 directory. A diff isn't much help, because they are binaries of different versions of gstreamer.

I unfortunately also don't have the Natty version of ~/.gstreamer-0.10, because I deleted it and it got regenerated. I imagine it would be possible to make one easily enough from a live installation disk, though.

Changed in gstreamer0.10 (Ubuntu):
importance: Undecided → Low
Revision history for this message
Stefan Löffler (st.loeffler) wrote :

The workaround worked for me - thanks.

Old (i.e., natty) .gstreamer-0.10 directory is attached.

FWIW:
$ uname -a
Linux Herkules 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
Marcel Kolaja (marcel.kolaja) wrote :

Removing ~/.gstreamer-0.10/ works around the issue. The ~/.gstreamer-0.10/ directory that prevents totem from playing Quicktime movies (i.e. before deletion) attached.

Revision history for this message
dc (darkcharl) wrote :

Another confirm that the workaround resolved the issue, the affected application was Banshee in my case.

Revision history for this message
Steve Magoun (smagoun) wrote :

One more confirmation...deleting the registry in ~/.gstreamer0.10 makes playback work again. Attached is a copy of my .gstreamer0.10 directory with 2 registries:
1) The original one that prevents quicktime movies from working
2) A rebuilt registry that allows quicktime movies to work

I can reproduce the failure to play quicktime moves at will by replacing the new registry with the old (busted) one.

Revision history for this message
Lukáš Chmela (lukaschmela) wrote :

Thanks, removing the ~/.gstreamer-0.10 directory did solve the issue for me too.

Revision history for this message
Teo (teo1978) wrote :

removing the ~/.gstreamer-0.10 directory did solve the issue for me too, but thumbnails preview and right-click/Properties still don't work in Nautilus. Is there a workaround for that too?

Revision history for this message
Teo (teo1978) wrote :

Imprtance "Low" is ridiculous. While there is an easy workaround, any user experiencing the issue is very unlikely to find it. And not being able to play mov files in itself is a very major issue.

Revision history for this message
Marcel Stimberg (marcelstimberg) wrote :

@matteo: Thumbnails and nautilus properties should work after a nautilus restart (call 'nautilus -q' or just log out and back in).

Changed in gstreamer0.10 (Ubuntu Precise):
importance: Low → High
tags: added: precise rls-mgr-p-tracking
Changed in gstreamer0.10 (Ubuntu Precise):
assignee: nobody → Ubuntu ARM Team (ubuntu-arm)
Revision history for this message
Tobin Davis (gruemaster) wrote :

This is not an arm issue. Unassigning the ubuntu-arm team.

Changed in gstreamer0.10 (Ubuntu Precise):
assignee: Ubuntu ARM Team (ubuntu-arm) → nobody
Revision history for this message
Jason Robinson (jaywink) wrote :

This was affecting me as well after an upgrade from Oneiric to Precise.

Did:
rm -rf .gstreamer-0.10/

And now it works.

Revision history for this message
alex (aarw2) wrote :

me too, the bug appeared after upgrade to precise

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers