Ubuntu

shell-recorder does not close file when recording is stopped

Reported by Daniel Swarbrick on 2012-04-06
36
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

According to https://live.gnome.org/GnomeShell/CheatSheet the GS screencast tool can be started and stopped with the key combination Control+Shift+Alt+R. I've found that stopping a recording does not close the file that is being recorded to (visible in the output of `lsof | grep webm`).

If I press Control+Shift+Alt+R again, instead of incrementing a counter and starting a recording to a new file, as the docs state, the recording is appended to the previous file (even if it has since been moved somewhere else). It definitely appears as if the file descriptor is not being closed, and shell-recorder is in fact pausing the the recording, rather than stopping it. See http://developer.gnome.org/shell/unstable/shell-shell-recorder.html

Another thing to note is that when playing back the recorded .webm file, VLC shoes "0:00" as the recording length, eg. it appears unable to determine the length, as if the file is incomplete... or was never closed properly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.4.1-5ubuntu1

---------------
gnome-shell (3.4.1-5ubuntu1) quantal; urgency=low

  * Re-synchronize with Debian. Remaining changes:
    - 09-respect-NoDisplay-semantics-for-app-menu.patch:
      + Disabled, as upstream says it breaks app tracking for NoDisplay apps
        and it's a Debian-specific problem anyway
    - 21_revert_evolution_gsettings.patch: Disabled, we have Evolution 3.4 now
  * Fixes gnome-shell recorder not starting new recording every time screen
    recorder stops and starts (LP: #975360)
  * Dropped Ubuntu's ARM patches because the Debian one works better. For
    instance the screen recorder is much faster on non-ARM platforms now.

gnome-shell (3.4.1-5) unstable; urgency=low

  * Disabling the screen recorder on arm{el,hf} was not sufficient to make it
    build everywhere since the screen grabber is also used for making
    screenshots. Update debian/patches/14_make-GLX-optional.patch instead and
    only use pixel buffers in the screen grabber if we have GL/GLX support.
    This means we can re-enable the screen recorder on arm{el,hf} as it will
    use the slow, cogl-based path there.

gnome-shell (3.4.1-4) unstable; urgency=low

  * debian/patches/14_make-GLX-optional.patch:
    - Add DEP-3 patch header.
    - Remove unconditional pkg-config check for the "gl" module.

gnome-shell (3.4.1-3) unstable; urgency=low

  * Upload to unstable.

gnome-shell (3.4.1-2) experimental; urgency=low

  * debian/patches/22-remove-online-accounts-from-user-menu.patch: Remove
    "Online Accounts" from user menu. It can be easily accessed via
    "System Settings" so there is no need to clutter up the user menu.
  * Tighten Depends on gir1.2-clutter-1.0. Closes: #673929
  * Change Recommends: gnome-themes-standard to Depends. Adwaita is the
    prefererred window manager theme and without a theme installed gnome-shell
    refuses to start. Closes: #590340
  * Bump Depends on gnome-settings-daemon to (>= 3.4.0). There was an
    incompatible change in the Power D-Bus API which caused the power icon to
    no longer update properly. Closes: #674429
  * Don't build the screen recorder on arm{el,hf} as the screen grabber uses
    GL/GLX and on those archs cogl uses GLES.
  * debian/patches/25-close-the-recorder-instead-of-pausing-it.patch: Close
    the screen recorder instead of pausing. Otherwise we continue to write to
    the same output file. Patch cherry-picked from upstream Git.
 -- Jeremy Bicha <email address hidden> Wed, 30 May 2012 22:02:18 -0400

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2012-05-31
Changed in gnome-shell (Ubuntu Precise):
importance: Undecided → Medium
status: New → Triaged
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
Daniel Swarbrick (pressureman) wrote :

I'm not so sure this is fixed. gnome-shell 3.4.1-5ubuntu1 does now create unique files for each recording, but those file are all exactly 300 bytes. The contents appear to be a valid webm header, but obviously contain no actual video data, and cannot be played back by VLC for example.

Jeremy Bicha (jbicha) wrote :

Daniel, I'm also getting 300 byte screencasts. Could you please open a new bug for this new issue, as it might be a problem with Ubuntu's gstreamer or something else? Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers