bluetooth-wizard failed to connect to a keyboard(logitech)

Bug #1035431 reported by Laurent Vivier on 2012-08-10
184
This bug affects 36 people
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
Fix Released
Medium
OEM Priority Project
High
Unassigned
Trusty
Undecided
Unassigned
bluez (Ubuntu)
Undecided
Unassigned
Precise
Medium
Unassigned
Trusty
High
Mathieu Trudel-Lapierre
gnome-bluetooth (Ubuntu)
Undecided
Unassigned
Precise
Medium
Unassigned
Trusty
High
Mathieu Trudel-Lapierre

Bug Description

[Impact]

 * Fixes issues connecting bluetooth devices using SSP (Simple Secure Pairing); which does include many newer bluetooth devices, especially keyboards.

[Test Case]

 * Try to connect a bluetooth keyboard using the wizard; especially one of the following models:

Logitech Bluetooth Keyboard K760
Logitech Bluetooth Keyboard K810
HP Bluetooth Keyboard K4000

[Regression Potential]

 * It must be ensured that keyboards that could already be paired successfully still work properly; specifically, especially for keyboards but for any other devices, that pairing still works despite changes to the SSP code.

[Other Info]

---

When I try to connect my bluetooth keyboard using bluetooth-wizard, it ever fails:

** (bluetooth-wizard:11367): WARNING **: Setting up 'Logitech K760' failed: Authentication Failed

This keyboard works fine with another computer under ubuntu 11.04.
This keyboard works fine with this computer and Windows 7 (arghhh).
This computer ubuntu 12.04 works fine with my bluetooth mouse.

I can attach manually this keyboard to this computer using :

sudo hidd --search

My computer is a Samsung 305U1A
My bluetooth interface is :

Bus 003 Device 002: ID 0a5c:219c Broadcom Corp.

Related branches

Laurent Vivier (laurent-vivier) wrote :

In /var/log/auth.log :

Aug 10 23:28:36 samsung dbus[898]: [system] Rejected send message, 3 matched rules; type="error", sender=":1.250" (uid=1000 pid=17327 comm="bluetooth-wizard ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.3" (uid=0 pid=944 comm="/usr/sbin/bluetoothd ")

Laurent Vivier (laurent-vivier) wrote :

# bluez-simple-agent hci0 00:1F:20:4D:3A:FE
Creating device failed: org.bluez.Error.AuthenticationFailed: Authentication Failed

bluetoothd[903]: src/adapter.c:adapter_create_device() 00:1F:20:4D:3A:FE
bluetoothd[903]: src/device.c:device_create() Creating device /org/bluez/903/hci0/dev_00_1F_20_4D_3A_FE
bluetoothd[903]: src/device.c:btd_device_ref() 0x7f8093527de0: ref=1
bluetoothd[903]: src/device.c:device_set_temporary() temporary 1
bluetoothd[903]: src/device.c:bonding_request_new() Requesting bonding for 00:1F:20:4D:3A:FE
bluetoothd[903]: src/device.c:bonding_request_new() Temporary agent registered for 00:1F:20:4D:3A:FE at :1.117:/test/agent
bluetoothd[903]: plugins/hciops.c:conn_complete() status 0x0b
bluetoothd[903]: src/event.c:btd_event_conn_failed() status 0x0b
bluetoothd[903]: src/device.c:device_cancel_bonding() Canceling bonding request for 00:1F:20:4D:3A:FE
bluetoothd[903]: plugins/hciops.c:hciops_cancel_bonding() hci0
bluetoothd[903]: src/agent.c:agent_release() Releasing agent :1.117, /test/agent
bluetoothd[903]: src/device.c:device_remove() Removing device /org/bluez/903/hci0/dev_00_1F_20_4D_3A_FE
bluetoothd[903]: src/device.c:btd_device_unref() 0x7f8093527de0: ref=0
bluetoothd[903]: src/device.c:device_free() 0x7f8093527de0
bluetoothd[903]: plugins/hciops.c:bonding_complete() status 0x0b
bluetoothd[903]: plugins/hciops.c:conn_complete() status 0x00
bluetoothd[903]: src/adapter.c:adapter_get_device() 00:1F:20:4D:3A:FE
bluetoothd[903]: src/adapter.c:adapter_create_device() 00:1F:20:4D:3A:FE
bluetoothd[903]: src/device.c:device_create() Creating device /org/bluez/903/hci0/dev_00_1F_20_4D_3A_FE
bluetoothd[903]: src/device.c:btd_device_ref() 0x7f8093527de0: ref=1
bluetoothd[903]: src/device.c:device_set_temporary() temporary 1
bluetoothd[903]: plugins/hciops.c:remote_features_information() hci0 status 0
bluetoothd[903]: plugins/hciops.c:link_key_request() hci0 dba 00:1F:20:4D:3A:FE
bluetoothd[903]: plugins/hciops.c:get_auth_info() hci0 dba 00:1F:20:4D:3A:FE
bluetoothd[903]: plugins/hciops.c:link_key_request() kernel auth requirements = 0x04
bluetoothd[903]: plugins/hciops.c:link_key_request() Matching key not found
bluetoothd[903]: plugins/hciops.c:remote_name_information() hci0 status 0
bluetoothd[903]: plugins/hciops.c:link_key_request() hci0 dba 00:1F:20:4D:3A:FE
bluetoothd[903]: plugins/hciops.c:get_auth_info() hci0 dba 00:1F:20:4D:3A:FE
bluetoothd[903]: plugins/hciops.c:link_key_request() kernel auth requirements = 0x04
bluetoothd[903]: plugins/hciops.c:link_key_request() Matching key not found
bluetoothd[903]: plugins/hciops.c:disconn_complete() handle 13 status 0x00
bluetoothd[903]: src/event.c:btd_event_disconn_complete()
bluetoothd[903]: src/adapter.c:adapter_remove_connection()
bluetoothd[903]: src/adapter.c:adapter_remove_connection() Removing temporary device /org/bluez/903/hci0/dev_00_1F_20_4D_3A_FE
bluetoothd[903]: src/device.c:device_remove() Removing device /org/bluez/903/hci0/dev_00_1F_20_4D_3A_FE
bluetoothd[903]: src/device.c:btd_device_unref() 0x7f8093527de0: ref=0
bluetoothd[903]: src/device.c:device_free() 0x7f8093527de0

Laurent Vivier (laurent-vivier) wrote :

Strangely, I was able to connect using :

# bluez-simple-agent hci0 00:1F:20:4D:3A:FE
DisplayPasskey (/org/bluez/903/hci0/dev_00_1F_20_4D_3A_FE, 153704)
Release
New device (/org/bluez/903/hci0/dev_00_1F_20_4D_3A_FE)

there is a line in /var/lib/bluetooth/linkkeys for my device now.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Calcipher (calcipher) wrote :

I know that the 'me too' button servers the same purpose, but I wanted to say that I'm experiencing the same problem. I'm using a Logitech k810 keyboard and Laurent's solution (use bluez-simple-agent to add the device) worked for me. Is there a way to make bluetooth-wizard put out verbose error messages?

John A. Lewis (pointful) wrote :
Download full text (3.4 KiB)

Also having similar problems with a new Logitech K810 under quantal running on a project sputnik laptop. bluez-simple-agent doesn't work for me. I either get authentication errors or timeout errors. Can't get it to connect via bluetooth-manager or bluetooth-wizard either. Switched over to blueman, and I am able to get it to connect by selecting "Proceed without pairing", but that isn't persistent, so I have to that every time I connect right now.

Here is the debug output from bluetoothd when attempting to pair properly via passkey and failing:

start pairing:

bluetoothd[4762]: src/adapter.c:adapter_create_device() 00:1F:20:4D:96:8B
bluetoothd[4762]: src/device.c:device_create() Creating device /org/bluez/4762/hci0/dev_00_1F_20_4D_96_8B
bluetoothd[4762]: src/device.c:btd_device_ref() 0x7ffceb6b2fa0: ref=1
bluetoothd[4762]: src/device.c:device_set_temporary() temporary 1
bluetoothd[4762]: plugins/mgmtops.c:mgmt_create_bonding() hci0 bdaddr 00:1F:20:4D:96:8B io_cap 0x01
bluetoothd[4762]: src/device.c:bonding_request_new() Requesting bonding for 00:1F:20:4D:96:8B
bluetoothd[4762]: src/device.c:bonding_request_new() Temporary agent registered for 00:1F:20:4D:96:8B at :1.125:/
bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() cond 1
bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() Received 39 bytes from management socket
bluetoothd[4762]: plugins/mgmtops.c:mgmt_device_connected() hci0 device 00:1F:20:4D:96:8B connected eir_len 20
bluetoothd[4762]: src/adapter.c:adapter_get_device() 00:1F:20:4D:96:8B

entered passkey:

bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() cond 1
bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() Received 14 bytes from management socket
bluetoothd[4762]: plugins/mgmtops.c:mgmt_auth_failed() hci0 auth failed status 5
bluetoothd[4762]: src/device.c:device_bonding_complete() bonding 0x7ffceb6b2d30 status 0x05
bluetoothd[4762]: src/device.c:device_cancel_bonding() Canceling bonding request for 00:1F:20:4D:96:8B
bluetoothd[4762]: plugins/mgmtops.c:mgmt_cancel_bonding() hci0 bdaddr 00:1F:20:4D:96:8B
bluetoothd[4762]: src/agent.c:agent_release() Releasing agent :1.125, /
bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() cond 1
bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() Received 16 bytes from management socket
bluetoothd[4762]: plugins/mgmtops.c:mgmt_cmd_complete()
bluetoothd[4762]: plugins/mgmtops.c:pair_device_complete() hci0 00:1F:20:4D:96:8B pairing complete status 5
bluetoothd[4762]: src/device.c:device_bonding_complete() bonding (nil) status 0x05
bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() cond 1
bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() Received 9 bytes from management socket
bluetoothd[4762]: hci0: Cancel Pair Device (0x001a) failed: Invalid Parameters (0x0d)
bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() cond 1
bluetoothd[4762]: plugins/mgmtops.c:mgmt_event() Received 13 bytes from management socket
bluetoothd[4762]: plugins/mgmtops.c:mgmt_device_disconnected() hci0 device 00:1F:20:4D:96:8B disconnected
bluetoothd[4762]: src/event.c:btd_event_disconn_complete()
bluetoothd[4762]: src/adapter.c:adapter_remove_connection()
bluetoothd[4762]: src/adapter.c:adapter_remove_connection() Removing temporary...

Read more...

Arne Brix (torpak) wrote :

Hi at the moment i would settle for a detailed workaround description to get my keyboard paired manually (persistently).

Magic Gandalf (magic-gandalf) wrote :

I can also confirm this bug with a Logitech K810 Keyboard on Linux Mint 14 (i.e Ubuntu 12.10 derivative). For the moment I settled the issue by blacklisting bluetooth modules btusb, btnep and rfcomm in /etc/modules.d/blacklist-custom. This entirely disables bluetooth, however keeps the HID stack from the Bluetooth Stick

Bus 002 Device 006: ID 0a5c:4502 Broadcom Corp. Keyboard (Boot Interface Subclass)
Bus 002 Device 007: ID 0a5c:4503 Broadcom Corp. Mouse (Boot Interface Subclass)

alive. I learn't that this is insecure and thus certainly not my favorite way of dealing with this issue. However, I can now use my pricely keyboard without any issues, even in dual-boot mode to Windows.

jake brown (jbb-s) wrote :

Hi there..
I had the same issue as you but I solved it while playing around on LinuxMint (with a logitech K810). The issue is that once you type in "sudo bluez-simple-agent hci0 XX:XX:XX:XX:XX:XX" the computer waits for a passkey, which never arrives, because you don't know what it is. Using the "bluez hcidump" tool (install if required), you can see what the passkey is and type it into the K810 before the connection times out.
Below is copied & pasted from the link you mentioned, plus what I did to get my K810 to work:

In a new terminal type:
"hcitool scan" and copy mac address XX:XX:XX:XX:XX:XX

Now in another terminal type:
"sudo hcidump -at"

You should get something like (followed by a blinking cursor):
HCI sniffer - Bluetooth packet analyzer ver 2.4
device: hci0 snap_len: 1028 filter: 0xffffffffffffffff

Switch back to your original terminal and type:
"sudo bluez-simple-agent hci0 XX:XX:XX:XX:XX:XX"

Now in the hcidump terminal you will see a few things scroll past until you get something that looks like:
2013-02-07 15:35:40.653393 > HCI Event: User Passkey Notification (0x3b) plen 10
    bdaddr XX:XX:XX:XX:XX:XX passkey 66235

Type the 'passkey' in to the keyboard on the K810 and press ENTER
On success you should get "Release" and "New device (/org/bluez/..."

Now set device as trusted:
"sudo bluez-test-device trusted XX:XX:XX:XX:XX:XX yes"

You might have a connection now, but still need to:
"sudo bluez-test-input connect XX:XX:XX:XX:XX:XX"

Now reboot and hope for the best!

John A. Lewis (pointful) wrote :

Yay! Jake's workaround in #9 finally solved it for me ousing the Logitech K810 on Ubuntu 12.10 running on a Dell XPS 13. So much better than manually connecting each time.

I have the same issue with Mac version that just came out last month (Logitech K811)

Jake's workaround #9 worked for me too after a couple tries. Ubuntu 12.04
Bus 002 Device 039: ID 0461:4d75 Primax Electronics, Ltd Rocketfish RF-FLBTAD Bluetooth Adapter

The keyboard was easily paired with another laptop with a partition running stock 12.04 (just the release - no updates) Happy to help debug this :-)

jake brown (jbb-s) wrote :

Glad it worked for you guys! I use the keyboard when I am lying in bed at night using my computer on my TV, and I only run linux on my devices so I am relieved it works (especially seeming it cost me about $150 in Australia for the keyboard and $30 for the Bluetooth adapter).

Does anyone more adept at Linux know why this fails to connect on the GUI; it seems it fails in Ubuntu & Redhat from what I have seen so far (basically gnome-bluetooth).

On a side note, if you want to make the Fn keys work without hitting the Fn button (useful for switching terminal windows etc if you have command line based system or setting up, stops you accidently 'changing devices' while looking for the F1, F2, F3 key), read, download and compile this:

http://www.trial-n-error.de/posts/2012/12/31/logitech-k810-keyboard-configurator/
http://www.trial-n-error.de/static/articles/k810/k810_conf-v0.1.tar.bz2

I had to change line 59 from:
printf("write: %d were written instead of %ld.\n", res, len);

to:
printf("write: %d were written instead of %d.\n", res, len);

to get it to compile properly. Then just set it up to run everytime on bootup and your Fn keys act like normal.

beccon (beccon) wrote :

In 13.04 the problem is still there. I get the following lines in the syslog

Apr 30 13:19:16 wetab bluetoothd[889]: Discovery session 0xb9639b68 with :1.48 activated
Apr 30 13:19:32 wetab bluetoothd[889]: Stopping discovery
Apr 30 13:19:33 wetab bluetoothd[889]: Unknown Management opcode 23 (index 0)
Apr 30 13:19:43 bluetoothd[889]: last message repeated 6 times
Apr 30 13:19:43 wetab bluetoothd[889]: hci0: Cancel Pair Device (0x001a) failed: Invalid Parameters (0x0d)

Maciej (hamsterready) wrote :

On 13.0.4 I installed bluez-compat just as described here: http://askubuntu.com/questions/283611/bluetooth-problem-on-lubuntu-12-04-2-lts and my logitech k810 works now as expected (I did not restart so not sure if connection will be persisted but at least typing using k810 now :)).

Markus Grobelin (grobi-6) wrote :

Couldn't pair my Logitech k810 keyboard & Parrot by Starck speaker aswell with those bluetooth gui tools - it just crashes when it would come up to enter the pairing PIN.

Systems I'm using are on Mint 14 Nadia (htpc) and Ubuntu 12.10 Quantal (laptop).

Jake Brown's comment #9 describes how to workaround this issue!

My notes:

# sniff bluetooth traffic in a terminal
sudo apt-get install bluez-hcidump
sudo hcidump -XYt # ...writes a lot of debug information to stdout

# scan for bluetooth devices
hcitool scan
Scanning ...
 00:1F:20:91:99:CE Logitech K810

# open an other terminal, add the device
sudo bluez-simple-agent hci0 00:1F:20:91:99:CE

# switch back to terminal with hcidump output & look for a row containing the passkey (pin) - here: 919878
[...]
2013-03-15 19:03:23.734363 > HCI Event: IO Capability Response (0x32) plen 9
    bdaddr 00:1F:20:*:*:* capability 0x02 oob 0x00 auth 0x04
    Capability: KeyboardOnly (OOB data not present)
    Authentication: General Bonding (No MITM Protection)
2013-03-15 19:03:24.694362 > HCI Event: User Passkey Notification (0x3b) plen 10
    bdaddr 00:1F:20:*:*:* passkey 919878
[...]

# Type pin with bluetooth keys and hit enter;
# make connection trusted & connect
sudo bluez-test-device trusted 00:1F:20:91:99:CE yes
sudo bluez-test-input connect 00:1F:20:91:99:CE

# for Parrot pin is '0000', to connect use...
sudo bluez-test-audio connect XX:XX:XX:XX:XX:XX

Markus Grobelin (grobi-6) wrote :

in case of error try:

sudo bluez-simple-agent hci0 00:1F:20:91:99:CE repair

...and repeat procedure

Persicus (amin.mahpour) wrote :

It has been almost 10 months since this bug is reported. It is so sad that Ubuntu dev team does not fix device bluetooth connectivity.

Persicus (amin.mahpour) on 2013-07-09
summary: - bluetooh-wizard failed to connect to a keyboard
+ bluetooh-wizard failed to connect to a keyboard(logitech)

This is a mess. In 13.04, the steps in #9 do not work -- after typing the code on the keyboard and hitting return, the bluez-simple-agent process exits with:

Creating device failed: org.bluez.Error.AuthenticationFailed: Authentication Failed

I attempted to run "repair" as suggested in a later post and got this error:

Traceback (most recent call last):
  File "/usr/bin/bluez-simple-agent", line 129, in <module>
    device = adapter.FindDevice(args[1])
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.bluez.Error.DoesNotExist: Does Not Exist

So with a completely up-to-date Ubuntu, you can't use bluetooth keyboards. And this has been known for nearly a year?

Artyom Kazak (artyom-kazak) wrote :

auslander: I am using using a Logitech K810 at this very moment on my completely up-to-date Ubuntu.

Still this bug is quite annoying and I wonder why isn’t it fixed already.

auslander (nate-protomatter) wrote :

How did you pair it? The steps in reply #9 did not work for me, I always get an authentication failed and it won't pair. I am tempted to downgrade to 12.04 LTS.

auslander (nate-protomatter) wrote :

Also note I am using a K811, which as far as I know is the same as the 810 except it has the mac-style "command" key, etc.

auslander (nate-protomatter) wrote :

Also note that under Linux Mint 15, the steps in #9 work reliably and the keyboard re-pairs after reboot. So maybe this is more of a gnome issue?

molecule-eye (niburu1) wrote :

I had this problem on Ubuntu Gnome 3.10 Final beta. The bug was also present on Fedora 20 Alpha 1 (Gnome 3.10). The only issue seems to be that the pin information is not being retrieved by bluetooth-wizard.

To get around the issue, I set my keyboard (MS Sculpt Mobile) to discovery mode, ran "sudo hcidump -at" in a terminal, then opened bluetooth-wizard, attempted to connect to the keyboard, checked for the pin in the terminal as reported by hcidump, entered that into the keyboard and pressed "enter", and bluetooth-wizard completed the set up.

Rykel from Singapore (rykel98) wrote :

I am using the Logitech K810 with Ubuntu 13.10 and you are right, it CANNOT be set up. And we thought that Ubuntu 13.10 is the big thing which will conquer the mobile world... which in turn uses Bluetooth devices nearly exclusively. Will this Bluetooth BUG be squashed soon?

Maciej (hamsterready) wrote :

@Rykel - it works for me on my 13.10 (updated from 13.04).

However I do have problems after my laptop suspend (to ram) as then I have to reboot to reconnect my keyboard.

Is there anything I can share (config files - or similar) to help?

Tim Chen (timchen119) wrote :

Hi,

Recent I got a HP bluetooth keyboard which has the exactly same issue,
after some analysis it's a problem between the dbus interface with gnome-bluetooth and bluez agent,
and I've backport some commits from bluez5 and fix some issues in gnome-bluetooth,

Can anyone who has this keyboard help me test the packages here:
https://launchpad.net/~timchen119/+archive/bluez4-ssp

instructions:
#sudo add-apt-repository -y ppa:timchen119/bluez4-ssp && apt-get update && apt-get install gnome-bluetooth bluez

the source code is locate at the "Related branches" in this bug.
If the result is positive I'll send the merge and prepare an SRU to sponsor.

I've upload Trusty, Utopic and Precise packages to my ppa, due to the bluez package is too old in Precise I've only port basic UI support and not as fancy as Trusty or Utopic but should still be usable.

Thanks.

Jean-Pierre Rupp (xenog) wrote :

Hello,

I upgraded to the packages in the PPA mentioned in comment #27. I removed mi Logitech K810 keyboard using the GUI, then restarted the computer. I managed to pair my keyboard successfully typing the six characters on-screen. In fact, the GUI showed progression as I typed the characters by marking already-typed ones with a dot.

Great Job Tim.

Tony Mobily (tonymobily) wrote :

I am typing this with my now-paired keyboard. THANK YOU Jim, it just worked!

Ugo (ugocupcic) wrote :

working for my k810 + ubuntu 14.04 too.

Scott Deagan (scott-deagan) wrote :

In reply to Tim Chen (#27):

I have installed the bluez4-ssp as instructed. It works, however, there is some weirdness. When I "Set up new device" and then select the K810 keyboard in the list and press the "Continue" button, it briefly shows one 6 digit PIN number before showing the second one.

While this is a fairly minor issue, it did result in an unsuccessful attempt to pair my K810 because I started typing in the PIN number from the first 6 digit PIN that was displayed, I then looked down at my keyboard and didn't see the PIN number change, I then continued to type in the remaining digits of the new PIN number that was displayed. The pairing then failed.

It was only on my second attempt that I noticed one PIN number is shown briefly before being replaced by a second PIN number.

Tim Chen (timchen119) wrote :

@Scott,

Hi, thanks for the testing and feedback,
that was because gnome bluetooth wizard is waiting the SSP callback event from the agent (and it may have different timing for different devices), currently it will briefly shows the usual PIN code page and switch to the SSP page when it recieve the callback event.

I will try to get some time to see how to fix this more properly and not broke gnome bluetooth wizard's current structure since this indeed affect user experience, but the current patch should be enough to fix the original SSP paring issue.

Ara Pulido (ara) on 2014-06-12
Changed in oem-priority:
status: New → In Progress
Ara Pulido (ara) on 2014-07-02
Changed in oem-priority:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Pascal Morin (pcm689) wrote :

According to last email from Ara:

Still waiting on cyphermox. I just pinged him today again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez - 4.101-0ubuntu19

---------------
bluez (4.101-0ubuntu19) utopic; urgency=medium

  * debian/patches/ssp_parameter.patch:
    Add ssp parameter fix, add a missing parameter entered in agent dbus API.
    Fixed Logitech Bluetooth Keyboard K760, Logitech Bluetooth Keyboard K810,
    HP Bluetooth Keyboard K4000 secure simple pairing failed issue.
    (LP: #1035431, #1291756)
 -- Jian-Ding Chen (timchen119) <email address hidden> Tue, 12 Aug 2014 09:47:45 -0400

Changed in bluez (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 3.8.2.1-0ubuntu9

---------------
gnome-bluetooth (3.8.2.1-0ubuntu9) utopic; urgency=medium

  * Add ssp parameter fix, fix the parameter entered in agent dbus API,
    also fix the wizard's UI to show the pin code correctly.
    Fixed Logitech Bluetooth Keyboard K760, Logitech Bluetooth Keyboard K810,
    HP Bluetooth Keyboard K4000 secure simple pairing failed issue.
    (LP: #1035431, #1291756)
 -- Jian-Ding Chen (timchen119) <email address hidden> Tue, 12 Aug 2014 15:14:40 -0400

Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Fix Released
Timm Freiheit (timm-freiheit) wrote :

Trying steps from #9 successfully connected my keyboard ONCE,- until the reboot. Now neither #9, #17 (repair) work, nor 'hcitool scan' or any GUI xfce blueman / gnome-bluetooth even see other bluetooth devices any more.

HP Chromebook 14
Xubuntu, 3.13.0-32-generic
gnome-bluetooth 3.8.2.1-0ubuntu5~test2 (latest version available to me)

lsusb says:
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 1058:1140 Western Digital Technologies, Inc. My Book Essential USB3.0
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 045e:0084 Microsoft Corp. Basic Optical Mouse
Bus 002 Device 003: ID 0cf3:311e Atheros Communications, Inc.
Bus 002 Device 002: ID 04f2:b40d Chicony Electronics Co., Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

any ideas?

Timm Freiheit (timm-freiheit) wrote :

additional info:
14.04 LTS

'hciconfig --all' says:
hci0: Type: BR/EDR Bus: USB
 BD Address: 48:5A:B6:11:6E:C4 ACL MTU: 1022:8 SCO MTU: 183:5
 UP RUNNING PSCAN
 RX bytes:1852 acl:0 sco:0 events:142 errors:0
 TX bytes:2782 acl:0 sco:0 commands:129 errors:0
 Features: 0xff 0xfe 0x0d 0xfe 0xd8 0x7f 0x7b 0x8f
 Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
 Link policy: RSWITCH HOLD SNIFF
 Link mode: SLAVE ACCEPT
 Name: 'chrubuntu-0'
 Class: 0x700100
 Service Classes: Object Transfer, Audio, Telephony
 Device Class: Computer, Uncategorized
 HCI Version: (0x7) Revision: 0x1102
 LMP Version: 4.0 (0x6) Subversion: 0x1
 Manufacturer: Atheros Communications, Inc. (69)

Timm Freiheit (timm-freiheit) wrote :

I updated to the ubuntu-mainline-kernel 3.16.1-031601-generic and everything's working fine now! GUI asks for PIN and it connects.

Changed in bluez (Ubuntu Trusty):
status: New → In Progress
Changed in gnome-bluetooth (Ubuntu Precise):
status: New → In Progress
Changed in gnome-bluetooth (Ubuntu Trusty):
status: New → In Progress
Changed in gnome-bluetooth (Ubuntu Precise):
status: In Progress → Triaged
Changed in bluez (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
Changed in bluez (Ubuntu Trusty):
importance: Undecided → High
Changed in gnome-bluetooth (Ubuntu Precise):
importance: Undecided → Medium
Changed in gnome-bluetooth (Ubuntu Trusty):
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in bluez (Ubuntu Trusty):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

No bluez-simple-agent 'solution' for me. cinnamon-bluetooth useless. Blueman useless. All options greyed out. bluetooth-wizard useless. Bluewho useless. Mint 17 64bit fresh install. Microsoft Sculp Mobile keyboard + working universal bluetooth dongle.

Traceback (most recent call last):
  File "/usr/bin/bluez-simple-agent", line 117, in <module>
    path = manager.DefaultAdapter()
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.bluez.Error.NoSuchAdapter: No such adapter

More like this in the forum:
http://forums.linuxmint.com/viewtopic.php?t=177748&p=921515
http://forums.linuxmint.com/viewtopic.php?f=49&t=168079

I uploaded the fixes for both gnome-bluetooth and bluez to trusty; pending review by the SRU team.

description: updated
Chris J Arges (arges) on 2014-09-23
summary: - bluetooh-wizard failed to connect to a keyboard(logitech)
+ bluetooth-wizard failed to connect to a keyboard(logitech)
Changed in gnome-bluetooth:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-bluetooth:
importance: Unknown → Medium
status: Unknown → New

Utopic works fine with my Logitech K760.

A backport for trusty 14.04 LTS would be really needed.

Hello Laurent, or anyone else affected,

Accepted bluez into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bluez/4.101-0ubuntu13.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bluez (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Laurent, or anyone else affected,

Accepted gnome-bluetooth into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-bluetooth/3.8.2.1-0ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-bluetooth (Ubuntu Trusty):
status: In Progress → Fix Committed
jimav (james-avera) wrote :

Does not work for me.
Running 14.10 with utopic-proposed enabled; an update installed gnome-bluetooth 3.8.2.1-0ubuntu9 amd64

Several errors were logged. It looks like an error occurs when starting discovery, before even attempting to pair with a device. And after attempting to pair, the usual "Invalid Parameters" error occurs AND a dbus error about a rejected message:

1. Clicked "Set up new device" in the bt applet
syslog: bluetoothd[637]: Discovery session 0x7f9eb2d982c0 with :1.70 activated
syslog: bluetoothd[637]: Unknown command complete for opcode 37

3. Selected a device in the list and clicked Next (the device was my Android 4.4 cellphone, which was set to be visible)
syslog: bluetoothd[637]: Stopping discovery
syslog: bluetoothd[637]: hci0: Cancel Pair Device (0x001a) failed: Invalid Parameters (0x0d)

auth.log: dbus[601]: [system] Rejected send message, 3 matched rules; type="method_return", sender=":1.73" (uid=2000 pid=5662 comm="bluetooth-wizard ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.1" (uid=0 pid=637 comm="/usr/sbin/bluetoothd ")

I'm using a usb bluetooth dongle. I've _never_ been able to use it with Ubuntu, so I suppose it could be a hardware problem. Even if that is so, the above errors looks like bugs to me, not legitimate diagnostics.

Tim Chen (timchen119) wrote :

HP Bluetooth Keyboard K4000 worked fine with packages in trusty-proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 3.8.2.1-0ubuntu4.2

---------------
gnome-bluetooth (3.8.2.1-0ubuntu4.2) trusty-proposed; urgency=medium

  * Add ssp parameter fix, fix the parameter entered in agent dbus API,
    also fix the wizard's UI to show the pin code correctly.
    Fixed Logitech Bluetooth Keyboard K760, Logitech Bluetooth Keyboard K810,
    HP Bluetooth Keyboard K4000 secure simple pairing failed issue.
    (LP: #1035431)

gnome-bluetooth (3.8.2.1-0ubuntu4.1) trusty; urgency=low

  * debian/patches/99_add_microsoft_mice.patch: fix the problem that
    Microsoft Bluetooth Mobile Keyboard 6000 cannot be paired. (LP: #1312349)
 -- Jian-Ding Chen (timchen119) <email address hidden> Mon, 28 Apr 2014 17:40:00 +0800

Changed in gnome-bluetooth (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-bluetooth has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez - 4.101-0ubuntu13.1

---------------
bluez (4.101-0ubuntu13.1) trusty-proposed; urgency=medium

  * Add ssp parameter fix, add a missing parameter entered in agent dbus API.
    Fixed Logitech Bluetooth Keyboard K760, Logitech Bluetooth Keyboard K810,
    HP Bluetooth Keyboard K4000 secure simple pairing failed issue.
    (LP: #1035431)

    backported bluez5 commits:
    upstream commit 546fee067daedc2b7860481aeaebd1771d192dfb
    mgmt: Implement support for Passkey Notify event
    upstream commit 97b930870dcd016b9cdd612e47b832736b4d0c5d
    core: Refactor authentication handling
    upstream commit e86fe268c77017731b792296eea16206918f1852
    agent: Add missing parameter to DisplayPasskey
    upstream commit 6a394b2c7f19b53b630bef2e865f9bc289d4b75c
    agent-api: DisplayPasskey: D-Bus doesn't have a uint8 type
 -- Jian-Ding Chen (timchen119) <email address hidden> Thu, 04 Sep 2014 13:34:39 -0400

Changed in bluez (Ubuntu Trusty):
status: Fix Committed → Fix Released
tags: added: precise
Ara Pulido (ara) on 2015-02-16
Changed in oem-priority:
status: In Progress → Fix Released
Changed in gnome-bluetooth:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.