git clone -q ends with "early EOF" error on large repositories

Bug #1228148 reported by Marek Vasut on 2013-09-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
git (Ubuntu)
High
Andy Whitcroft
Lucid
Undecided
Unassigned
Precise
High
Andy Whitcroft
git-core (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Hello,

I am trying to clone a repository and I am getting the following output:

$ git clone -q git://kernel.ubuntu.com/ubuntu/linux.git
fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed

The "fatal:" lines usually appear a few minutes after running the clone. Of
course, the clone does not finish successfully. Interestingly, when I drop the
'-q' option from the git clone commandline, the clone finishes correctly.

My git version is:

$ git --version
git version 1.8.4.rc3

This issue was reported to git AT vger kernel org ML with the following result:
http://www.spinics.net/lists/git/msg217736.html

Server-side patch must be applied as described here:
http://www.spinics.net/lists/git/msg217744.html

Patches that fix the issue:
http://www.spinics.net/lists/git/msg217019.html
http://www.spinics.net/lists/git/msg217020.html

Can you please fix your git server at kernel.ubuntu.com ?

Thank you!

Best regards,
Marek Vasut

Andy Whitcroft (apw) wrote :

This affects commands against kernel.ubuntu.com as well, so we would need any fix backported to Lucid currently and likely Precise as the next likely upgrade. Targetting there.

Changed in git (Ubuntu):
status: New → Confirmed
summary: - git clone -q ends with early EOF
+ git clone -q ends with "early EOF" error on large repositories
Andy Whitcroft (apw) wrote :

It seems that back in Lucid we were still calling this git-core ... so fork to that for Lucid.

Changed in git (Ubuntu Lucid):
status: New → Invalid
Changed in git-core (Ubuntu Precise):
status: New → Invalid
Andy Whitcroft (apw) on 2013-09-20
Changed in git-core (Ubuntu):
status: New → Invalid
Marek Vasut (marek-vasut) wrote :

Hello, are there any news on this issue ?

Changed in git (Ubuntu):
assignee: nobody → Irfan Fauzan (irfan-it2988)
Changed in git (Ubuntu Lucid):
assignee: nobody → Irfan Fauzan (irfan-it2988)
Changed in git (Ubuntu Precise):
assignee: nobody → Irfan Fauzan (irfan-it2988)
Changed in git-core (Ubuntu):
assignee: nobody → Irfan Fauzan (irfan-it2988)
Changed in git-core (Ubuntu Lucid):
assignee: nobody → Irfan Fauzan (irfan-it2988)
Changed in git-core (Ubuntu Precise):
assignee: nobody → Irfan Fauzan (irfan-it2988)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in git (Ubuntu Precise):
status: New → Confirmed
Changed in git-core (Ubuntu Lucid):
status: New → Confirmed
Anders Kaseorg (andersk) on 2014-05-13
Changed in git (Ubuntu):
assignee: Irfan Fauzan (irfan-it2988) → nobody
Changed in git (Ubuntu Lucid):
assignee: Irfan Fauzan (irfan-it2988) → nobody
Changed in git (Ubuntu Precise):
assignee: Irfan Fauzan (irfan-it2988) → nobody
Changed in git-core (Ubuntu):
assignee: Irfan Fauzan (irfan-it2988) → nobody
Changed in git-core (Ubuntu Lucid):
assignee: Irfan Fauzan (irfan-it2988) → nobody
Changed in git-core (Ubuntu Precise):
assignee: Irfan Fauzan (irfan-it2988) → nobody
Andy Whitcroft (apw) on 2015-01-26
Changed in git-core (Ubuntu Lucid):
status: Confirmed → Won't Fix
Changed in git (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Andy Whitcroft (apw)
milestone: none → ubuntu-12.04.5
milestone: ubuntu-12.04.5 → none
Changed in git (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
milestone: none → ubuntu-15.01
Andy Whitcroft (apw) on 2015-01-27
Changed in git (Ubuntu Precise):
status: Confirmed → In Progress
Changed in git (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
Anders Kaseorg (andersk) wrote :

This was fixed in Git 1.8.4.2, which is in Trusty. Marking closed in the current development release (the Precise task remains open).

Changed in git (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers