Quicklist action for creating new document is incorrect

Bug #1027584 reported by Barneedhar on 2012-07-22
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gedit
Fix Released
Medium
gedit (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Both the actions of gedit quicklists have the same command listed.

$ cat /usr/share/applications/gedit.desktop
[Desktop Entry]
Name=gedit
GenericName=Text Editor
Comment=Edit text files

[Desktop Action Window]
Name=Open a New Window
Exec=gedit --new-window
OnlyShowIn=Unity;

[Desktop Action Document]
Name=Open a New Document
Exec=gedit --new-window
OnlyShowIn=Unity;

Only showing relevant parts of the .desktop file.

The command for creating a new document is actually `gedit --new-document` and not the `--new-window` that is currently in the quicklist.

This bug was probably introduced when fixing bug #938748.

Barneedhar (barneedhar) on 2012-07-22
Changed in gedit (Ubuntu):
status: New → Fix Committed
assignee: nobody → Barneedhar (barneedhar)
Barneedhar (barneedhar) on 2012-07-22
Changed in gedit (Ubuntu):
status: Fix Committed → In Progress
Barneedhar (barneedhar) on 2012-07-22
description: updated
Changed in gedit (Ubuntu):
importance: Undecided → Low
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit - 3.5.1-0ubuntu2

---------------
gedit (3.5.1-0ubuntu2) quantal; urgency=low

  * Pass --new-document instead of --new-window in the "Open a New Document"
    action. (LP: #1027584)
 -- Iain Lane <email address hidden> Mon, 23 Jul 2012 11:09:02 +0100

Changed in gedit (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Iain Lane (laney) wrote :

I pushed this for Precise to lp:~ubuntu-desktop/gedit/precise-proposed. I won't upload though, because this isn't worth SRUing on its own. If gedit gets SRUed for whatever reason, this fix will get in then.

Changed in gedit (Ubuntu Precise):
status: New → Fix Committed
Barneedhar (barneedhar) on 2012-07-23
Changed in gedit (Ubuntu):
assignee: Barneedhar (barneedhar) → nobody
status: Fix Released → Confirmed
Barneedhar (barneedhar) on 2012-07-23
Changed in gedit (Ubuntu):
status: Confirmed → Fix Released
Iain Lane (laney) on 2012-07-23
Changed in gedit (Ubuntu Precise):
importance: Undecided → Low
Changed in gedit:
importance: Unknown → Medium
status: Unknown → New
Changed in gedit:
status: New → Invalid
Changed in gedit (Ubuntu Precise):
status: Fix Committed → Incomplete
Melanie (gingerspy11) on 2013-05-06
Changed in gedit (Ubuntu Precise):
status: Incomplete → New
Mathew Hodson (mhodson) on 2017-02-25
affects: gedit → ubuntu-translations
Changed in ubuntu-translations:
importance: Medium → Undecided
status: Invalid → New
no longer affects: ubuntu-translations
Changed in gedit:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.