libfreerdp-plugins-standard is uninstallable on Ubuntu images due to banned libavcodec

Bug #931931 reported by Martin Pitt on 2012-02-14
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
freerdp (Ubuntu)
Undecided
Martin Pitt
Precise
Undecided
Martin Pitt

Bug Description

We recently replaced rdesktop and vinagre with FreeRDP and Remmina. However, remmina-plugin-rdp Depends: libfreerdp-plugins-standard, and freerdp-x11 recommends it. libfreerdp-plugins-standard depends on libavcodec53 which is banned from installation images due to potential patent infringements.

So we either need to drop the depends/recommends on libfreerdp-plugins-standard, or find a way to make this not depend on libavcodec, by either split things out further, or disabling some features, or using gstreamer.

I'll revert the seed change for now, until this is resolved.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in freerdp (Ubuntu):
status: New → Confirmed
tags: added: iso-testing precise qa-daily-testing
Martin Pitt (pitti) wrote :

Stephane suggested to just disable FFMPEG support for now, the support for MMR will come back later through the gstreamer rewrite.

Changed in freerdp (Ubuntu Precise):
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package freerdp - 1.0.1-1ubuntu1

---------------
freerdp (1.0.1-1ubuntu1) precise; urgency=low

  * debian/control, debian/rules: Drop libavcodec-dev build dependency and
    disable ffmpeg support, to avoid the banned libavcodec53 on the
    installation images. Support for MMR will come back later in the planned
    gstreamer rewrite. (LP: #931931)
 -- Martin Pitt <email address hidden> Tue, 14 Feb 2012 13:26:44 +0100

Changed in freerdp (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints