Ubuntu

[armel] eglibc test regressions on armel in oneiric

Reported by Matthias Klose on 2011-05-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
High
Linaro Tool Chain Working Group
Precise
High
Unassigned

Bug Description

these regressions are new when building eglibc in oneiric:

next.out, Error 1
nodelete2.out, Error 1
noload.out, Error 1
order2.out, Error 1
reldep5.out, Error 127
reldep6.out, Error 1
reldep8.out, Error 134
tst-cancel24, Error 1
tst-cputimer1.out, Error 1
tst-initorder.out, Error 1
tst-putenv.out, Error 1
tst-tls6.out, Error 1
unload4.out, Error 127

Matthias Klose (doko) on 2011-05-02
summary: - eglibc test regressions on armel in oneiric
+ [armel] eglibc test regressions on armel in oneiric
tags: added: armel
Changed in eglibc (Ubuntu):
importance: Undecided → High
milestone: none → oneiric-alpha-1
status: New → Confirmed
Kate Stewart (kate.stewart) wrote :

  Its been over a month with no activity on this bug, so not sure if Linaro team knows about it or not. Assigning this to the Linaro toolchain group explicitly, so it shows up on their radar.

Changed in eglibc (Ubuntu):
milestone: oneiric-alpha-1 → oneiric-alpha-2
assignee: nobody → Linaro Tool Chain Working Group (linaro-toolchain-wg)
Martin Pitt (pitti) on 2011-07-07
Changed in eglibc (Ubuntu):
milestone: oneiric-alpha-2 → oneiric-alpha-3
Changed in eglibc (Ubuntu):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Matthias Klose (doko) wrote :

still seen in 2.13-9ubuntu3

next.out, Error 1
nodelete2.out, Error 1
noload.out, Error 1
order2.out, Error 1
reldep5.out, Error 127
reldep6.out, Error 1
reldep8.out, Error 134
test-fenv.out, Error 1
tst-cancel17.out, Error 1
tst-cancel24, Error 1
tst-cancelx17.out, Error 1
tst-efgcvt.out, Error 4
tst-initorder.out, Error 1
tst-putenv.out, Error 1
tst-tls6.out, Error 1
unload4.out, Error 127

Michael Hope (michaelh1) wrote :

Hi there. Sorry, I hadn't seen this bug. We should talk about how to track issues some time.

I'm afraid this isn't a priority and we won't be working on it any time soon. I'm happy to look at specific issues that block progress but this is lower priority than the GCC, GDB, and QEMU work.

How about putting it in the ARM porters queue for further triage?

Martin Pitt (pitti) on 2011-08-31
Changed in eglibc (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
Kate Stewart (kate.stewart) wrote :

removing milestone since no one working on it. The fact its slipped from milestone to milestone indicates some process changes needed.

Changed in eglibc (Ubuntu):
milestone: ubuntu-11.10-beta-2 → none
Matthias Klose (doko) wrote :

re-confirmed with 2.13-20ubuntu1

tags: added: arm-porting-queue
Adam Conrad (adconrad) wrote :

Testsuite failures in 2.17 are much more manageable and in line with upstream expectations:

annexc.out, Error 1 (ignored)
check-localplt.out, Error 1
run-conformtest.out, Error 1 (ignored)
test-fenv.out, Error 1
tst-backtrace6.out, Error 1

A couple of those would still be nice to clean up, but it's far less scary than it once was.

Changed in eglibc (Ubuntu Precise):
status: Confirmed → Won't Fix
Changed in eglibc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers