cmake sets the default optimization level to -O3

Bug #840301 reported by Matthias Klose on 2011-09-03
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cmake (Debian)
Fix Released
cmake (Ubuntu)

Bug Description

Debian policy 10.1 gives defaults for the optimization level, which is -O2.
The last paragraph allows exceptions for certain packages on the decision of the
package maintainer. It's certainly not meant for the maintainer of a build
system to make this decision on the behalf of all packages using this build
system. The default should be changed to -O2.

Plus it looks like that -g is not enabled for release builds.

Matthias Klose (doko) wrote :

won't touch in oneiric

Changed in cmake (Ubuntu):
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Won't Fix
Changed in cmake (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.