landscape handler needs to set RUN=1 in /etc/default/landscape-client

Bug #1042758 reported by Andreas Hasenack on 2012-08-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Thomas Herve
cloud-init (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

==== Begin SRU Information ===
[IMPACT]
 * explanation: The prevents people using cloud-init and Landscape to automatically register instances. The configuration will be updated, but Landscape won't start, thus forcing people to either write additional code or manually go the instances.
 * justification: without this landscape integration of cloud instances requires further effort by the user
 * Fix: the fix is simple, it writes 'RUN=1' to /etc/default/landscape-client if and only if landscape configuration is given.

[TESTCASE]
To reproduce the problem, create a cloud-init configuration with Landscape credentials:
#cloud-config
landscape:
 - account_name: "$host_account"
 - computer_title: "Test instance"
 - cloud: true

Using the released version, the configuration will be written, but the client won't start and the instance won't register. With the fixed version, the client will start and register to Landscape hosted.

The change is minimal and only impact the Landscape portion of the code. https://code.launchpad.net/~therve/cloud-init/fix-landscape-config/+merge/122870 contains the relevant changeset.

The user-data at http://paste.ubuntu.com/1256164/ should result in the ppa being added, cloud-init being upgraded, and the new code correctly being used.

[Regression Potential]
 * There is very little potential for regression here. The changes modified path is only taken if there is landscape configuration given to cloud-init.

==== End SRU Information ===

The landscape handler needs to also set RUN=1 in /etc/default/landscape-client. Without it, the initscript /etc/init.d/landscape-client won't start the service.

Related branches

Thomas Herve (therve) on 2012-09-05
Changed in cloud-init:
assignee: nobody → Thomas Herve (therve)
status: New → In Progress
Scott Moser (smoser) wrote :

fixed in revno 645.

Changed in cloud-init:
status: In Progress → Fix Committed
Scott Moser (smoser) on 2012-09-19
Changed in cloud-init (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cloud-init (Ubuntu Precise):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.7.0~bzr659-0ubuntu1

---------------
cloud-init (0.7.0~bzr659-0ubuntu1) quantal; urgency=low

  * New upstream snapshot.
    * add signal handlers to more cleanly exit
    * add logging fallback in case logging fails
    * documentation fix for landscape config (LP: #1042764)
    * do not write a comment in /etc/hostname (LP: #1052664)
    * fix incorrect ubuntu mirrors for 'ports' arches [Robbie Basak]
    * fix generation of hostname based on ip address in datasource
      (LP: #1050962) [Andy Grimm]
    * remove 'start networking' from cloud-init-nonet and replace it
      with container specific fixes (LP: #1031065)
    * fix landscape configuration so client will run (LP: #1042758)
    * enable all available datasources (adding AltCloud and None)
    * fix bug where user data scripts re-ran on upgrade from 10.04 versions
      (LP: #1049146)
 -- Scott Moser <email address hidden> Wed, 19 Sep 2012 22:08:51 -0400

Changed in cloud-init (Ubuntu):
status: In Progress → Fix Released
Scott Moser (smoser) on 2012-09-24
Changed in cloud-init:
importance: Undecided → Medium
Changed in cloud-init (Ubuntu):
importance: Undecided → High
Changed in cloud-init (Ubuntu Precise):
importance: Undecided → High
Scott Moser (smoser) on 2012-10-01
Changed in cloud-init:
status: Fix Committed → Fix Released
Scott Moser (smoser) wrote :

The fix to 12.04 was uploaded on Wednesday in cloud-init_0.6.3-0ubuntu1.1.

description: updated
Changed in cloud-init (Ubuntu Precise):
status: Confirmed → In Progress
Scott Moser (smoser) on 2012-10-05
description: updated

Hello Andreas, or anyone else affected,

Accepted cloud-init into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cloud-init/0.6.3-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cloud-init (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Scott Moser (smoser) on 2012-11-06
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.6.3-0ubuntu1.1

---------------
cloud-init (0.6.3-0ubuntu1.1) precise-proposed; urgency=low

  [Thomas Hervé]
  * if configuration enables landscape, then set RUN=1 in /etc/default/landscape
    (LP: #1042758)
 -- Scott Moser <email address hidden> Tue, 02 Oct 2012 10:59:05 -0400

Changed in cloud-init (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers