[Enumertaed ENS1371 inside VMWare, playback] Sound volume set to 0 when booting from install CD

Bug #927459 reported by Christopher Chaltain on 2012-02-06
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
High
mayur
Precise
High
Unassigned

Bug Description

When booting from the install CD for Precise, the audio volume is set to 0. Therefore, I don't hear the drums and don't know when to press control+s to start Orca. I am a blind user, and this problem hinders the accessibility of Ubuntu. In my case, I'm able to use the system's media keys to raise the volume of audio.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.24+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: chaltain 1483 F.... pulseaudio
 /dev/snd/pcmC0D0p: chaltain 1483 f...m pulseaudio
 /dev/snd/timer: chaltain 1483 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'AudioPCI'/'Ensoniq AudioPCI ENS1371 at 0x2040, irq 16'
   Mixer name : 'Cirrus Logic CS4297A rev 3'
   Components : 'AC97a:43525913'
   Controls : 24
   Simple ctrls : 13
Date: Sun Feb 5 23:15:23 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:AudioPCI successful
Symptom_Card: ES1371 [AudioPCI-97] - Ensoniq AudioPCI
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_Type: None of the above
Title: [ENS1371 - Ensoniq AudioPCI, playback] Playback problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/02/2011
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 6.00
dmi.board.name: 440BX Desktop Reference Platform
dmi.board.vendor: Intel Corporation
dmi.board.version: None
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr6.00:bd06/02/2011:svnVMware,Inc.:pnVMwareVirtualPlatform:pvrNone:rvnIntelCorporation:rn440BXDesktopReferencePlatform:rvrNone:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: VMware Virtual Platform
dmi.product.version: None
dmi.sys.vendor: VMware, Inc.

Related branches

Christopher Chaltain (chaltain) wrote :
Christopher Chaltain (chaltain) wrote :

I forgot to mention that I see this same behavior when installing Ubuntu 11.10.

Attila Hammer (hammera) wrote :

Hy Christopher,

I see your amixer values following interesting value:
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [off]
What happening if you run following command when your sound is not muted:
amixer set 'IEC958',0 off
Your sound is muted?
After you doed this test and run amixer set 'IEC958',0 on command, your sound is restored correctly?

If yes, I try making a patch for Precise to solving this issue. Other mixer values I not see 0 value, and not see muted channel for importanter playback related channels.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Alan Bell (alanbell) on 2012-02-06
tags: added: a11y
tags: added: rls-mgr-p-tracking
Changed in alsa-driver (Ubuntu):
importance: Undecided → High
David Henningsson (diwic) wrote :

I'm not sure this bug is what it seems like.

1) There is no system-ready sound (the drums). This is because lightdm never triggers one, like gdm does. This is a bug in lightdm, but it does not concern the live-CD, which boots right into a logged in session (bypassing lightdm).

2) There is no session-login sound (the longer note jungle like sound). This is because it is disabled; as can be seen if you pull down the system menu/indicator, startup applications. You will find the "GNOME Login Sound" application in a disabled state. You can enable it on an installed system, but not on a live-CD (because the live-CD does not store state between sessions).

3) Looking at the audio on your particular system, audio does not seem to be muted. It is not muted everywhere (i e, if I start a live-CD 12.04 session here, audio is at a good volume when I boot my system). Can you confirm that your system actually is muted at startup, so that you're not just suffering from bugs 1 and/or 2? If so, can you attach an alsa-info ( https://wiki.ubuntu.com/Audio/AlsaInfo ) from still being in the muted state? (Don't worry about it if this is nearly impossible for a blind user)

Changed in alsa-driver (Ubuntu Precise):
status: Confirmed → Incomplete
Kate Stewart (kate.stewart) wrote :

When I bring up mumble the first time on real hardware (not a virtual machine), I have to go in and reset the output back to 100%. Its marked at 0%. Next time I do a fresh install, will try to capture this if someone doesn't do it before me.

Changed in alsa-driver (Ubuntu Precise):
status: Incomplete → Confirmed
Christopher Chaltain (chaltain) wrote :

In reference to comment #4 above, I'm talking about hearing the drums when booting from a Live CD, and not the jungle music you hear when you log in, so I don't think issues 1 or 2 apply in this case.

My sound volume is also set to 0 on the first boot after the install, but again I don't think this is the same as #1, since I do need to raise the volume in this case. It may be that in this case, even with the volume set higher, I still wouldn't hear the drums because of the issue with lightdm.

You're right, I had already raised the volume before running ubuntu-bug. I haven't been able to figure out how to capture this information myself from the Live CD or the first boot, but I'll see if I can get some sighted help this weekend and post the alsa-info before changing the volume.

Also, I don't think the sound is technically "muted". My wife says she doesn't see the nhorn corssed out. Furthermore, unmuting doesn't change anything. I have to explicitly raise the volume. I'm not sure if that distinction is important or not.

David, I actually suspect the bug lies in the alsactl init/restore code somewhere, as I also have a system that has no volume set on boot, or at least, not all of the ALSA mixer controls are enabled and turned off, thereby causing pulse to think the audio is muted.

I am going to try and reproduce the problem with the alsa-utils 1.0.25 package, and if the problem still persists, I think its alsa-utils where this bug should reside.

Will update accordingly once I have investigated on my affected system.

OK, I got some sighted help and ran alsa-info.sh after booting up the Live CD where the volume was set to 0.

Raymond (superquad-vortex2) wrote :

>> This is the output of the alsa-info.sh command that was saved in the /tmp directory. (14.7 KiB, text/plain)

This is not a real ens1371, just the emulated ens1371 sound card inside a vm

Manufacturer: VMware, Inc.
Product Name: VMware Virtual Platform
Product Version: None

Raymond (superquad-vortex2) wrote :

BTW since ens1371 support mono playback

Does "test speaker" in gnome sound preference crash when you select "mono" profile in hardware

tags: added: rls-p-tracking
tags: removed: rls-p-tracking
Changed in alsa-driver (Ubuntu):
status: Confirmed → Fix Committed
Changed in alsa-driver (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
Changed in alsa-driver (Ubuntu Precise):
status: Fix Committed → Fix Released
Matthew Paul Thomas (mpt) wrote :

(Undoing vandalism by ~arturbryczek.)

Changed in alsa-driver (Ubuntu):
status: Fix Released → Confirmed
Changed in alsa-driver (Ubuntu Precise):
status: Fix Released → Confirmed
Raymond (superquad-vortex2) wrote :

should this bug be fixed in vmware since the emulation of ens1371 and cs4297areally different from the real hardware

Changed in alsa-driver (Ubuntu):
assignee: nobody → Carlos Rivera (cadaritre)
Changed in alsa-driver (Ubuntu):
status: Confirmed → Fix Committed

Please DON'T change the bug status without explanation

Changed in alsa-driver (Ubuntu):
status: Fix Committed → Confirmed
mayur (mayur-bharda) on 2013-06-27
Changed in alsa-driver (Ubuntu):
assignee: Carlos Rivera (cadaritre) → mayur (mayur-bharda)
status: Confirmed → Incomplete
ljubisa (ljubisadenik) on 2015-09-02
Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
summary: - [ENS1371 - Ensoniq AudioPCI, playback] Sound volume set to 0 when
+ [Enumertaed ENS1371 inside VMWare, playback] Sound volume set to 0 when
booting from install CD
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers