[needs-packaging] hpfall

Bug #910040 reported by carlosv on 2011-12-30
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Unassigned
Precise
Wishlist
Unassigned

Bug Description

A lot of the HP laptops have 3D Driveguard. This package is crucial for the HP laptops that include the 3D Driverguard (many from HP) and should be include in Ubuntu. The device use the PC accelerometer device used to park the hard drive spindle when the notebook PC falls or is in motion may not function as expected after performing a recovery process using restore media. When functioning correctly, an amber LED will light in the hard drive notification area.

Now, the driver for the accelerometer is loaded by default in Linux Kernel as modules hp_accel and lis3ld02d. It can be used as a Joystick as well. And works really well in Ubuntu. I have been trying the performance. I have it on my HP touchsmart tm2 and with Ubuntu 11.10 amd64. So in order to activate the protection it is needed to run the hpfall.c deamon that is not include. In order to render useful the device on the HP laptops the package should be included in Ubuntu. Otherwise, the device won't protect the hard disk in case of fall and it is useful just to play pinball with the HP laptops.

URL: https://launchpad.net/~pmjdebruijn/+archive/ppa/+build/2562251
License: GPLv2
Notes: it is released for Ubuntu 11.04 but works as well in Ubuntu 11.10

tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
tags: added: blocks-hwcert-enablement
Manoj Iyer (manjo) wrote :

SRU JUSTIFICATION
================

CAUSE
======
Missing New HP laptops assign a new PNP id "HPQ6000" for DriveGuard, this is required for the new laptops to park the head when the laptop falls.

Test
======
Test kernel available at http://kernel.ubuntu.com/~manjo/oneiric/lp914454/ This kernel was tested by me and James Ferguson.

carlosv (cvedovatti) wrote :

I just test it with the Kernel available at http://kernel.ubuntu.com/~manjo/oneiric/lp914454/ . Works fine!

Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem ( 3.0.0-17.30). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
carlosv (cvedovatti) wrote :

I test it on the proposed Kernel 3.0.0-17-generic. Same performance, LED, parking working on free fall. No problem detected. I will tag it as "verification-done-oneiric".

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Christoph Buchner (bilderbuchi) wrote :

So, what's the status of this? I've tried to install hpfall from pmjdebruijn's PPA but it doesn't work on Precise. :-(

carlosv (cvedovatti) wrote :

Hi there! Unfortunately it has not been implemented in Ubuntu 12.04 and the PPA is not up to date.
On the other hand, just install the package for Natty and it works for Ubuntu 11.10 and 12.04. I have been using it since one year and I had no problem. I attached to this comment. Just install it, restart the system and you can test it. To test it, just let fall your computer, obviously over your bed or shake it up and down and the LED of the hard disk should change to amber when is parked. Another way to test it, is that change the Power settings so when you close the lid of the laptop, it turn of the screen and avoid suspending. When the lid is closed, the deamon is even more sensitive and it parks the hard disk with even less movements. Then close the lid and move your computer and the LED should change color amber.

Christoph Buchner (bilderbuchi) wrote :

Ah awesome, thanks for that. I was under the impression that the PPA failing would mean that the natty package is incompatible anyway. Trying this out right now.

PK (peekay) wrote :

Why is the status "Fix Released" or "Fix Committed" when the package is still not included?

carlosv (cvedovatti) wrote :

I believe that the "Fix Released" is due the fact that the package is there and works. The "Fix Committed" I guess it means that this package will be included in the Ubuntu releases. But I am not pretty sure about it.

PK (peekay) wrote :

You are not sure about it but you marked it as such for Precise on 2012-05-28 according to the activity log?

carlosv (cvedovatti) wrote :

HI, what I meant is that I am not pretty sure about the meaning of "Fix Committed" in the releases names and "Fix Released" in Ubuntu. That may sound as contradiction and I didn't change the status. What I pointed out in the 2012-05-28 is that the deamon works fine for precise and natty. I have tried on my HP touchsmart tm2 and HP EliteBook. I have been using it since 18 months and it works fine.

PK (peekay) wrote :

Well, IMHO "fix commited" would mean that the hpfall package is included in the Ubuntu repositories which is what the first post calls for. Since that's not the case I am going to change it back.

Pascal de Bruijn (pmjdebruijn) wrote :

I'm currently not maintaining the hpfall package anymore, as all my systems have an SSD now. It's an extremely simple package, where hpfall.c is gotten from the upstream kernel tarball. I used to update hpfall.c with each ubuntu release, using the kernel version from which the hpfall.c file came.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Adolfo Jayme (fitojb) on 2013-05-18
no longer affects: Ubuntu Oneiric
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers