<process> crashed with AttributeError in __getattr__(): 'Symbol' object has no attribute 'MODIFY_EVENT' in zeitgeist python library

Bug #807282 reported by Craig Magina on 2011-07-07
This bug report is a duplicate of:  Bug #807076: raptor2 not supported. Edit Remove
234
This bug affects 50 people
Affects Status Importance Assigned to Milestone
Ubuntu Software Center
Fix Released
High
Gary Lasker
Zeitgeist Framework
New
Undecided
Unassigned
zeitgeist (Ubuntu)
High
Canonical Desktop Team
Oneiric
High
Canonical Desktop Team

Bug Description

I had just clicked the Arista Transcoder entry under the recommended list and was looking at the optional packages when I got the apport pop-up.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.8
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic x86_64
Architecture: amd64
Date: Thu Jul 7 19:21:35 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110705.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in __getattr__(): 'Symbol' object has no attribute 'MODIFY_EVENT'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Craig Magina (craig.magina) wrote :
visibility: private → public
Satriyana (sa3yana) on 2011-07-08
Changed in software-center (Ubuntu):
assignee: nobody → Satriyana (sa3yana)
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Same problem when launching s-c and trying to purchase a software.

@Satriyana, only assign a bug to yourself is you actually plan to fix it.

Changed in software-center (Ubuntu):
assignee: Satriyana (sa3yana) → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → High
status: New → Confirmed
Vangel Ajanovski (ajanovski) wrote :

not just for Arista, it does the same on other apps.

Martin Pitt (pitti) on 2011-07-08
Changed in software-center (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Gary Lasker (gary-lasker)
Alessandro Losavio (alo21) wrote :

Ubuntu 11.10 alpha 2 amd64

Step to reproduce it:

1) Open Ubuntu Software Center from Launcher
2) Search "skype"
3) Click on "Use this source"

The crash appears to me and the source was edded

Alessandro Losavio (alo21) wrote :

I had this bug when i open Ubuntu Software Center and install program too. But all work done

James Galea (jamesgalea) wrote :

Alpha 2:
Same as Alessandro here:
1) Open Ubuntu Software Center from Launcher
2) Search "skype"
3) Click on "Use this source"

nakki (titibanjekistan) wrote :

Same installing deb file from skype's site...or searching skype on sotware-center or using a bit software-center...
There are many spets to reproduce it.

Chris Coulson (chrisccoulson) wrote :

This is actually a bug in zeitgeist:

<chrisccoulson> hmmm, i get bug 807282 in bzr too. i wonder if it's actually a zeitgeist bug instead
<ubot2> Launchpad bug 807282 in software-center "software-center crashed with AttributeError in __getattr__(): 'Symbol' object has no attribute 'MODIFY_EVENT'" [High,Confirmed] https://launchpad.net/bugs/807282
<seif> chrisccoulson, is it and we are working on it
<seif> its actually a critical bug
<chrisccoulson> seif, awesome, thanks!

affects: software-center (Ubuntu Oneiric) → zeitgeist (Ubuntu Oneiric)
Changed in zeitgeist (Ubuntu Oneiric):
assignee: Gary Lasker (gary-lasker) → Canonical Desktop Team (canonical-desktop-team)
Christopher (soft-kristal) wrote :

It makes sense that it's due to zeitgeist, as the software center still works.

summary: - software-center crashed with AttributeError in __getattr__(): 'Symbol'
- object has no attribute 'MODIFY_EVENT'
+ <process> crashed with AttributeError in __getattr__(): 'Symbol' object
+ has no attribute 'MODIFY_EVENT' in zeitgeist python library

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #808020, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
Chenheting (chenheting) wrote :

I just start trying to install some software at software-center. It pop-up to report this bug.

Siegfried Gevatter (rainct) wrote :

From #807076 (Zeitgeist upstream bug):

The problem is not in zeitgeist itself, but in the recent version of raptor2-utils in ubuntu oneiric.
See http://bugs.librdf.org/mantis/view.php?id=451 for the upstream bugreport.

Affected version is raptor2-utils >= 2.0.2

Changed in software-center:
assignee: nobody → Gary Lasker (gary-lasker)
importance: Undecided → Medium
status: New → Triaged
importance: Medium → High
Gary Lasker (gary-lasker) wrote :

I added some code in software-center to gracefully handle the AttributeError. This will take care of the crasher in Software Center pending the real fix in Zeitgeist.

Changed in software-center:
status: Triaged → Fix Committed

The problem is not Zeitgeist itself but the upstream rdflib
http://bugs.librdf.org/mantis/view.php?id=451

On Tue, Jul 12, 2011 at 8:13 PM, Gary Lasker <email address hidden>wrote:

> I added some code in software-center to gracefully handle the
> AttributeError. This will take care of the crasher in Software Center
> pending the real fix in Zeitgeist.
>
> ** Changed in: software-center
> Status: Triaged => Fix Committed
>
> --
> You received this bug notification because you are a member of Zeitgeist
> Framework Team, which is subscribed to Zeitgeist Framework.
> https://bugs.launchpad.net/bugs/807282
>
> Title:
> <process> crashed with AttributeError in __getattr__(): 'Symbol'
> object has no attribute 'MODIFY_EVENT' in zeitgeist python library
>
> Status in Ubuntu Software Center:
> Fix Committed
> Status in Zeitgeist Framework:
> New
> Status in “zeitgeist” package in Ubuntu:
> Confirmed
> Status in “zeitgeist” source package in Oneiric:
> Confirmed
>
> Bug description:
> I had just clicked the Arista Transcoder entry under the recommended
> list and was looking at the optional packages when I got the apport
> pop-up.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: software-center 4.1.8
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic x86_64
> Architecture: amd64
> Date: Thu Jul 7 19:21:35 2011
> EcryptfsInUse: Yes
> ExecutablePath: /usr/share/software-center/software-center
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64
> (20110705.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/software-center
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/bin/software-center']
> SourcePackage: software-center
> Title: software-center crashed with AttributeError in __getattr__():
> 'Symbol' object has no attribute 'MODIFY_EVENT'
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/software-center/+bug/807282/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~zeitgeist
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~zeitgeist
> More help : https://help.launchpad.net/ListHelp
>

Gary Lasker (gary-lasker) wrote :

Software Center version 4.1.9 has been released and will prevent this crash in Software Center itself, pending the real fix at the library level. Thanks all!

software-center (4.1.9) oneiric; urgency=low

  [ Michael Vogt ]
  * data/ui/*.ui:
    - move into data/ui/gtk preparing the gtk3 merge
  * utils/piston-helpers/*.py:
    - return exitcode 1 on expections
  * softwarecenter/backend/scagent.py:
    - properly copy when building the command

  [ Gary Lasker ]
  * merge lp:~evfool/software-center/nonetworkfixes to fix menu
    item network state bugs, many thanks to Robert Roth
    (LP: #802919, LP: #802920)
  * softwarecenter/ui/gtk/appview.py:
    - fix crash on a network change event (LP: #804414)
  * softwarecenter/ui/gtk/appdetailsview_gtk.py:
    - gracefully handle AttributeError from zeitgeist pending
      fix in zeitgeist itself, fixes crasher (LP: #807282)
  * softwarecenter/ui/gtk/appdetailsview_gtk.py,
    softwarecenter/utils.py:
    - fix crash when searching gmenu paths (LP: #793024)

  [ Aaron Peachey ]
  * softwarecenter/backend/reviews.py,
    softwarecenter/backend/spawn_helper.py:
    - correct modify/delete UI callback behaviour with
      new spawn helper and pagination code (LP: #807010)
    - fix submit_usefulness and report_abuse callbacks
      to work with the new spawn_helper and pagination code

 -- Michael Vogt <email address hidden> Wed, 13 Jul 2011 16:11:35 +0200

Changed in software-center:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.