Fresh install of Xubuntu 11.10 misses gvfs-backends package

Bug #878682 reported by Ilya Almametov on 2011-10-20
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xubuntu-meta (Ubuntu)
Medium
Lionel Le Folgoc
Oneiric
High
Lionel Le Folgoc
Precise
Medium
Lionel Le Folgoc

Bug Description

After I made a clean installation of Xubuntu 11.10 I noticed that there are no "Network" icon in Thunar, and it is impossible to mount remote file systems via Gigolo. I found out that this is because the package gvfs-backends was missing. After manual installation of that package everything works fine.

Step to reproduce:
1. Make clean install of Xubuntu 11.10
2. Open Thunar - there are no "Network" icon. Moreover, if you type in address bar something like smb:// it immediately shows ''no entry sign" icon even before you type an IP address there.
3. Open Gigolo an try to connect to network share. There is only "Custom location" option. If you type in URI field say smb://10.0.0.110 (of course that is real working IP) you get error message "Connecting to "smb://10.0.0.110/" failed. Location is not mountable".
4. After installing gvfs-backends package everything works as expected.

Ubuntu release:
lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunar 1.2.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Thu Oct 20 10:01:23 2011
ExecutablePath: /usr/bin/Thunar
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)
XsessionErrors:
 (xfce4-indicator-plugin:1779): Gtk-CRITICAL **: IA__gtk_widget_set_name: assertion `GTK_IS_WIDGET (widget)' failed
 (xfce4-indicator-plugin:1779): libindicator-WARNING **: IndicatorObject class does not have an accessible description.
 (xfce4-indicator-plugin:1779): libindicator-WARNING **: IndicatorObject class does not have an accessible description.
 (xfce4-indicator-plugin:1779): libxfce4panel-CRITICAL **: IA__xfce_panel_plugin_add_action_widget: assertion `GTK_IS_WIDGET (widget)' failed
 (xfce4-indicator-plugin:1779): Gtk-CRITICAL **: IA__gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)' failed

Ilya Almametov (ilya-almametov) wrote :
affects: ubuntu → thunar (Ubuntu)
affects: thunar (Ubuntu) → xubuntu-meta (Ubuntu)
Changed in xubuntu-meta (Ubuntu):
status: New → Triaged
importance: Undecided → High
Lionel Le Folgoc (mrpouit) wrote :

I fixed the seeds for precise (I haven't regenerated xubuntu-meta though). Also, we might want to fix xubuntu-desktop for oneiric too.

Changed in xubuntu-meta (Ubuntu Precise):
importance: High → Medium
status: Triaged → Fix Committed
Changed in xubuntu-meta (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
Ilya Almametov (ilya-almametov) wrote :

I think It should be fixed in Oneiric as well because in corporate environment it is very common that people needs to connect to remote shares, e.g. Windows. Although workaround is very simple.

Changed in xubuntu-meta (Ubuntu Precise):
assignee: nobody → Lionel Le Folgoc (mrpouit)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.139

---------------
xubuntu-meta (2.139) precise; urgency=low

  * update.cfg: refreshed for precise.
  * Refreshed dependencies
  * Added gvfs-backends to desktop-recommends lp: #878682
 -- Lionel Le Folgoc <email address hidden> Sun, 30 Oct 2011 19:24:12 +0100

Changed in xubuntu-meta (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in xubuntu-meta (Ubuntu Oneiric):
assignee: nobody → Lionel Le Folgoc (mrpouit)
Lionel Le Folgoc (mrpouit) wrote :

I uploaded a fixed xubuntu-meta to oneiric-proposed, it's waiting for approval.

Hello dicka, or anyone else affected,

Accepted xubuntu-meta into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xubuntu-meta (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Ilya Almametov (ilya-almametov) wrote :

I made fresh installation of Xubuntu on virtual machine. After enabling of proposed updates and updating the system the gvfs-backends came as a dependency. So I can confirm that now everything works as expected.

Martin Pitt (pitti) on 2011-12-18
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.138.1

---------------
xubuntu-meta (2.138.1) oneiric-proposed; urgency=low

  * Added gvfs-backends to desktop-recommends (fix lack of networking support
    in Thunar, lp: #878682).
 -- Lionel Le Folgoc <email address hidden> Sun, 11 Dec 2011 12:04:19 +0100

Changed in xubuntu-meta (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers